Spyware, Viruses, & Security forum

General discussion

e:\$Mft windows -delayed write failed . error:disk read erro

by auto78900 / February 24, 2009 3:50 PM PST

e:\$Mft windows -delayed write failed

error:disk read error - read fails, the system cannot find the file specified.
these are the error messages that come up when I run my external hdd. What is the possibility that it is caused by a virus called minesweeper. My anti virus can not detect it. Please help.

Discussion is locked
You are posting a reply to: e:\$Mft windows -delayed write failed . error:disk read erro
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: e:\$Mft windows -delayed write failed . error:disk read erro
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Why do you thing you have such a virus?
by Kees Bakker / February 24, 2009 4:23 PM PST

- If it's on your machine, try it on another machine.
- If it's on the external disk, use AUTORUN EATER (free download) to disable autoruns. It shouldn't be activated then and you should be able to access the disk without errors.

But it sounds like a hardware issue.


Collapse -
autorun eater
by auto78900 / February 25, 2009 11:48 AM PST


I use public pcs and have 2 pcs at home. This is because I do not have the internet at home.
Is there another version of "autorun eater" where u do not need administrative privledges ?

Collapse -
I tried Autorun Remover
by auto78900 / February 25, 2009 12:04 PM PST

I tried Autorun Remover and does not need admin priv. but what is happening is , when I click search for autorun ,it finds it and asks to
re-scan, I press that and it keeps going in circles. What now ?

Collapse -
That would tend to indicate a problem ...
by Edward ODaniel / February 25, 2009 2:33 AM PST

with the Master File Table and you would be well advised to open a command prompt and run the command CHKDSK /F /R to fix/repair the problem if possible.

Unlike FAT, NTFS can store an entire file right in the MFT rather than just pointing to it depending on the file's size.

Collapse -
did chkdsk /f /r
by auto78900 / February 25, 2009 10:58 AM PST

Message came up "cannot Lock current drive because the volume is in use by another process. Dismount first. so I dismounted it and it did the
chkdsk /f /r. After I finished I went back to the other pc I was using.
And then Later I got that message again "error:disk read error".

Collapse -
If chkdsk didn't fix the problem ...
by Edward ODaniel / February 26, 2009 1:41 AM PST
In reply to: did chkdsk /f /r

you need now to take a look on the drive manufacturer's web site for their diagnostic software and run it on the drive as it is possible that the drive is damaged.

If you can't locate the diagnostic software on your drive manufacturer's site you can try the hitachi universal Drive Fitness Test and if you do this I would recommend the CD image rather than the floppy disk AND I suggest you also download the user manual for it. Most all of these drive diagnostics DO NOT WORK on USB drives

Collapse -
tried diagnostics
by auto78900 / February 26, 2009 3:21 PM PST
Collapse -
A memory address ...
by Kees Bakker / February 26, 2009 3:25 PM PST
In reply to: tried diagnostics

is in the RAM. A hard disk error is on the hard disk.

If chkdsk finds an irrecoverable error, it's time for a new disk.


Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.