PC Hardware forum

General discussion

DVD RW drive fails to eject and other problems

by canearn1974 / February 2, 2009 12:47 PM PST

The DVD-RW drive of my HP Pavilion dv1603tn most of the time fails to eject when the eject button is pressed or the eject function is selected from the right button command. It takes more than 1 try to have it eject out with the disk or open even without any disks loaded in it.

At times it suddenly opens even if there was no manipulation done on eject button or any function.

Another problem noticed is that it fails to read DVD-R as it was used to, I ran a CHKSDSK as suggested by HP helpdesk but it does not show any problem. The drive's hardware name is HL-DT-ST DVDRAM GSA-4084N.

Please give me suggestions on the solution to these problems.

Discussion is locked
You are posting a reply to: DVD RW drive fails to eject and other problems
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: DVD RW drive fails to eject and other problems
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Non eject
by Phil Crase / February 2, 2009 10:46 PM PST

Does it eject from the drive? Have you tried going to MY COMPUTER, locating the designated drive, doing a RIGHT click and trying to eject from there? If it doesn't eject from that location, it could be a couple of things, software driver needs updating but it could just be a tired drive, in which case, change it out.

Collapse -
Non eject
by canearn1974 / February 5, 2009 2:23 PM PST
In reply to: Non eject

Thanks for the feedback. I have done using MY COMPUTER, right clicked and used the eject function. It does not work on the first try and needs more tries before responding.

Also, another problem observed is that it opens even if it is not ejected by manual button or by right clicking on the eject function from MY COMPUTER.

Maybe, you are right that this drive is tired after 2 years of use.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

Does BMW or Volvo do it best?

Pint-size luxury and funky style

Shopping for a new car this weekend? See how the BMW X2 stacks up against the Volvo XC40 in our side-by-side comparison.