Computer Help forum

General discussion

DVD Playing Problem - Help Please

by -jannica- / March 16, 2005 1:24 AM PST

Hi, I am new to this forum and was wondering if somebody could help suggest some solutions to my problem.

I have recently been unable to play any DVD's on my computer (windows XP). When I insert the dvd into the drive, the light turns on, and then nothing happens. It's like it's trying to read the DVD, but then a message comes up saying "Please insert DVD into D:" I've tried using different software players and have downloaded all necessary updates on my computer.

Where it gets even more frustrating is that I CAN play CD's and video games that are on disc from my D: drive with no problem.

Any help for me would be really really appreciated!
Thanks : )

Discussion is locked
You are posting a reply to: DVD Playing Problem - Help Please
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: DVD Playing Problem - Help Please
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
My first test is...
by R. Proffitt Forum moderator / March 16, 2005 1:34 AM PST

To see if the hardware works. I use GEEXBOX from google.com and with this 6.5 Megabyte bootable CD I can test to see if the hardware is capable of DVD playback...

Do that test first.

Bob

Collapse -
thanks bob
by -jannica- / March 16, 2005 2:34 AM PST
In reply to: My first test is...

Thank you Bob! I Will give it a shot!

Collapse -
same problem
by Willow7882 / March 16, 2005 6:53 AM PST

I'm also having the exact same problem with my DVD's on my computer, and I also have Windows XP. If you could, please tell me how the GEEXBOX worked out for you. Thanks.

Collapse -
May want to look at this thread while you wait......
by Jwd1savh / March 16, 2005 10:05 AM PST
In reply to: same problem
Collapse -
Geexbox solution?
by -jannica- / March 16, 2005 1:11 PM PST
In reply to: same problem

Unless I downladed the wrong thing, GEEXBOX didn't do anything for my problem. Will let you know how when I find out though..thx ; )

Collapse -
If GEEXBOX doesn't play DVDs, then you found your issue.
by R. Proffitt Forum moderator / March 16, 2005 8:44 PM PST
In reply to: Geexbox solution?

GEEXBOX is a standalone boot and play DVD solution.

If it doesn't play DVDs on your hardware, then it's too likely your hardware is in need of repair.

Bob

Collapse -
after installing
by Oil_Tan / March 16, 2005 7:48 AM PST

bit torrent today. Ulead DVD player had to be directed to the drive the disc was in. Looking in wrong drive apparently.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?