Question

Duplicate HDD Partition?

Hello, I have a 3tb hdd and for some reason after a new restore, it created a 746.5 gb secondary partition with the same name "Drive 0 Unallocated Space". Both my main hdd and this one have the same name, and I can't delete either of them. Can someone help me with this?

Discussion is locked
Follow
Reply to: Duplicate HDD Partition?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Duplicate HDD Partition?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
I've seen this happen

It was caused by a few things. Remember I've seen a lot of PCs over the years so here goes. First it happens with dated BIOS and OSes. Next I've seen it when the owner used other than the OS to partition and a limit was hit. Or tried FAT32 instead of NTFS.

Tell more.

- Collapse -
Reply

Well the computer is pretty new, and the first time I did it it had the full 3tb. Virus completely took over my computer which forced me into reinstalling windows 10 which I think didn't exactly delete what I had before. I believed it did at the time, but I don't think it did. So now I have only 2tb of that 3tb on a regular HDD, and the rest is unallocated space, not associated to any drive. It should be part of the 3tb hdd since it is a 3tb hdd, but yeah. Disk management won't allow me to do anything with it nor will disk recovery/removal programs. On disk manager it shows that its part of C, but completely unallocated. I can't do anything on it except attempt to uninstall but it forces a restart which does nothing. No other options available.

- Collapse -
Note

I should try to specify that this unallocated space is already a part of C://, and not a separate partition. Pretty much every google search I've come across talks about unallocated space being its own partition which is easily merged. But this one falls under the category of C://, which gives me no options.

- Collapse -
Space

Do you have a windows install disc/stick or perhaps factory restore media?
If so grab a copy of partition wizard 9.1 and put it on a disc.
Boot it up and delete all the partitions on the disk.
Install windows from the disc/stick/media.

Before you start this copy out 'your stuff'.

- Collapse -
Reply (2)

I have a windows 10 disc, but it doesn't remove what was previously stored I don't think. I tried a factory restore, but for some reason it cancelled on me saying it was unable to successfully delete all of my files. When I'm in Win10 installation, I do choose to start new and the 745gb partition is the same as the 2tb partition. Same name, different space. Unable to delete the partition or do anything with it other than "New", which sets it up to be in use.

That gives me an idea, actually. Perhaps if I set it up as a new partition I'll be able to remove it or merge it with C://

- Collapse -
Space

Did you miss that part about partition wizard?

- Collapse -
It's a clone

See if the UUID on both drives is also the same. If so, you can use a LIVE version of some Linux distro, or the stand alone GParted program to change the UUID of one partition, and then if it retains the same name, windows should still see them as different drives.

For instance, in Linux I can run blkid and see the UUID of each partition.

blkid
/dev/sda1: LABEL="FAT32-1" UUID="CB87-D98F" TYPE="vfat"
/dev/sda2: LABEL="BOOT" UUID="685277b7-4331-4288-91c3-4b2dc1c91d3e" TYPE="ext2"
/dev/sda3: LABEL="Kubuntu" UUID="d37aed66-75aa-4da2-8aae-3ce95aeab43a" TYPE="ext4"
/dev/sda5: UUID="98F1-105D" TYPE="vfat"
/dev/sda6: UUID="a350d050-f0fc-44f8-8a15-85b80b64eb3b" TYPE="swap"
/dev/sda7: LABEL="MINT-16" UUID="14f23016-8f05-4bdc-be9f-a3465bfea1da" TYPE="ext4"


The long ones are Linux versions and the short ones are Windows partitions. If I had a clone partition, I could use GParted to issue a new UUID to one of them, thereby solving the problem.

Perhaps something similar can be done using Windows, such as the diskpart program.

That UNIQUEID section looks promising.

CNET Forums