Thank you for being a valued part of the CNET community. As of December 1, 2020, the forums are in read-only format. In early 2021, CNET Forums will no longer be available. We are grateful for the participation and advice you have provided to one another over the years.

Thanks,

CNET Support

General discussion

dual monitors, second monitor won't wake up after sleep

Oct 15, 2008 10:39AM PDT

I just got a second monitor, plug and play worked and was fine even though my main (laptop) was 1280 x 800 and the second screen is 1024 x 768. It went to sleep. I woke up my laptop, and both screens showed the waking up loading windows, then the second screen went black. Before, it still let me use the second screen even though I couldn't see anything, now I can't extend to the second screen through display settings. If I try now, the laptop seems to get set to the lowest display settings possible, and the second screen stays dark. Help?

Discussion is locked

- Collapse -
Just sharing
Oct 15, 2008 10:41AM PDT

When this happens to me, it's always the drivers. Since it's a laptop your choices are limited but make sure you make a warranty claim if they don't support it by some driver on their web site.

- Collapse -
works for a while
Oct 16, 2008 12:47AM PDT

i just restarted my computer with the monitor unplugged, plugged it back in after it was started, and now the second monitor works fine again. But I feel like as soon as it falls asleep and I try to wake it up, it's going to not want to wake up again. So it's not that it's not supported I think, since it does work, but it doesn't wake up after falling asleep. I've seen other forum posts like this but there weren't answers to those either.

- Collapse -
Then make it a warranty issue.
Oct 16, 2008 1:25AM PDT

Laptops (which you didn't give make or model) are proprietary. You can make this a warranty claim now.

I have no answers since there is so little to work with in your post. Thus I only can share what it was for me, most of the time.
Bob

- Collapse -
thanks for your help
Oct 16, 2008 2:49AM PDT

I have a gateway MT6840, and it says the display adapter is 945gm express chipset family. When the laptop went to sleep, the second monitor could turn on again, but when it hibernated, the second monitor stayed off, but was still there, ie I could move my mouse onto it, as well as other windows. Thanks for your help. Also, I'm out of warranty since I got it over a year ago.

- Collapse -
So what date driver are you using.
Oct 16, 2008 3:13AM PDT

I'm always wondering why people leave out the make, model in posts. Why is that.

-> But tell me what date driver you are using. I see the drivers at http://www.intel.com/support/chipsets/sb/CS-022034.htm and the date looks to be 2/15/2008.

Again, for completeness I'll install the latest chipset and graphics drivers when I see this issue. Your posts never revealed if you did that.
Bob

- Collapse -
945gm chipset family
Oct 16, 2008 4:25AM PDT

So I tried downloading the driver update (from 6/28/200Cool from the intel site for my computer, Windows Vista Home Premium 32bit edition. The first page of the installer said the drivers the installer updated, and the 945GM Express Chipset family was included on the list. Then setup quits saying "The driver being installed is not validated for this computer. Please obtain the appropriate driver from the computer's manufacturer." Hm... But it says my driver is from 12/12/2006, and when I try to update it from the device manager and tell it to search the internet to find the upgrade, it says that I already have the most up to date version.

- Collapse -
That's it.
Oct 16, 2008 5:42AM PDT

You have a very outdated driver. 12/12/2006 predates Vista's release. I see we've found the most likely cause.

In closing, UAC can block drivers. I know to shut that down during driver installs. Also I didn't see Vista mentioned till this last post.

Since you are making incomplete posts, it's unlikely that anyone can guess what the issue is but given that date I'd say you found it.
Bob

- Collapse -
Yeah, but
Oct 16, 2008 6:01AM PDT

I have UAC completely disabled because it's annoying, and when I try to install the update it gives the error message I copied into my last response. Any insight on why that would happen? Since I downloaded the 945GM express chipset update, and that's the chipset I have, I don't know why it's giving me that error message. But I agree that's probably it. Thanks for the help again

- Collapse -
I am taking your word for it....
Oct 16, 2008 6:46AM PDT

That your BIOS is current and you have the i945gm VIDEO. I have not checked your work here. There's a reason I haven't and it's because the details are being slowed given out. When you post, everytime you post there is a note asking you to give out details. Without such I am left to wait for the details or just give general responses.

You found the most likely cause of the issue.
Bob

- Collapse -
Let's check those specs.
Oct 16, 2008 7:00AM PDT
- Collapse -
it came with vista
Oct 16, 2008 7:58AM PDT

I took a screen shot of the device manager: http://i469.photobucket.com/albums/rr58/theblackred/Capture.jpg

I bought this laptop from the gateway site last summer, August 2007, it came with vista. It had a harddrive problem so they sent me another with factory defaults this past winter, 1/2008, so it's even more strange the driver is from 2006. I googled my installation error "The driver being installed is not validated for this computer" and it seems like other people with gateway laptops have this error.

- Collapse -
intel not gateway
Oct 16, 2008 8:07AM PDT

In my previous post I meant it seemed like a lot of people who were trying to download intel driver updates had the same error I'm getting

- Collapse -
I can see why.
Oct 16, 2008 10:27AM PDT

I see no less than FOUR possible drivers. Using the i945gm should have failed.

Again, you have a warranty issue. It's been defective since day one it seems.
Bob

- Collapse -
Lol
Oct 16, 2008 11:20AM PDT

Oh lol. Found the solution on some european world of warcraft forum.

Apparently there's some glitch with the .exe file intel's update uses that makes vista unhappy. So I had to download the zip file for the 945gm driver, and then tell the driver to update from a disk, but actually find the place where i extracted the zip file to and say that's where it should update from. Specifically a .inf file in the extracted updater. Tricky.

So yeah nothing wrong with driver or hardware or anything. Just vista + intel = stupid. The forum was http://forums.wow-europe.com/thread.html;jsessionid=88F7ED8ED983C57E193885AE8CD10C02.app03_04?topicId=254595484&sid=1 if anyone wants to read up on it more.

So yay happy ending. My video driver is now up-to-date. Thanks for your effort and patience Rob.

- Collapse -
Sorry. Something I haven't run into.
Oct 16, 2008 11:03PM PDT

There are some million machines out there. I know the issue, the usual cure and have never had to go to that extreme (yet.)

Thanks for keeping at it and sharing what you found. I value such feedback since "now I know" and will do better next time around thanks to you!
Bob

- Collapse -
A software called NoSleep
Sep 15, 2016 6:22AM PDT