Question

Driver Issues with new computer

Mar 8, 2018 5:52AM PST

Hi There,

I am having some issues with my PC since recently upgrading the HD, Motherboard, CPU and Ram.

I kept my case, PSU, and GPU, 1 HD (not plugged in yet) and Blu Ray Drive from my old rig.

System Specifications are as followed;

OS - Windows 7 Home Premium 64 Bit
Motherboard - Gigabyte GA-Z170X - Ultra Gaming
CPU - Intel(R) Core(TM) i7-7700K CPU @ 4.20GHz
HD - Samsung SSD 850 EVO
GPU - AMD Radeon R9 290
RAM - 2X4GB of Corsair Vengence LPX DDR4 Ram 2666MHz
PSU - Corsair HX1000W

I installed the drivers on the disk which came with the motherboard, and certified my windows with the CD in the drive so should have received all necessary windows updates.

Basically the issues I'm having are driver based by the looks of things.

1. Display Driver Software "RadeonSettings" no working properly.

After installing my AMD Display Drivers for my R9 290 for which installation was successful when I try to run Radeon Settings I get this error message

"RadeonSetting.exe - System Error

The program can't start because api-ms-win-crt-runtime--|1-1-0.dll is missing from your computer. Try reinstalling the program to fix this problem."

I have attempted to uninstall, use AMD's removal program to completely remove the drivers, amdcleanuputility.exe was run and I restarted the computer and then re installed the drivers and the same issue is still present...

Can you just download this .dll file and drop it into the correct AMD folder to solve this?

2. Intel RST Service Not Running

I noticed recently an icon in my tray which is telling me "Intel RST Service Not Running"

I went to Control Panel - Administrative Tools - Services and found the Intel Rapid Storage Technology service and right clicked it and selected start which it appears to do as Services is now showing Status Started for Intel RST, however when I refresh services it goes back to not being started...

I have since reverted back to an older version of Intel RST and still this same issue is occuring, is there any known way to fix this? and is RST even necessary? and could it be related to the display driver issue?

If you have any information on this, I would be extremely grateful as so far googling my issues hasn't given me an answer to solving it.

Many Thanks in advance.

Cameron

Discussion is locked

Follow
Reply to: Driver Issues with new computer
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Driver Issues with new computer
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Are you using an old CRT monitor?
Mar 8, 2018 5:56AM PST
"The program can't start because api-ms-win-crt-runtime--|1-1-0.dll is missing from your computer. "

Did you install the Catalyst package too?
- Collapse -
Nope
Mar 9, 2018 1:36AM PST

Hi there,

I have two Benq Senseye 3 LCD monitors but only one is plugged in until I get my display drivers sorted.

I have tried both the full install driver and the simple version also from the AMD website, if you select

Desktop Graphics
Radeon R9 Series
R9 290

Then it gives you the options to install the full driver pack or simple and I have tried both neither reaping the results that I have wanted sadly...

- Collapse -
Answer
Re: dll
Mar 9, 2018 2:57AM PST
- Collapse -
LOL, have to keep that one in mine
Mar 9, 2018 1:13PM PST

It sure seemed to fit the situation. Wink

- Collapse -
Answer
Finally figured out what was happening...
Mar 9, 2018 5:03AM PST

Hi,

So I've figured out what the issue was.

Window tried to install Service Pack 1 the first time around when I authenticated my copy of windows 7 home premium, but the install log showed that it had actually failed, which meant I was missing a ton of Windows/System32 .dll files which was preventing things like my graphics card drivers and the Intel RST Functions.

All seems to be working as it should do now.

Thank you to anyone that gave me suggestions on how to solve this.

Have a nice day.

Thanks
Cameron

- Collapse -
Re: figured out
Mar 9, 2018 1:30PM PST

Thanks for telling.
Since you wrote " certified my windows with the CD in the drive so should have received all necessary windows updates." nobody could have guessed this.

Yes, SP1 is necessary nowadays. And it's best to not have it done by Windows update, but downloading it yourself. In fact, after downloading SP1, it's easiest to download the convenience rollup also.
If you store the 2 downloaded files in your backup (just like all other programs you installed yourself) you're ready for the next time you want to do a clean install of Windows 7/.

CNET Forums

Forum Info