Computer Help forum

General discussion

Drive letter no longer available

by ZekeEvans / February 6, 2004 6:23 AM PST

I have XP Pro, Athlon 2500+, 1024 MB RAM. I've had my CD-RW and DVD-ROM (everything on my computer is less than three months old) work fine until yesterday. Then the associated drive letters no longer showed up in explorer. I restarted, to have it freeze on the "Detecting IDE drives...". I restarted again and went into the BIOS, noting that now the CD-RW shows up. Now the CD-RW (on the secondary Master) is showing up and is fully functional, but my DVD does not show up, nor does it respond when I try to open the drive.

Any suggestions?

Discussion is locked
You are posting a reply to: Drive letter no longer available
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Drive letter no longer available
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re:Drive letter no longer available
by Edward ODaniel / February 6, 2004 6:33 AM PST

With the computer shut off (disconnect) the power and data cables from the problematic DVD drive then reconnect them (making sure the connection is snug). Do the same to the other end of the data cable where it plugs into the IDE connector.

Reconnect power and reboot. If drive is seen no problem. If not seen try the above with a new 80 wire IDE cable (they can turn bad).

If still no joy, time to check into the warranty on the drive (three month old system should still be under warranty).

Collapse -
Re:Re:Drive letter no longer available
by ZekeEvans / February 6, 2004 8:44 AM PST

Ok, I'll try reconnecting the cables, but I don't know how they could have been jarred loose. My computer's been sitting here fine and dandy, nice and still.

What about a new IDE cable? I bought some rounded IDE cables, I hope they're not the problem.

Collapse -
Re:Re:Drive letter no longer available
by ZekeEvans / February 6, 2004 10:02 AM PST

Nope. It worked for a while after rebooting, but then randomly disappeared ALONG with the CDRW again. After restarting, the CDRW came back, but again there's no sign of the DVD drive. I've done a system restore to two days ago, when I was gleefully watching a movie to no avail. No viruses, and there's no major driver updates.

There's gotta be some solution.

Collapse -
The fact that it "worked" for a while is interesting...
by Edward ODaniel / February 7, 2004 4:49 AM PST

as well as your mention of "bought some rounded cables".

All cables are not created equal and many of the "rounded cables" (and even some flat ones) exceed the IDE specifications in length.

If you have available or can get a new 80 conductor cable give it a try. The wires in the cable are pretty small and actually fairly fragile and can be damaged fairly easily without any apparent/visible damage.

Collapse -
Re:The fact that it
by ZekeEvans / February 7, 2004 9:12 AM PST

Here's what fiddling around taught me:
First, I changed the primary and secondary cables, to make sure it wasn't just one faulty cable. When I say "hangs", that means it hangs at "Detecting IDE drives" and I cannot access the BIOS.

CDRW Master DVD Slave - CDRW ok, DVD not detected
CDRW Master (none) Slave - Nothing detected
(none) Master DVD Slave - hangs

DVD Master CDRW Slave - hangs
(none) Master CDRW Slave - hangs
DVD Master (none) Slave - nothing detected

(none) Master (none) Slave - nothing detected (obviously)

And before anyone asks, I checked the jumper settings and changed them accordingly during these tests. I don't think I could be more thorough unless I throw in the Hard Drive and Primary channel as well.

If anyone can figure out what the problem is from all these different setups, I'd love to know.

Collapse -
Re:Re:The fact that it
by Edward ODaniel / February 7, 2004 10:54 AM PST
In reply to: Re:The fact that it

Try one more thing before facing the idea that the DVD itself has problems.

Try putting the DVD on the primary controller as a slave to the hard drive.

That would be:
Primary IDE HD == Master, DVD == slave
Secondary IDE CD-RW == Master

Make sure that in your BIOS you show no secondary device on the secondary IDE when set up this way.

If still no joy, time to contact whoever built it for a new DVD (although if you know someone else who might let you temporarily install he DVD on their computer it might rule out the DVD being bad and this would point to a possible problem with the motherboard connector.

Collapse -
Re:Drive letter no longer available
by Cursorcowboy / February 6, 2004 10:55 PM PST

1. (Q310123) lists 33 error codes that may be reported by Device Manager and provides possible resolutions. A TechNet article covers up to 49.

2. Use the Windows Drivers and Network Adapters troubleshooter.

3. The article [Q321641] describes how you can troubleshoot issues reading CD-ROM or DVD-ROM optical discs and discusses how to troubleshoot common issues with CD-R and CD-RW devices.

4. The article [Q824894] describes issues that may occur if your CD-ROM or DVD drive is not configured correctly, the program CD-ROM or DVD is damaged or dirty, or the Microsoft Data Access Components (MDAC) installation is damaged, and suggest troubleshooting tips which may assist.

Collapse -
Re:Drive letter no longer available
by jaybee / February 17, 2004 10:33 AM PST

Hi Zeke:

This kind of a problem can sometimes be resolved by System Restore. Did you try it. I find that System Restore puts everything back the way it was a few days ago and/or a week ago. If you have a Compac or HP computer this will work for you. It did for me.

Good Luck!

Jaybee
email:jbog1038@yahoo.com

Collapse -
JAYBEE.
by Cursorcowboy / February 17, 2004 8:25 PM PST

I've noticed you're replying to messages a week to 10-days old which should be consider closed/abandoned. When you do this, such messages pop back to the top of the tree and appear to everybody else as new and requiring assistance until we open them and see the status. Please always note what the original date is of a message before replying. In addition, your comments have in most instances already been covered.

Your assistance in this matter will help others so that we are not wasting precious time helping someone who has just asked a question instead of going over old/abandoned stuff unnecessary.

Thank you.

Collapse -
Re:JAYBEE.
by jaybee / February 18, 2004 7:56 AM PST
In reply to: JAYBEE.

To: Cursorcowboy

Thanks for advice re. assistance in helping others in the past.

I wasn't fully aware of the situation..but it pays to listen to other people who can help you when you are doing something that is quite unnecessary.

Your input on wasting precious time has been noted.

Jaybee

Popular Forums
icon
Computer Help 51,912 discussions
icon
Computer Newbies 10,498 discussions
icon
Laptops 20,411 discussions
icon
Security 30,882 discussions
icon
TVs & Home Theaters 21,253 discussions
icon
Windows 10 1,672 discussions
icon
Phones 16,494 discussions
icon
Windows 7 7,855 discussions
icon
Networking & Wireless 15,504 discussions

REVIEW

The most beautiful phone ever has one wildly annoying issue

The Samsung Galaxy S8's fast speeds and fantastic curved screen make it a top phone for 2017, but the annoying fingerprint reader could sour your experience.