That's an interesting one. My first thought is that there's a double registry entry for system doctor. It could also be the program itself is corrupted somehow. Odd, have you tried disabling the system doctor on startup and see if the ghost window still appears? Try that, if they both don't appear after it's disabled, try enabling it again and see what happens. If the problem reoccurs, start>run type in msconfig and press enter. The system configuration utility window should come up. Under the startup tab, ensure there isn't a double entry for the norton system doctor. Let me know what you find. Good luck.