Networking & Wireless forum


Double Router OpenVpn Port Forwarding

Here Is my Scenario :
ROUTER1------------ -IS A ROUTER/MODEM combo. and connects to internet through Isp phone line.
Does not support dd-wrt firmware, so the need for second router

ROUTER2..............just router only, connects to the wan port of Router1 to get to internet, Flashed with dd-wrt for vpn client support

ROUTER_1 _INTERNAL IP:, DHCP is enabled.


ROUTER_2 _EXTERNAL IP:, GATEWAY:, DNS:dns: from vpn provider.

PC1 _INTERNAL IP:, GATEWAY:, DNS:dns: from vpn provider.
PC2 _INTERNAL IP:, GATEWAY:, DNS:dns: from vpn provider.


VPN (openvpn client) is INSTALLED ON Router2 through commandline.

Now all PC1 & PC2 can now connect to wireless ssid of Router2 and vpn works on them all

Everything works well without vpn , but once i turn on vpn I loose access to the port.

The vpn provider said the problem has nothing to do with their service.
I did as adviced on here
and it still failed.
here is what i executed on the dd-wrt console for PC1:
iptables -t nat -I PREROUTING -i ath0 -p tcp --dport 2300 -j DNAT --to-destination
iptables -I FORWARD -p tcp -d --dport 2300 -j ACCEPT

and I can't still see the service.
Please any help to make it work would be appreciated.

Discussion is locked
You are posting a reply to: Double Router OpenVpn Port Forwarding
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Double Router OpenVpn Port Forwarding
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
I read this and see an issue.

In reply to: Double Router OpenVpn Port Forwarding

A VPN is curently defined (and this is the simple definition) as if you were plugged into that other network. Your other connections SHALL fail because of how VPNs work.

I run into folk all the time that want a broken VPN that allows local network connections and the VPN.

If you ever see this, that's not a VPN.

Collapse -
Then what next

In reply to: I read this and see an issue.

Then do you have any idea of what I should be doing ? Because from the article in that link , it worked for the user, seem i am getting something wrong .

Collapse -
I'm just a programmer that

In reply to: Then what next

Wrote router code over the years. To me a VPN that does something other than a VPN is not a VPN. So in my view this would break what a VPN does and as such should fail.

If you feel that article is good, post there or email the author and contributors but here, I'm going with not expected to work.

Collapse -
Still on it

In reply to: I'm just a programmer that

The article is 2015, and no longer active. unlike in PIA vpn, you can forward a port on the vpn directly.. All I wanted was for the connection to outside to tunnel through the vpn. If the vpn does not have anything to do with my portforward , does it not mean that I can still bypass vpn to forward , since my service can't listen through the vpn?

Collapse -

In reply to: Still on it

Let's redo this. As you'll discover, double routers or two routers in a row does not find any support out there.

If you want to fix this, fix the reason you have two routers.

In the meantime I thought of one thing. Put the second router's IP into the DMZ entry of the first router. Not that it may help since two routers is one too many.

Collapse -
Did that Already

In reply to: Redo.

I already have that setup in router1. the initial reason for the introduction of the second router is; the first router does not support vpn client and the only way to extend the router1 for vpn client is to flash with custom firmware. Still first router is not supported by dd-wrt or any other open source firmware., so the need to introduce another router(router2). port forwarding works only when i disable the vpn on router2, but once i turn vpn on, it fails to work.

Collapse -
I find it odd....

In reply to: Did that Already

The statement about not supporting the vpn client. That is, my Windows running Opera's VPN is a CLIENT and the HOST is out there. I've yet to find a router this didn't work on.

Now if someone wanted to install a VPN CLIENT in the router, well that's a whole 'nuther kettle of fish.

Collapse -
Now a change of mind.

In reply to: I find it odd....

Now am wondering if i could do same thing with a hosted vps service , such that i setup my own vpn server and have multiple client behind my router connected to it. Then each client can forward port as they like ? Just wondering though. I really would prefer vpn client on router installation with forwarded port for each client with a static local ip.

Collapse -
Great way to immerse yourself in deep networking.

In reply to: Now a change of mind.

It's advanced so you'll love all the new stuff to learn. Most folk prefer simple.

Popular Forums

Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


This one tip will help you sleep better tonight

A few seconds are all you need to get a better night's rest.