Networking & Wireless forum


"DNS Error" in WIFI MODEM ROUTER Dlink 2750U

by darshan_jayco / October 21, 2012 5:20 PM PDT

I am using following hardware and connection:-
- Dlink 2750u (ADSL+ Modem and Wifi Router)
- Reliance Wired Broadband connection (DHCP Connection)
- I was using ITI Modem Router before which was working perfectly.
- Currently, Reliance Wired Internet is connected to Dlink 2750u via DSL link. Wifi Routing is done by the same device.
- For surfing the internet (from WIFI Laptop or Android mobile WIFI or LAN connected laptop), I get DNS error. I AM ABLE TO OPEN WEBSITES BY TYPING THEIR IP ADDRESS but NOT BY TYPING THEIR DOMAIN NAME. (This happens in both LAN as well as WIFI connections).

What configuration I need to check to resolve the same. I can post the techincal details of any required settings.


Discussion is locked
You are posting a reply to: "DNS Error" in WIFI MODEM ROUTER Dlink 2750U
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: "DNS Error" in WIFI MODEM ROUTER Dlink 2750U
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.

All Answers

Collapse -
Try manual configuration
by sunwatcher / October 21, 2012 11:36 PM PDT

Check the settings on your DLink to see if it is set to automatically obtain a DNS address. Normally this appears under the Status tab.

You can also manually input a DNS address of your choosing into either the DLink or your PC. I recommend configuring the network adapters (wired and wireless) on your PC manually.

As a suggestion, Google operates a DNS at and

Collapse -
Regarding configuration
by darshan_jayco / October 24, 2012 5:36 PM PDT

Thank you for your prompt reply.
The Adsl Modem is set to obtain DNS automatically. The connection has been setup manually only because Dlink does not have Reliance settings profile.
I have tried inputing Google DNS addresses manually but still the DNS error remains. In automatic mode Dlink Modem would get DNS as primary and as secondary DNS Servers. (As in normal Adsl modem we would get 4 different DNS servers). In laptop or mobile, settings are automatic and ip addresses, DNS servers, Gateways and all settings would be from
Any other thing I can try out.. ??

Collapse -
by bill012 / October 24, 2012 11:17 PM PDT

First change the dns in the end device manually to one of the google ones to makes sure it works that way. If not you need to be checking firewall settings.

Even if the router itself does not get a valid DNS from ISP you can still force it to tell the PC and other devices it serves to use the goodle ones via the DHCP options. Not sure why the default it to always ask the local router for DNS and then have it waste its cpu power asking the real DNS server rather than directly asking from the end device.

Collapse -
by darshan_jayco / October 31, 2012 11:31 PM PDT
In reply to: DNS.


I tried the option given by you. I manually entered google's dns servers in laptop network settings. All working till logged in Reliance. Unless logged in, google's dns server's cant be reached. Ultimately homepage of reliance cannot be opened ( from where we need to log in first in Reliance broadband.

For mobile devices, some do not permit manual dns settings.

Can you suggest me to do some settings in my dsl modem only so that in end devices the settings remain automatic ??


Collapse -
DNS Error" in WIFI MODEM ROUTER Dlink 2750U
by RCOM_Care / November 2, 2012 8:15 PM PDT

Dear Customer,

We regret the inconvenience caused to you. This is to inform you that your concern has been noted. Please provide us your contact details such as Full name, Subscriber ID, and the type of Inconvenience you are facing, so that we are able reach you. Our team is eager to help you.



Collapse -
by darshan_jayco / November 6, 2012 2:51 PM PST

Thank you for your concern. I have come to conclusion of my problem as under.

1. I only get one dns server in my Dlink 2750u wifi modem AS compared to modem provided by reliance in which i get 4 dns servers (I have two reliance broadband wired connections and a bsnl broadband)

2. I right now use the following method for using internet which is not the optimum.

3. I resolve reliance login page's dns address by using tools in dlink modem page ( Then I go to that page by typing dns address. I log into reliance. My laptop's network has been set to use google's dns servers for dns resolution so i can access the net.

4. BUT other devices (handhelds and mobile phones) which do NOT support manual dns with auto ip cannot browse the net.

RCom Care, I request you to provide me proper settings for my modem so that i get proper dns server addresses. Please provide me your official email id. I would send my details on that.


Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Meet the drop-resistant Moto Z2 Force

The Moto Z2 Force is really thin, with a fast processor and great battery life. It can survive drops without shattering.