The unsafe part is likely the choice of wifi encryption.

Change that router to its defaults and then enable WPA for the wifi.

That's about all I'd do here.
Bob