TVs & Home Theaters forum

General discussion

Denon Receiver Problem - Video but No Sound (AVR-S920W)

I own the Denon AVR-S920W AV receiver. I connected a Sony Blu Ray via HDMI cable to Input 3. Output from receiver to TV also with HDMI. Until yesterday, the connections were fine - I was able to watch Blu Rays and DVDs without problem. Today, I tried to play a Blu Ray disc and although I got a picture, there was no sound. Tried a DVD - same result. Played a cd, Apple TV, iPod and was able to get audio through the speakers, so those are hooked up properly. Played the Blu Ray directly into TV through the HDMI cable without a problem, so it's not the player, the cable, or the TV. The receiver "Mute" is off. "HDMI Audio Out" is set to "AMP" - when I changed it to TV, it passed the audio signal to the TV. I've read and reread the manual several times to no avail and before I spin my wheels with Denon customer support, I thought I'd try here. Thanks a lot

Post a reply
Discussion is locked
You are posting a reply to: Denon Receiver Problem - Video but No Sound (AVR-S920W)
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Denon Receiver Problem - Video but No Sound (AVR-S920W)
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
A few links.

In reply to: Denon Receiver Problem - Video but No Sound (AVR-S920W)

Collapse -
No audio

In reply to: A few links.

Thanks for your support, I think that it’s any configuration because there is no sound include in the headphone but video it’s ok!

Collapse -
So you didn't try settings?

In reply to: No audio

I've lost count of how many times it worked after changes. I fear you'll have to call them now.

Collapse -
Simple solution that works!

In reply to: Denon Receiver Problem - Video but No Sound (AVR-S920W)

I had basically the same issue and looked up possible cause. As it turns out many people have the same issue and it appears the fix is easy.
BLOW into the headphone jack or better yet blow compressed air into headphone jack...I tried it and it now works! I don't know why or how but it works!
I'm not kidding, sounds crazy right?
There's another blog about this on cnet that's where I found the solution.

This applies to Denon AVR X1000 and others too

Post was last edited on October 22, 2018 2:02 PM PDT

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

DEALS, DEALS, DEALS!

Best Black Friday Deals

CNET editors are busy culling the list and highlighting what we think are the best deals out there this holiday season.