Storage forum

Question

Denied access to external hard drive?

by fmitchelltx01 / May 20, 2014 10:42 AM PDT

For some reason I can't access the files on my WD Elements external Hard drive. Also, the drive is no longer showing up on my network. The external hard drive, a WD Elements WDBAAUDD0020HBK-01 is just out of warranty. It is plugged in to my desktop computer and is never moved from my desk here at home.

I receive an error message saying: You don't currently have permission to access this folder. Click continue to gain access to this folder. I click continue and I get another error message: you have been denied permission to access this folder. To gain access you will need to use the security tab. Security tab is in blue and I can click on. A new box opens that has 4 tabs to choose from. The one that is open when clicked on is Security. The tabs are are General, Sharing, Security, Customize. The open box says: You must have read permissions to view the properties of this object. Click Advanced to continue. I click Advanced a new box opens with three tabs, Permissions, Auditing, Effective Access. The open one, Permissions reads File Thank You_files ( this is one example. It does the same with any file on the hard drive) Below that it reads: Owner Unable to display current owner Change (highlighted in blue, I can click on. In the main part of the box, the message reads: You do not have permission to view this objects security properties, even as an administrative user. Below that it reads: To try taking ownership of the object, which includes permission to view its properties, click Change above. I click change and a new window opens: The box reads: Select User or Groups as the title at the very top of the open box. Inside the open box it reads: Select this object type: In the box below: User, Group, or Built-in security principal Object Types can be clicked on. If I click on Object Types, a window opens with Other objects, Built-In security principals, Groups, Users. All of the options are checked. Going back to the previous screen, Select User Or Groups, the second line down in the box reads From this location: DESKTOP next to this is a box with: locations, inside the box. The next line reads: Enter the object name to select (examples) examples is highlighted in blue. I can click on this or enter text in the box below. Advanced check names (inside a box I can click on) are at the bottom of the window.

How do I regain access to my files? All was okay and nothing has been changed on either my laptop or desktop. I tried to access files today and can't. I live alone and am the only user of either computer. I can't even turn on file history to save documents, etc from this date forward. As I say, the WD Elements does not even show up on my network anymore when using the laptop. It is plugged into my desktop computer. I run Windows 8.1 on both computers.

Please let me know what I need to do in order to gain access to my important files stored on this external hard drive. Obviously, I want to add files to it and access it from my laptop via the network.

Please respond ASAP.

Thank you!

Today, I received the following e-mail back from WD:

We truly apologize for the inconvenience, I will be more than glad to assist you with this issue.


See the instructions below to assign full permissions to the drive, also I attached some screenshots in case you may need better guidance. You can connect the drive to another computer, and follow the instructions below.

1. Right-click on the folder and select "Properties"
2. Click on "Edit"
3. Select "Add"
4. In the box type "Everyone" and select "OK"
5. Select the "Everyone" user from the list, check the "Full Control" option below and click on "Apply" and "OK"
6. On the next screen select the "Everyone" user and click on the "Advanced" button
7. Select the "Owner" tab and click on "Edit"
8. Click on "Other users or groups"
9. Type "Everyone" in the box and select "OK"
10. On the next screen click on "Apply" and "OK"

If you are unsuccessful after following the steps above, we recommend you to contact Microsoft Support for further assistance to assign the proper permissions to have access to the drive again.


Should you have any further questions, please reply to this email and we will be happy to assist you further.

Sincerely,

Western Digital Service and Support


I tried this solution and still can't access any of my files. I am still denied permission. Their WD fix did nothing. It is the same as it was. Do I just lose all of the saved data and buy another external hard drive?

Answer This Ask For Clarification
Discussion is locked
You are posting a reply to: Denied access to external hard drive?
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Denied access to external hard drive?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
still denied
by nakanti / February 25, 2016 7:44 PM PST

i can follow all of these steps up until adding full control. i type 'everyone' and select full control, but i get a popup saying, "An error occurred while applying security information to... (the name of the files i am trying to get into) Failed to enumerate objects in the container. Access is denied."

Collapse -
Try an Older OS
by PaulinSA / December 22, 2016 12:38 AM PST
In reply to: still denied

I had exactly the same problem on my WD passport. Interestingly when used with my TV, it was still able to read the file, but my laptop (Windows 10) could not. I followed the instructions sent above with the same result - not access, however when I tried the same on an older Windows 7 (that would never let me upgrade to Windows 10 because it was a Samsung but that's another story), presto I was able to type 'everyone' into the relevant box and after that I was able to read the file on my Windows 10 laptop (with admin privileges).

So in my case the answer was to change ownership on and older machine. Hope this helps!

Collapse -
Try Linux
by Dayle46 / April 23, 2017 3:45 AM PDT
In reply to: still denied

I have downloaded FREE Linux iso and installed on all old Windows XP laptops to get continued use out of hardware that is perfectly fine while XP os now totally unusable. Guess what, no Windows user security issues. I have recovered W10 system drives, both boot and data drives, that have been whacked by software updates, etc. by connecting them to a Linux system via usb in external drive hardware like Thermaltake. Transfer the data to the Linux drive and then wherever you like from there.

Collapse -
Clarification Request
Cannot change permissions to the folder
by Torresvila / September 3, 2016 4:50 AM PDT

Hello, I have tried the solution explained here, but I get a message saying that I cannot change the permissions to access the folder. How can I get around that?

Thanks

Collapse -
Clarification Request
Mine isn't working in only a few specific files
by Sam_Darley / December 18, 2017 10:49 AM PST

So I followed the instructions, I managed to gain access to most of my folders. There is one specific folder with more inside that I still can't access for some reason. I realize this may be more of a hypothetical situation that never happens, but I hope you do have an answer.

All Answers

Collapse -
Answer
At the top of this forum are ideas.
by R. Proffitt Forum moderator / May 20, 2014 10:54 AM PDT

The Lost and Found post covers the usual but you don't keep your files on one drive. That's too dangerous. One slip or failure and those files may cost thousands to replace.

I have no less than 3 external HDDs that are synced with my desktop plus some things in the cloud and on memory sticks.

Make your files "Hard To Kill".
Bob

Collapse -
Answer
Permissions
by sonicdrive / May 20, 2014 1:28 PM PDT

You might need an Administrator level account to edit the access rights permissions of the files and folders in your hard drive. Alternatively, you can also try to check your drive with WD Lifeguard Diagnostic tool to check if there are possible errors on your drive that prevents you from normal access.

Collapse -
Administrator
by fmitchelltx01 / May 20, 2014 8:27 PM PDT
In reply to: Permissions

I am the administrator and have tried it that way too. I still can't access my files. Where would I get the WD Lifeguard Diagnostic tool? Thanks for your help.

Collapse -
Wd Lifeguard
by sonicdrive / May 23, 2014 2:33 PM PDT
In reply to: Administrator

You can download it and install from WD support page.

Collapse -
Ditto
by James Denison / March 25, 2017 10:57 AM PDT
In reply to: Wd Lifeguard

Elements and Passport don't necessarily work the same way for access to them.

Collapse -
Administrator
by fmitchelltx01 / May 24, 2014 4:30 AM PDT
In reply to: Permissions

I am the only user of my computers. I am the administrator. Is there anything else I can try? WD customer service is useless.

Collapse -
The administrator in Windows is not "God"
by R. Proffitt Forum moderator / May 24, 2014 4:38 AM PDT
In reply to: Administrator

There are too many discussions about that area. That is, it doesn't make any difference if you are the Administrator, only user and more.

Windows does not have a God mod where it lets you do anything you wish. That is, if a folder is without an entry for the Administrator or is protected by WFP (http://support.microsoft.com/kb/222193 ) then a person new to this area of permissions and more may exclaim they are the Administrator, only user or "Why?"

There are tomes on the web about that.

Moving forward. Long ago I offered an advice on how to get around it all. Still works today.
Read http://tips.oncomputers.info/archives2004/0401/2004-Jan-11.htm

Also, data recovery is covered at the top of this and other forums.
Bob

Collapse -
Thanks
by fmitchelltx01 / May 24, 2014 10:16 AM PDT

Thank you

Collapse -
Answer
'Virtual Disk' service started?
by Irwan K / March 30, 2016 6:07 AM PDT

Make sure 'Virtual Disk' service was started.
I also get same problem (USB/external HDD) was 'access denied' and can not see current owner from Security tab.

Collapse -
Answer
Use Comand Prompt or Powershell
by Ian_Hoover / March 9, 2017 1:55 AM PST

First of all, apologies for resurrecting this ancient thread. But this is the first google hit on the subject and it doesn't supply any great answers. Here is my solution that worked for me quite well.

The root of my problem is that I wasn't the owner of the folder on the external hard drive. The solution? takeown command, naturally.  Here's how to do it:

    1: launch powershell (or command prompt) as an administrator. (To do this, hit windows, begin typing the name, and right click on it. The n select "run as administrator"
    2: take ownership of the drive by running 'takeown /F [PATH TO YOUR FOLDER AND/OR FILE] /R'
    3: You should now be able to change your access permissions in the usual way. right-click, properties etc.

I hope this helps somebody.

Collapse -
so powerful; this totally worked
by smvd2k / March 11, 2017 1:52 AM PST

wow. I don't know how, or why, I don't care. But it worked. Thank you for sharing your knowledge. you are amazing too.

Collapse -
Further Detail
by VivoAzzurro / March 15, 2017 10:27 PM PDT

Could you explain exactly how I should type the path to my folder? My folder is in the (D:) Drive, then inside of a folder named "Documents and Settings", then "User", and finally "My Documents". Unfortunately I don't know the proper way to identify the path to the folder Sad

Thank you for reviving the thread. Perfect timing, actually.

Collapse -
Figured it out if anyone was in a similar situation
by VivoAzzurro / March 15, 2017 11:01 PM PDT
In reply to: Further Detail

takeown /f "D:\Folder Name\Folder name\..." /r /d y

Quotations are a part of the command line

Collapse -
Worked for me
by Heatherj0 / March 25, 2017 10:43 AM PDT

Woohoo!!! This worked for me. I was trying to pull files off of an old windows XP laptop HDD. I wish I would have found this thread sooner. Thank you Ian.

Collapse -
this is not wroking for me
by jpeer2 / March 27, 2017 10:41 AM PDT

can you please help. this is what I am entering:
takeown /f "I:\Pictures" /r
this is the error I get:
INFO: Access is Denied. (File Name)

this is on a WD external harddrive. I have been having this issue for years since I got a new computer.

Collapse -
Not working for me either.
by slstr / October 19, 2017 8:28 PM PDT

After trying the takeown method in cmd, i still receive the You don't currently have permission to access this folder. in my hard disk.

Anyone else can help?

Collapse -
Answer
This worked perfect!
by Seattlejade / June 5, 2017 7:30 PM PDT

The answer is what Is explained above/ followed your instructions and was so happy to be back in/ hoping not 'EVERYONE' can use my drive in reality Great answer success! Thank you!

Collapse -
Good topic
by Arathy123 / October 20, 2017 1:35 AM PDT
In reply to: This worked perfect!
Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?