General discussion

Dell XPS M1710 wont power on HELP Please!!!

I have read several posts about this but none seem to be exactly the same as my problem, so forgive me for posting again. Laptop was on working fine, I left it for maybe 20 minutes when I come back to it, it was dead. I tried powering on again but nothing. I tried a different power supply and tried with and without the battery. Same result. When plugged in I get the battery light flashing to indicate there is power, the power light on the supply is also on. When I push FN and power, I get NO lights in the Lock LED's and the laptop dies in seconds as does the power supply, the led on the power supply goes out instantly, I have to unplug it, leave it for a few seconds then plug it back in and the power supply led comes on again. The only LED on the laptop that flickers for a second before dying is the wifi. Laptop is about 4 years old and is out of warranty. I look after it really well and haven't replaced any parts recently. It's on a docking station and never moves anywhere. (I have done all tests off of the docking station and directly connected to the power supply) I was advised it was the Motherboard but I have replaced this and it made no difference, I still have axactly the same problem. Any other ideas anyone please?

Discussion is locked
Follow
Reply to: Dell XPS M1710 wont power on HELP Please!!!
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Dell XPS M1710 wont power on HELP Please!!!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Just one fast thing to try.

Remove power, battery, press hold the power button for the full 60 seconds. Release the button, slip in the battery, apply AC, count to 10 and try again.

If that fails it's probably it's power or still another bad motherboard. I rarely see folk change the motherboard due to the cost from Dell. And those ebay units always seem dead.
Bob

- Collapse -
Still need help

Sorry this didn't help, same thing happens. Replacement motherboard is fine, it was pulled from a working unit, I saw it working. I wonder if it could be the graphics card, but don't know if that would cause this fault to happen? The vents inside the machine were quite blocked with dust so I'm thinking it may have over heated?

- Collapse -
So you replaced the PSU and the motherboard.

And you're sure the new PSU is file and the new motherboard is fine. That's strange.

One question though. Did you use the old RAM and/or the old CPU in the replacement motherboard? Or did you replace the mobo with CPU and RAM included?

Kees

- Collapse -
Replaced just the motherboard

I replaced just the main board itself, I used the old CPU and ram, although I have also tried different ram with the new board. I have been advised elsewhere that it sounds like the video card, but having already paid out for a new mobo I'm reluctant to pay out for a video card as well if that is not going to fix it?

- Collapse -
Then go in reverse.

You say the motherboard was from a working unit. What happens when you put the video, ram and such in that unit?

Those Dell laptop graphic cards are a tech's dream (bad one.) I've lost count.

Be aware that nothing points to anything specific. We'll have to use the most common failure given only this story and model.
Bob

- Collapse -
Check the motherboard

Hi,

Maybe that's the cpu heat dissipation fan problem,it won't power on or
auto shutoff for a few seconds if your fan is blocked.Just as my laptop
acer 4520g,it works well after i repaired it for the same reason.

- Collapse -
Fault found

Thanks for all the advice. It was actually the graphics card.

CNET Forums