Question

DELL Vostro 15 - 7590 and Ballistix Sport LT not compatible?

I just bought Vostro 15 (7590) and want to upgrade the memory with 2 x 16Gb Ballistix Sport LT SODIMM DDR4 2666 ( https://www.crucial.com/usa/en/vostro-15-%287580%29/CT13181057 ).

I tried one by one, but I only got keyboard backlight and blank screen for around 1-2 minute and then shut down automatically.
I tried one with the original memory and the other with Ballistix Sport LT and got the same issue for both memories.

I assumed that there is a XMP issue (might be wrong assumption), tried to find the setting in bios but can't find it.

Any body has the same issue/experience?

Moderator Edited: Fixed link.

Post was last edited on July 4, 2019 11:36 AM PDT

Discussion is locked
Answer
Follow
Reply to: DELL Vostro 15 - 7590 and Ballistix Sport LT not compatible?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: DELL Vostro 15 - 7590 and Ballistix Sport LT not compatible?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
It appears to be "on the list."
https://www.crucial.com/usa/en/compatible-upgrade-for/Dell/vostro-15-%287580%29 has that stick BUT it may require the BIOS to be CURRENT and ONE MORE THING.

I've seen troubles when I had the PC set to hibernate. W10 is an odd beast about that so be sure to tell it to power off and not sleep or such. Also, when I change laptop RAM I remove the battery and wall power.

As you were able to get it to work with the old RAM I will still list the install issues in my list to follow.

1. Be sure the machine BIOS is Dell's latest.
2. Be sure Windows has shutdown and not hibernating or sleeping.
3. Try the old simple reset. Remove power and battery, press and hold the power button for 60 seconds, release, insert battery, apply power and test.
4. Have someone check your stick install. Sometimes I find folk don't get the RAM seated.
- Collapse -
I did almost all of the points but still no luck

I already did all points that you mentions
1. I used latest BIOS v.1.1.1 (25 Jun 2019)
2. Windows was shut down
3. I already took the round battery connection off for more than 1 minute
4. I do not have technical friend here, but I already play around with the new and the old memory. I also did some memory upgrade before.

I bought this from newegg. Have you every got product issue from this company before?

- Collapse -
Time to call Crucial.

They have a warranty about it working so it's back to them to do their thing.

CNET Forums