Computer Newbies forum

General discussion

Defrag and Diskeeper problems

by nenay8 / November 4, 2006 2:30 AM PST

My initial proble began when I tried to run my Windows XP Defrag...I would get a message saying that "Disk defragmetor has detected that CHKDSK is scheduled to run on the volume:(C:). Please run CHKDSK /f."
Alright, so I tried that and then would receive a message at the third stage of the CHKDSK that says, "Unable to write to attribute 128 of file 9."

I am therefore going around and around in circles as I cannot run my defrag, as I continue to get the message as mentioned above, and when I run CHKDSK /f, that is not helping either.

So...I then purchased Diskeeper online, thinking that might help me as I had read good things about this program in your column. I had no problem downloading it but have a problem in the installation process. I have written to the Diskeeper Help site several times and their information to me is not helping. It would appear that my problem is this...When I try installing Diskeeper from the Installation Wizard, I receive error message 1920, which says that..."Service Diskeeper failed to start. Verify that you have sufficient priveleges to start System Services." Well, when I go to the Services panel, find Duskeeper and try to start the program (which I had set to "Automatic", I receive another error message when I try to start it. This is error message 1062, which says..."could not start the Diskeeper service on the local computer. Error 1062. The service has not been started." I have gone through everything to try and find why the service will not start and cannot find a thing.
Can anyone help me with either of these defrag problems?
I am running Windows XP Pro-Service Pack 2
Computer: Seanix Intel(R)
Pentium (r) 4cpu
1400 MHz
1-40 GHz, 256 MB of RAM


Discussion is locked
You are posting a reply to: Defrag and Diskeeper problems
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Defrag and Diskeeper problems
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
(NT) (NT) Tried under the 'Safe Mode' ?
by VAPCMD / November 4, 2006 2:43 AM PST
Collapse -
Had no luck with "Safe Mode"
by nenay8 / November 4, 2006 11:13 AM PST

Thank you for your suggestion. I did in fact try to both run my Windows Defrag as well as the Diskeeper Installation under safe mode. But without much luck I am afraid...received the same message "CHKDSK is scheduled to run on the volume" when I tried running my defrag. Of course, got nowhere with trying to install Diskeeper there either as Windows Installer will not run when in safe mode.
I do appreciate your trying to help me though!

Collapse -
Bummer ....was hoping that might help. Guess you'll have
by VAPCMD / November 4, 2006 12:15 PM PST

to try Bob's remedy. Keep us posted.


Collapse -
(NT) (NT) Thanks for trying anyway!
by nenay8 / November 4, 2006 12:39 PM PST
Collapse -
Sorry if we have to step beyond newbie mode.
by R. Proffitt Forum moderator / November 4, 2006 2:44 AM PST

"What you should do next is type in "CHKNTFS /X c:" This will force windows NOT to run chkdsk at next startup. That way it won't be "running a process when you DO try to run CHKDSK later on.

Reboot the computer and then run chkdsk this time with the flags /f and /r
so type in: "CHKDSK /f /r c:" (without quotes)

Then run the FSUTIL again and it shouldn't say its dirty, restart the computer and then you'll be able to defrag"

More at

Collapse -
Still no luck...
by nenay8 / November 4, 2006 12:37 PM PST

Sorry to say that your suggestions did not help me with my problems. I tried to follow your instructions exactly (hey, I even purchased a membership yo the link you gave me!) but I still get the message..."CHKDSK is scheduled to run on the volume" when I try to defrag. Still cannot install Diskeeper either because I still cannot get the service to start. Back to square one...

Collapse -
Have you looked in the Forum under Windows XP ?
by VAPCMD / November 4, 2006 11:32 PM PST
In reply to: Still no luck...

Might consider reposting there with a note indicating you also posted in the Newbies Forum.


Collapse -
Tip. No membership was needed.
by R. Proffitt Forum moderator / November 4, 2006 11:53 PM PST
In reply to: Still no luck...

Many hit that membership request and stop reading. If you keep scrolling down you find more to read and sometimes your answer.

I can't explain why people don't keep scrolling down to get to the good content below.


Collapse -
by nenay8 / November 5, 2006 4:13 AM PST

You are so right Bob...had I kept scrolling down, I would have received the answer I paid for! Oh well, hopefully the funds will get put to good a retirement home for techies! Although, you should know that it doesn't always show on their site. I just went back one time I could see the answer and the next time I couldn't. Go figure...
I do have a question though...again. When you mentioned FSUTIL...I didn't have a clue what you were talking about until I did a search in Microsoft to explain it to me. There I received warnings not to play around with that unless I was knowledgeable, which I surely am not. However, trusting your advice, I did go to the answers given on that site and entered the command, "FSUTIL dirty query C:" as suggested in the site response. What I did was to click Run, type in the above and hit OK. My black command screen appeared for a second and then disappeared again. Am I doing something incorrectly? Also, should I take this forum to the Windows XP forum as suggested by another responder? Thank you for all of your patience with me as I am new to all of this!

Collapse -
by nenay8 / November 5, 2006 4:20 AM PST
In reply to: Whoops...

Idid run the command again...FSUTIL dirty query C:...this time it did come back and say that the C: volume was dirty.

Collapse -
"My black command screen appeared for a second" fix.
by R. Proffitt Forum moderator / November 5, 2006 6:19 AM PST
In reply to: Whoops...

Next time, run CMD and you'll get the command window. Now you can type commands without it vanishing.

With your perseverence you'll either fix it or learn something new. Both are good things.


Collapse -
Thank you for the tip
by nenay8 / November 5, 2006 8:00 AM PST

Perserverence is an understatement...I may not have resolved my problems with CHKDSK, Defrag, and Diskeeper, but I have learned some new things along the way. Thinking my next step might be to dump this computer off of the closest cliff and buy a new one?

Collapse -
I bet you are 'oh so close.'
by R. Proffitt Forum moderator / November 5, 2006 9:50 AM PST
In reply to: Thank you for the tip

Review that link again on how to clear the dirty bit.


Collapse -
So close maybe, but not there yet
by nenay8 / November 5, 2006 2:49 PM PST

Bob, the discussion in that link is a little over my head (plus I am blonde!) but this is what I did...Perhaps you can tell me what I have missed.

I clicked start, then run...typed cmd.
On the command screen I typed CHKNTFS /X c: and then enter...
Nothing happened and I then turned off my computer.
I restarted my computer again (I am assuming that is what you meant by REBOOT.
I then clicked start, run and cmd again.
In the command screen I typed CHKDSK /f /r c: and then enter.
I then receved the usual message that says..."Cannot lock current drive. CHKDSK cannot run because the volume is in use by another process. Would you like to schedule the volume to be checked the next time the system restarts? (Y/N)"
I typed Y and then shut off my coputer again.
Then I started it and CHKDSK did its check but as always, I get the message that it "cannot write to attribute 128 of file 9."
So here I am...going around in circles again. And I still have the dirty bit.
Are you able to tell me what I missed or did wrong?
As always, thanks so much. You feel like my lifeline.

Collapse -
Nearing the end I fear.
by R. Proffitt Forum moderator / November 5, 2006 5:49 PM PST

"Error Message:

Unable to write to attribute parameter of file filename.


Chkdsk was trying to restore a corrupted attribute for the specified file. The attribute was unable to be written to the file because the file is either corrupted or a hardware problem may have occurred on the disk drive.

User Action:

Try to restore the specified file from a backup copy. If you continue to get this message, backup the hard drive and do a low level format and then restore the file system. If the problem persist, replace the hard drive. "

from this link

If this was my machine I'd try this one more time is SAFE MODE. There is some thought that GOBACK or other such software can cause this but to fix this appears to be the work noted above.

I wish there was an easy fix but armed with what you've revealed so far the above looks to be the answer.

Can you reveal how old this install of XP is? And how old the machine or hard disk is?


Collapse -
Oops. Additional information.
by R. Proffitt Forum moderator / November 5, 2006 5:50 PM PST

CHKDSK /V may reveal the filename in question.


Collapse -
Thank you for your patience and advice.
by nenay8 / November 9, 2006 2:00 PM PST

Thank you Bob for your patience and advice in trying to help me deal with my problem. As I am a newbie, I think this machine is off to the nearest shop for some "fixing"! I did want to thank you though for your patience and advice. It was a real learning experience!

Collapse -
same problem with diskeeper here
by mpluspo / November 7, 2006 9:17 PM PST

i can't seem to run diskeeper.. it was giving out the same error 1920 diskeeper service could not start thingy.. so i uninstalled it. installed the version 10. no luck. still with the error 1920 during installation. i tried many things from different forums like running the service.msc, regedit (imagepath editing.. adding "") no luck.

so please help me also.. thanks!

i have winxp pro sp2.

Collapse -
by nenay8 / November 9, 2006 2:04 PM PST

Did you write to the technical support folks at Diskeeper? They had a list of things to try for me when i wrote to them. Unfortuately it did not help me, but their suggestions might be beneficial to you.

Collapse -
diskeeper tech support didn't help
by mpluspo / November 11, 2006 2:07 AM PST
In reply to: Diskeeper

i tried their website.. it has a number of things to try out.. and it worked with several users when according to different forums i searched from.. unfortunately it didn't work for me. i dont want to format yet. im hoping ill get this fixed.

Collapse -
(NT) You and I are in the same boat then! Good luck!
by nenay8 / November 12, 2006 9:17 AM PST
Collapse -
i finally fixed it!
by mpluspo / November 19, 2006 12:24 AM PST

yahoo! i finally fixed it.. my sister's friend helped me with it.. hehe check out your services.msc under services.. we found out my EventLog was missing! if it is.. then we have the same problem. hehe i tried sfc /purgecache then sfc /scannow to fix it first.. but apparently it didn't work for me.. because my winxp CD doesn't have sp2 i think.. im running sp2.. so what i did was.. i asked for an export copy of the registry key of my sister's friend. he was running winxp home.. im running pro.. well it doesn't really matter i think. i merge the key.. (dont mind the error. just click ok.) i restarted. and installed the diskeeper without any problems! yahoo! case closed! hope you fix yours camerashy!

Collapse -
Yahoo for you! Now please help me!
by nenay8 / November 19, 2006 5:00 AM PST
In reply to: i finally fixed it!

Great news that you finally found the resolution to your problem. I have the EXACT same problem that you did in that the Event Log is not showing on my Services list.
Would you be able to provide me with step by step instructions as to what you did exactly to resolve your issue? It may just be the thing I have been searching for! If it is, I could kiss you!

Collapse -
(NT) Well... that would be interesting! :)
by glenn30 / November 19, 2006 5:47 AM PST
Collapse -
before you entering the non-newbie dimension....
by jguitard / January 23, 2008 9:03 PM PST

try going to administrative tools - services and verifying the status of the Event Log Service. Some people shut this service down for performance reasons. By default, Diskeeper is setup to write to the logs. if this is disabled, Diskeeper will give you a 1062 error on startup. Simply enable and start the Event log Service.

(worked for me anyway) Good Luck!

Collapse -
chkdsk / diskeeper
by gordo43 / June 17, 2010 7:30 AM PDT


In order to clear out the CHKDSK requirement to begin using your Diskeeper software, you must run a CHKDSK C: /R on your system.

Replace C with a different drive letter if needed.

Run the COMMAND PROMPT, which you can do via the Start Menu

Collapse -
Hopefully, You're Aware You Responded To a 4 Year Old.......
by Grif Thomas Forum moderator / June 17, 2010 9:45 AM PDT
In reply to: chkdsk / diskeeper

.....topic and the original poster in this thread hasn't posted in the forum since 2006? I doubt they will see your reply..

It's best to respond to current threads so the topic originator can learn from such.

Hope this helps.


Collapse -
4 year old post
by gordo43 / June 17, 2010 9:59 AM PDT

Thanks for the info. I thought I saw 2010 I guess I need new glasses

Maybe someone who needs it will find it.


Collapse -
Not working solution
by psoph58 / June 6, 2011 1:18 AM PDT
In reply to: 4 year old post

indeed Silly i found the info through google but your solution didn't work out Sad

Collapse -
It's a tough one. Beyond this forum's intent.
by R. Proffitt Forum moderator / June 6, 2011 2:36 AM PDT
In reply to: Not working solution

I had to step over the forum's title and start writing about more advanced tools.

I suggest you start a new discussion in the forum of your choice. Tell a lot more!

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.