Remember that on some motherboards this is a bios setting and only does that if you have the right RAM.

Bob