HolidayBuyer's Guide

Networking & Wireless forum

General discussion

D-Link DWLG-122 USB adapter can't connect at all

by SteveMcGarrett / February 8, 2007 11:39 PM PST

I purchased a DI-524 router and DWLG-122 USB Wireless adapter together and was able to set up the router easily. I had no problem picking up the wireless signal on my laptop anywhere in the house, but when I attempted to install and use the USB adapter it will not work.

I've installed the latest firmware update, but it still reports that it cannot find a wireless network, even though my laptop is sitting right next to it and reports that the signal strength is excellent.

I've uninstalled and reinstalled numerous times without ever having the USB adapter pick up the signal.

The people I've talked to on the tech support line were very difficult to understand and I have a hard time believing that this can be that difficult as it should be a straightforward plug and play type of solution.

I have not changed any factory defaults so I'm thinking this may be a hardware failure.

I'm running XP Pro w/ SP2. I've tried connecting using both XP's Wireless Config and w/ the D-Link config w/o any success. It's not even "seeing" the network, let alone configuring it. The D-Link utility icon is just white bars and it's bombs almost immediately when I search for wireless networks.

My laptop saw it and connected immediately right away so it can't be signal strength or encryption. My next step is to borrow a different USB adapter from a friend who no longer uses theirs to see if that would make any difference. I don't think it's firewall related as it doesn't even get that far along in terms of trying to connect to the net.

Any help you can offer would be most appreciated!

Discussion is locked
You are posting a reply to: D-Link DWLG-122 USB adapter can't connect at all
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: D-Link DWLG-122 USB adapter can't connect at all
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I have a 524.
by R. Proffitt Forum moderator / February 9, 2007 12:02 AM PST

It was just about to be tossed back when I discovered the firmware was out of date. Once I corrected that (visited the router is working fine.

Hope this helps.


Collapse -
Think it's the adapter, not the router
by SteveMcGarrett / February 9, 2007 12:18 AM PST
In reply to: I have a 524.

The router is spitting out the signal just fine, but the USB adapter is picking it up at all.

The built in wireless card in my laptop saw it right away and has always connected w/o a hitch so I know it's not a question of the router not transmitting.

I would think the USB adapter would be a simple plug and play type of deal, but maybe I'm missing something here.

Collapse -
My router was spitting out a signal just fine too.
by R. Proffitt Forum moderator / February 9, 2007 12:27 AM PST

But connecting to the laptop was sporadic and worse.

Sorry to see you miss the clue I offered.

-> One more time. With the outdated firmware one machine connected, another didn't. To the unseasoned they may think it's not the router since one machine worked. I hope this helps you understand this better.



Collapse -
Got it
by SteveMcGarrett / February 9, 2007 12:33 AM PST

Thanks Bob I'll update the firmware on the router and give it a shot.

Collapse -
D-Link (DWA-131) USB adapter can`t connect
by fogbrainthesecond / May 26, 2011 7:32 PM PDT

Anyone had this problem?

We have a fully functional wireless network running from a Linksys WRT54GL router
(with master pc connected).

I purchased a D-Link DWA-131 USB adapter to connect from another room.

OS: XP home 2002, serv pack 3

Have installed drivers from installation disk.

My pc identifies the wireless network.

SIgnal strength 90%

Any ideas?


Collapse -
No. Never.
by R. Proffitt Forum moderator / May 29, 2011 5:58 AM PDT

But if you were to ask me to guess I'd give you the most common reason is the owner didn't type in the WEP password correctly. And if the owner insists that its right then we change the wifi router to WPA and never use MAC FILTERING.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.