Which browser are you using? (If Internet Explorer, which version?)

Are you making it to the log on page? The link below should do it.
http://mail.yahoo.com/?.intl=us

Did you choose the "Secure" setting or the "Standard" one? (I prefer NOT to use the "Secure" option.

Do you get an error message?

Are you sure you're typing in the correct username and password? (Did you make sure that you don't have the "Caps Lock" on?)
___________

If you're using Internet Explorer 6 at the moment, click on "Tools" in the upper left, choose "Internet Options", then click on the "Privacy" tab. Move the Cookie slider to "medium" and it should allow you to log on to YahooMail!.

HOpe this helps and let us know more.

Grif