Controlling DHCP assignments


Fiber Optics into a MikroTik RouterBoard 950
950 connects to an HP ProCurve 24-port switch
Ubiquiti NanoBeam M5 connects to the ProCurve to provide access to a remote location
Linksys 900 installed at remote location
DLink N300 range extender extends the Linksys to an adjacent remote location

The MikroTik is configured as authoritative DHCP server, and also is configured to provide WIFI locally. Somehow, local WIFI connections are occasionally picking up an IP address from the N300, and not from the MikroTik and, to make it worse, won't work! Devices at the remote location that connect to the N300 will work fine. This is driving me nuts, and I can't figure out how to prevent it from happening. The closest DHCP server - and certainly the authoritative server - should always be first, shouldn't it? How do I stop this?

Discussion is locked

Reply to: Controlling DHCP assignments
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Controlling DHCP assignments
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
- Collapse -
On a LAN, there can only be one DHCP server.

If you have more than one, your IT lead has to be sent back to school.

- Collapse -
Re: On a LAN, there can only be one DHCP server.

<dripping with sarcasm>What an incredibly helpful post you made.</dripping with sarcasm>

There can definitely be more than 1 DHCP server on a network; however, that has nothing to do with the post. If you had read it properly, you would have seen that the range extender is causing the problem. The range extender cannot have its DHCP server functionality disabled.

Please educate yourself on equipment before posting, as well as the purpose of having public forums.

- Collapse -

I noted a common area we cover in the classroom and if you break this rule you do so to learn why you don't do this.

Now if you have a range extender issue that's another problem you learn over time. That is, range extenders tend to result in call backs and your seasoned networker will not field extenders. They will use a WAP to deploy where the WIFi is needed.

I don't mind new networkers. We all started somewhere.

Post was last edited on February 22, 2017 10:32 AM PST

- Collapse -
Let's google that DHCP
- Collapse -
Re: Let's google that DHCP

If it were possible to deploy a solution other than the range extender, that would have been done already. What I am trying to figure out, as the original post indicates, is why the devices connected wirelessly to the MikroTik, which is configured as the authoritative DHCP server, would even attempt to talk to the range extender for DHCP authorization since the range extender is well down the line.

- Collapse -
Would not deploy that setup.

I have many other ways to get a connection and set it up. I have run into IT leads that deploy such and they spend their time fixing it.

Back to to MicroTik to see what they support here.

-> Parting thought. I recall one extender I fixed with a firmware update. Before the update the machines on the other side failed DHCP assignments. But it was fixed and no warranty given. We know better.

- Collapse -
Static and Reserved IP address

The simplest solution is to assign static IPs to the devices that are connected. If for some reason that isn't a possibility, some routers will let you reserve a section of IP addresses. In the settings menu you will be able to define the range of the addresses assigned.

CNET Forums

Forum Info