Thank you for being a valued part of the CNET community. As of December 1, 2020, the forums are in read-only format. In early 2021, CNET Forums will no longer be available. We are grateful for the participation and advice you have provided to one another over the years.

Thanks,

CNET Support

General discussion

Continuous/Random CRC errors when I unpack .RAR files...

Dec 9, 2007 3:48PM PST

I seem to be running into the same problem which only is affecting my computer.

I've been attempting to download several large (5 GIG+) sets of files (split into separate .RAR files) from Rapidshare. I can download them fine. My problem is when I try to unpack them.

I randomly seem to run into "crc failed: volume is corrupt" or "packed data - crc failed" errors when trying to unpack these large sets of files (they are DVDs.)

I've used 3 different download accelerators (Internet Download Manager, Rapidget, Orbitdownloader) and they all give me the same problem. Also, I restarted my computer in Safe mode (Running Vista on a 3.2 GHZ, 2 Gigs Ram computer) and downloaded each file, one at a time without an accelerator and had the SAME issue unpacking the files -- random CRC errors.

I tried unpacking them with Winzip but have the same issue. Something is going on. Others have checked the files and they work for them so it's an issue only with me.

Any thoughts? THANKS!

Discussion is locked

- Collapse -
Try 7zip to unpack them
Dec 9, 2007 4:14PM PST

These might help:

http://www.download.com/8301-2007_4-9798652-12.html?tag=more

Or the windows downloader with 7zip. I do not use download accelerators myself.

Is your C: drive full?

Do you have registry repair software? It is available here:

http://www.download.com/3120-20_4-0.html?tag=fil&qt=registry+repair&sort=&operatingSystems=&licenseType=49&fileSize=&ca=

These were filter as freeware.

I was working with a guy earlier this week on this very same issue we never did figure it out as far as I know. He went AWOL on us.

- Collapse -
Not much room left...
Dec 10, 2007 4:49AM PST

I have about 11 gigs free out of about 300. Does that matter?

I'm not sure about the registry cleaner...

- Collapse -
One more thing....
Dec 10, 2007 4:50AM PST

I don't have any partitions on my C drive. It's just one single massive drive. I'm not sure if that's a good thing or a bad thing. Just FYI....

- Collapse -
Re: crc-errors
Dec 9, 2007 5:06PM PST

This can only mean that either the file is corrupt (getting corrupted somewhere between the source and your hard disk) or your computer is so unreliable that it loses bits randomly (in the RAM or the CPU).

Try downloading the file two or three times and compare them with a file compare program. They should be identical to the last bit.
Then burn one of those identical copies you can't unrar to another PC and try to unrar it there.
Together, these experiments serve to pinpoint the problem.

By the way, I wouldn't advice cleaning the registry for this problem. The chance that it introduces other problems is much bigger than that it solves this particular one.

Kees

- Collapse -
Doesn't this look familiar Kees?
Dec 9, 2007 5:28PM PST

Kees and I were working on a problem just like this one earlier this week. Odd how things like this happen. Maybe the ghost of Christmas past is at work here. Not that I believe in that sort of thing. No way, I'm a reasonible man, well grounded, sober of thought, naaa couldn't be. Shocked

- Collapse -
Wow, heard someone outside my house
Dec 9, 2007 5:44PM PST
- Collapse -
file-compare program
Dec 10, 2007 4:52AM PST

what's a good one your reccomend I can use for free?

thanks!

I have a sneaking suspicion this may have to due with my hard drive being so full...or maybe a memory issue? Can I somehow check my memory to make sure it wouldn't be somehow causing CRC mismatches/errors? Or is that just a red herring?

- Collapse -
Nope
Dec 10, 2007 4:58AM PST

Nope, CRC (Cyclic Redundancy Check) errors are exactly as said. They are either a result of the file being corrupted or bad RAM. They have nothing to do with the amount of space free on the drive. There's a whole other error for that.

So, either try downloading the whole 5GB mess again, or if it's broken up into multiple parts, see if you can just download those parts causing problems. You may also want to download the memtest86 program to check for bad RAM.

- Collapse -
Memory just fine
Dec 10, 2007 7:12AM PST

I was just working with a guy from Dell tech support and he had me run several memory diagnostics after I rebooted my computer. They all passed.

I decided to run a whole slew of system test and only found an issue with a USB driver (I've had a strange USB recognition issue for a while now.)

Anyway, the RAM looks fine. Now what? I thought MAYBE Winrar was corrupted so I uninstalled it and re-installed it to no avail.

I will try the file-comparison suggestion now to see if I'm getting the same file each time.

Any other advice?

- Collapse -
No offense
Dec 10, 2007 8:37AM PST

No offense... Okay, there is some offense intended here, but Dell support people are almost universally useless to just slightly less than useless because they'll send you a whole new product to get you off the phone faster rather than try and solve the problem.

So without knowing what programs they had you run, I'm going with the safest assumption which is that none of them were thorough enough. Something like memtest86 is intended to be let run overnight, not just for a few minutes while you're on the phone with someone.

- Collapse -
Different binary files....!
Dec 10, 2007 8:02AM PST

So,

I've downloaded the SAME large .RAR file (~100 megs) twice, using both a download accelerator and the old-fashioned way. I used ExamDiff to compare the two binary files, and they are different binary files both ways I tried to download it.

Somehow the file is changing as I download it. WHAT GIVES? Is it some process I'm running.

I don't have issues with huge video files -- it's just these damn .RAR files.

- Collapse -
DOWNLOAD ACCELERATORS are well known for this.
Dec 10, 2007 8:12AM PST

A rar is heavily compressed so don't count on DA's to help.

Bob

- Collapse -
i know....
Dec 10, 2007 8:21AM PST

But I still have this issue when I DON'T use an accelerator and download a single file through the IE window...

- Collapse -
If you download through IE ...
Dec 10, 2007 4:26PM PST

is it different then each time?
is it different from a copy on a another machine?

You don't tell (yet).

It seems that something in your machine is corrupting the download. Most likely some software you installed yourself (XP or Vista are nog especially known to corrupt data), less likely some hardware issue.

The simple rule: if it still goes wrong after a clean re-install of the OS and all necessary drivers (that is: back to Dell's system recovery CD) it's hardware. If it goes OK, then it probably will go OK forever afterward. If the errors come back 'suddenly' do a System Restore to before that 'suddenly' and you practically know the cause.

Kees

- Collapse -
update
Dec 11, 2007 4:49AM PST

I haven't checked out downloading on other machines. All I know is that if I download the same file through IE -- and compare them -- they have different binary signatures -- and they should be the SAME, right?

It's definitely some lame-*** software issue. I do have a bunch on my computer. I also have a lot of huge video files taking up a bunch of space (as I said, I have about 11 gigs free / 300 gigs.)

Maybe I should try to use firefox to download them -- maybe it's some weird IE thing.

Otherwise, I guess I'm open to a clean Vista install. Do I lose all of my installed software then?

- Collapse -
After a clean install ...
Dec 12, 2007 3:43AM PST

you lose all installed programs. So you need the setup.exe or program.msi or CD to install them again. Takes some time.

Kees

- Collapse -
.rar CRC check error
Jan 13, 2009 2:35PM PST

Guys,
I'd fixed the problem of dl .rar CRC check error: by reset IE.
Internet option-->Advanced-->Restore Default or Reset (depends on your IE version).
Good luck

- Collapse -
CRC check error on downloaded .RAR file
Jan 9, 2009 7:03PM PST

I think IDM had something to do with the CRC check failure on .rar file if you previously installed the hacked IDM.

- Collapse -
Continuous/Random CRC errors when I unpack .RAR files...
Jan 31, 2012 6:40AM PST

i am having the same problem. ive downloaded 5GB video file


which is compressed in .RAR format using a previously hacked IDM. i always receive a message like CRC mismatch.. Do u have a solution for that?? Anyone????

- Collapse -
Locked.
Jan 31, 2012 9:59AM PST

The forum policy forbids discussion of cracked or pirated software.

- Collapse -
This might help
Dec 10, 2007 11:17AM PST

Did a search for Microsoft data base for "packed data crc failed" (see response below). According to this and other responses the file is being sent corrupted from the web server and unless they, the source of the problem, fix it, it will not install. Contact them and ask if an alternate mirror site is available? If the original is corrupt then all sites might be affected. A previous version might be an alternative if available. There are several responses like this:

http://forums.microsoft.com/Dynamics/ShowPost.aspx?PostID=1803004&SiteID=27

(Unlike our previous post this one seems isolated to one down load from one site.)

- Collapse -
At this point
Dec 10, 2007 11:12PM PST

perhaps we need to look at this differently. How about reinstalling IE7 this is a long shot but this program might be a factor. How about a connection problem? A fresh look and other ideas might be in order. You might have to start over with and OS install to correct it but let's put on our thinking caps first. Any long shots out there?

- Collapse -
Continuous/Random CRC errors when I unpack .RAR files
May 26, 2010 2:47AM PDT

The last few days I bin getting the same thing.. So i did what evry www told me CHKDSK ok so that was step 1.. next was to look at the cpu i used CPUStabTest ran my cpu up to 62c norm is 52c but didn't luck up my computer or blue screen of death so cpu is step 2. step 3 was Motherbord so I took it out looked for bad tops of compasatos ect. setp 4 Ram now this i would have to say if u are getting bad crc's in ramdom 2gb+ files in, 15mb 50mb 100mb packs that randomly fail.. 100% its the ram.. http://www.memtest86.com is what your looking for. put in 1 stick at a time.. if u have a 4+ core cpu down it to 2. when runing this program.. I have a 4 core amd and I had to change it to 2cores.. to get it to work..