Question

Connecting to PC via USB hub

Hi

I try to connect my Samsung WB 750 camera to my desktop PC via a USB-hub. It works when connecting a xperia z android or a kingston USB-stick to the PC via the hub, but my PC dont recognize the camera when using the hub, its only charging. On another PC , it works great to connect the camera using the hub. And it works on my PC, when connecting the camera directly to a USB port on the PC, not connecting via the hub. What could be the reason why it dont works via the hub on my PC?

Discussion is locked
Follow
Reply to: Connecting to PC via USB hub
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Connecting to PC via USB hub
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
System info

Windows 7 home premium
64 bites system intel core
i5 760 @ 2.80 Ghz
4.00 GB RAM

- Collapse -
Answer
Some devices don't work over hubs.

Why is usually technical and not something we can fix. If HUB and devices work on another PC then the most likely is a port difference from USB 3 to 2 or one ports power supply is better than the next.

Since fixing this is not always possible you try the usual and never state it can be fixed. Try other hubs.

- Collapse -
Technical

In spite its technical , it may be possible to fix. My PC is built where it was bought, so replacing some of the USB ports may be possible

- Collapse -
(NT) That and desktop front USB ports continue to create issues.

CNET Forums