Question

Connected my New HardDrive its not showing up?

Well today for christmas i got a new 1TB HardDrive Grin I was so exited so i connected it to my pc and turned my pc on ^_^ When i went to My Computer to see the new hard drive i saw it wasnt there? And i became worried so i looked up videos online... These videos told me that sometimes they dont show up due to the fact of the Drive not being assigned a letter... so i went to disk management and i assigned it to letter G:. After i finished that i went back to My Computer and the HardDrive still didnt appear Sad I then went back to disk management to check the drive again and this time the drive was no where to be found?!?! Can someone help me?

Discussion is locked
Follow
Reply to: Connected my New HardDrive its not showing up?
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Connected my New HardDrive its not showing up?
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
So you see it under DISK MANAGEMENT but not under

EXPLORER ?

If yes, I'm thinking you need to partition (allocate) the space on the new disk and then do the QUICK format so it can be used.

VAPCMD

- Collapse -
Answer
1TB HDD

What are the basic parameters of the system that you are hooking up to? What manufacturer is the exernal drive? Are there any lights showing on the drive with the adapter plugged into an A/C source?

- Collapse -
Answer
More details

What PC do you have? Did the new HD come with any s/w or install disc? On what SATA port was it attached, I assume SATA. You provided so few details, that I'm guessing here and asking ?'s to get to the basics.

tada -----Willy Happy

CNET Forums