Networking & Wireless forum

General discussion

Connect to internet on Mitsubishi TV through wireless router

by juliepunch / November 2, 2010 4:42 AM PDT

Just purchased a new Mitsutishi TV LT-55164 with built in internet connectivity. We have a Netgear wireless router set up at house so we can conntect our laptops to internet and that works fine. It is not a secure network, so no password was set up. When tried to connect to internet over tv, we selected our wireless network, but then it asked for a password. Default password for net gear is "password" so we entered that, but the tv would not connect through the router. How do we connect?

Discussion is locked
You are posting a reply to: Connect to internet on Mitsubishi TV through wireless router
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Connect to internet on Mitsubishi TV through wireless router
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Let's try the usual.
by R. Proffitt Forum moderator / November 2, 2010 4:47 AM PDT

If I install TWO NETGEAR ROUTERS the default name for both could be NETGEAR. You may have found someone else's router.

Two ideas.

1. Change the SSID to something unique.
2. Given the new exploits called FIRESHEEP and IDIOCY it is unsafe to have WIFI with WEP or no security. It's time to change to WPA/WPA2 PSK as well as do idea 1.


Collapse -
upgrade software
by allameriboy / November 13, 2010 9:01 AM PST

My Tv has the same issue. You need to download the new software program from Mitsubishi.

Collapse -
Same Issue
by kmfriedle / November 23, 2010 11:56 AM PST

I am having the same issue. It does not seem to matter if I have a password or not on the router. From where the TV is placed, I can see and access three different wireless routers, I can not connect to any of them and I have the new software installed. I have been calling Mitsubishi regularly trying to resolve the problem. Their engineer is supposed to be calling me because they think this is a unique issue since everything else on my tv works exactly as it should. I will post if the engineer can resolve the problem. I would love to hear if you get it figured out as well!

Collapse -
Connect to internet on Mitsubishi TV through wireless router
by jderbabian / January 4, 2011 8:49 PM PST
In reply to: Same Issue

Just bought a 55265 and I am having the same issue. I can connect from my laptop at the couch and I have plenty of signal, but not able to connect the TV to the network. I get the "Invalid password or network issue" error message.

Collapse -
Easy fix to try
by kmfriedle / January 5, 2011 12:01 AM PST

So, though I have yet to be logged in to vudu through my tv, I did manage to resolve the problem with connecting to my network/wireless router. The name of your network can have NO spaces. It's stupid, but worked like a charm. Rename your network and see what happens.
Bummer is I can now connect to the Internet but I can't seem to manage to handshake with vudu's site. I have their guys working on it and will post again if I discover a fix for that. Here's to half way there.

Collapse -
Connect to internet on Mitsubishi TV through wireless router
by jderbabian / January 5, 2011 12:27 AM PST
In reply to: Easy fix to try

My network name has no spaces in it. I have tried the actual password and the key, both in upper and lower case - makes no difference. I even opened up my network with no WEP at all and still cannot connect.

Collapse -
This old discussion
by R. Proffitt Forum moderator / January 5, 2011 12:33 AM PST

While we can't use the first entries I'll only offer that I find the firewalls in the routers to matter so put the TV into the DMZ and if not working still, create a NEW discussion with all the details.

Collapse -
Connection Solved
by mhenry54 / February 20, 2011 11:21 PM PST

I had the same problem as everyone else. Phoned Mitsubishi, and they insisted that my network was passworded. It is not, but, like most networks, it is protected. The stupid TV wants the WEB address, not a password. Mits tech denied this, but once I got the WEB entered correctly, my connectivity worked. You have to be careful when entering this number. The remote control cycles through the number pad letters before it gives you a number (ex: press the 2 key once to get A, twice gives B, thrice C, the fourth gives "2". Be careful on the 1 key: the first presses cycle through #,@,! and all the symbol keys before you finally get the number 1. I think the WEP number is the first thing I tried when prompted for the password, but I didn't enter it correctly. Mits tech help was a waste of time. This is so easy, why don't they know about it??? Unfortunately, I don't get a very strong signal from my office router to my livingroom TV, so I don't know if this is worth it or not. (Anyone help me? Do I need a repeater or what?) Hope this helps! -- Mike H

Collapse -
Connection Solved--correction
by mhenry54 / February 20, 2011 11:24 PM PST
In reply to: Connection Solved fingers types "WEB" but I meant "WEP." -- Mike

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?