1. Disable User Account Control and see if they'll delete correctly:

Open the Control Panel (Classic Style), then double click on "User Accounts", then in the "Turn User Account Control (UAC) on or off", UNCHECK the box for "User Account Control". Reboot the computer.

Once that's done, Vista may warn you of the lack of security by throwing a red or yellow warning shield in the lower right corner/system tray. You can disable that as well by opening Control Panel, then the "Security Center" icon, then select the "Don't Notify me and don't display the icon" option.

2. Change permissions and take ownership of the files, then attempt to delete them.

RIGHT click on the folder that contains the files in question, choose "Properties" from the menu, then click the Security tab, and then press the Advanced button...The "Advanced Security Settings for [folder name]" window will appear. Click on the Owner tab and click Edit. Replace the file's original owner with that of your account.

3. If it's malware causing the issue, download, install, update, then run a full system scan using the free malware removal tool from the link below:

Malwarebytes Antimalware

Hope this helps.

Grif