Question

Computer connected to network, but NO internet access

Jul 29, 2016 7:46PM PDT

my computer says its connected to the internet but i have no access. ie, aim, slingbox all things that need internet connection do not work. ive tried all of the obvious solutions (pinging, clearing old internet file cookies etc.) i have this problem in multiple places with my laptop, at work, at home, friends houses and i cant connect to anything anywhere. i have tried lan connections and wireless. i made no changes in any of my settings, just one day it stopped working. please help if u can
thanks

Discussion is locked

Follow
Reply to: Computer connected to network, but NO internet access
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Computer connected to network, but NO internet access
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
There are many reasons.
Jul 29, 2016 7:59PM PDT

The most common I run into is an expired antivirus. What about your phone or other PC?

- Collapse -
Answer
Collapse - winsock fix or default gateway
Jul 29, 2016 8:34PM PDT

These are the first things that come to mind for your problem.

First, go into your Control Panel / Network Connections / either the Local Area Connection Properties or the Wireless Connection Properties, whichever is giving you the trouble / TCP/IP Properties, and make sure that IP address and DNS are set to "automatically obtain." Also click the Advanced button and make sure that nothing is explicitly entered for Default Gateway, nor anything on the DNS tab.

Secondly, run the Winsock fix per this article:
http://support.microsoft.com/kb/811259

If one of these restores functionality, run a full virus scan on your computer, and full malware scans with Spybot and super anti-spyware.

CNET Forums

Forum Info