Computer Help forum

General discussion

Compatible Video s/w for Mac OS 10.4.11

by macplebe / January 22, 2008 3:06 AM PST

Okay starting a new thread here regarding an old problem. What video s/w is compatible with OS 10.4.11? I have iMovie 3.03 and FCE 1.0.0. Will I have any issues with either of these versions? If so, what's the most practical upgrade?
dual 867ghz 756ram

Discussion is locked
You are posting a reply to: Compatible Video s/w for Mac OS 10.4.11
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Compatible Video s/w for Mac OS 10.4.11
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Be sure to look at apple.com
by R. Proffitt Forum moderator / January 22, 2008 3:13 AM PST

I see they usually note the latest versions and what it runs on. You appear to have the fading away from the scene Power PC chips so make plans to move out this year.

Bob

Collapse -
Apple site
by macplebe / January 22, 2008 1:44 PM PST

I'm having trouble locating the iMovie 3.03 download section to read the compatiblity info. When typing iMovie 3.03 in the search engine I got something unrelated. Will try to poke around more to figure it out.
Thanks again

Collapse -
Compatible with what?
by Jimmy Greystone / January 22, 2008 3:27 AM PST

Compatible with what is the question that springs to mind. You neglect to mention what you are planning to use this video software for. Not even so much as a reference to another discussion thread if that aspect has been covered before.

Collapse -
Compatible
by macplebe / January 22, 2008 9:11 AM PST
In reply to: Compatible with what?

meaning, will the versions of iMovie and FCE I have work with that OS version?
In a nutshell, the old thread had to do with my being "unable to export a video project to tape or dvd". I had compatibilty issues with the OS revision and the iMovie version I used to have, and lack of RAM. A project from hell as it were, all self-imposed.
Since I've updated my OS and iMovie, I wonder if they're compatible is all.

Collapse -
They should be
by Jimmy Greystone / January 22, 2008 9:26 AM PST
In reply to: Compatible

They should be, since Apple is still actively supporting 10.4, any recent version of iMovie should work.

Collapse -
Checked the website again
by macplebe / January 22, 2008 1:49 PM PST
In reply to: They should be

okay I'm good to go as it were.The version is compatible. We'll see if I can get the project together and exported. I'll probably update the original "Can't export..." post when I've finished to put some closure on it.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!