"please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended."

I don't see any detail about your laptop and laptops here don't have a device labeled "receiver" so some further explanation could help. However I just fixed a com port error like that by two means.

1. We checked a box in some control panel to "never dial"
2. We disabled the modem in the machine's bios.