Computer Help forum

General discussion

Code 19 on both CD-RW drive and DVD-ROM drive

by M038 / December 13, 2008 11:11 PM PST

Sorry this post is long, but I have been working on this for weeks. I have been down several dead ends.

Computer: Dell Dimension 4550 P4 2.53 GHz 384 Mb RAM. Windows XP Home SP3

Machine had Easy CD creator (Roxio) installed and iTunes (I don?t know which version this was. I don?t know if iTunes was updated in the previous 3-4 weeks, but I believe it was to iTunes 8, possibly 8.02. )

Running McAfee SecurityCenter and Spybot S&D resident.

Running ATI Catalyst software for the video card, VisionTek Radeon 9600

Running Limewire 4.16.6.

Machine picked up a copy of $sys$DRMserver.exe from a copy protected disk.

First indication of trouble: My daughter tried to play a new music CD in the CD-RW drive. It didn?t play, but it would play in her boom box, so I didn?t pay any attention. This was 3-4 weeks back. I figured it was more DRM crud.

Second indication of trouble: She tried to download a song, but it was caught as malware and McAfee prevented her from downloading it.

The other night, she went to play a game using a CD. This game CD has worked in the past, but would not. I asked her to restart the machine, which she did, but it did not clear up the problem.

Discovered both drives have disappeared from My Computer. Checked the Device Manager, they both show up as Code 19, your registry may be damaged.

Tried uninstalling both drives, then restarting the machine. No good. Tried the troubleshooter that comes up after the drives fail to install correctly, without positive result.

Tried uninstalling the drives then rebooting the computer several times.

Uninstalled Easy CD Creator using add/remove programs as directed by 314060.
Used the Microsoft knowledge base article on code 19 errors, article [Q314060].
Used the ?guided help? software, which completed successfully. Did not uninstall iTunes. [Is this a possible problem?]

Tried uninstalling the drives then rebooting the computer several more times.

Tried unplugging the power to the two drives, restarting, shutting the system down, then plugging them back in?no change, still code 19.

Tried uninstalling iTunes (much protesting about losing her music.) I uninstalled the drives several times, all ending in code 19 when the ?new? hardware was recognized.

Uninstalled Spybot S&D. Ran McAfee virtual technician on Security Center, which found and repaired 3 errors.

Downloaded and Installed iTunes 8.0.2 so as to not lose her music.

Regedit shows the upper filters have returned in the class for CD/DVD. ?GEARaspiWDM? is the upper filter.

Googled GEARaspiWDM. Appears to be installed by iTunes, and appears to have issues when ATI Catalyst is running, per posting on zdnet.

Uninstalled iTunes.
Checked that the upper filters were still present in the registry (it was)
Ran the ?guided help? software from Q314060; which ran OK. Uninstalled the drives, then restarted the computer. No joy.

Checked the registry. Upper filter was still in place, apparently not removed by the ?guided help? software. Removed the filter manually. Uninstalled the drives, Restarted the machine, no positive result.

iTunes protests that the drivers for burning to CD are missing.

Tried to run the CD diagnostics from inside iTunes?there were no drives in the drop down, apparently they are still invisible. I could not run the diagnostic.

Downloaded, ran the CDGONE patch from post on CNET: Look and try CDGONE at http://www.aumha.org/regfiles.php

Created restore point. I had to extract the patch from the zip file before I could merge it!

Merged the registry patch OK. Restarted the machine, still no drives, still code 19 registry may be damaged.

Created the UpperFilter GEARAspiWDM from scratch. iTunes no longer protests that it needs re-installed. Both drives are still code 19.

Discussion is locked
You are posting a reply to: Code 19 on both CD-RW drive and DVD-ROM drive
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Code 19 on both CD-RW drive and DVD-ROM drive
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Spybot S&D resident.
by R. Proffitt Forum moderator / December 14, 2008 12:15 AM PST

Limewire are all "trouble."

Let's not worry about iTunes and just use Microsoft's fix at http://support.microsoft.com/kb/314060

Since this machine's owner is running Limewire we know that it's a trouble machine so be sure to tell them it may never be fixed but a reload of the OS may be needed.
Bob

Collapse -
Found a fix
by M038 / February 14, 2009 11:20 AM PST
In reply to: Spybot S&D resident.

I found a link to the removal tool for the SonyBMG DRM crud:

http://cp.sonybmg.com/xcp/english/updates.html

I downloaded and ran the removal tool, and my drives reappeared when I rebooted. My thanks to derekra, who posted this on the Dell forums. This has alleviated 3 months of no access to my DVD/CD drives!

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?