Question

Changed from AHCI to RAID, PC doesn't boot.

I accidentally changed the settings of my drives from AHCI to RAID and now by PC doesn't boot. I am using a 120gb SSD from kingston and a 1tb wd blue hdd, with a z97p-d3 from gigabyte. I tried entering the bios to change the settings back, but I cannot (tried pressing F2 while the system boots, as said in the MB manual). After a screen where I am told to press CTRL-i to enter the configuration (tried it 1000 times, nothing happens), another screen comes up with the error ''Reboot and select a proper boot device). Is there a way to change the setting back to AHCI and boot normally, without losing any files? Thanks

Discussion is locked
Follow
Reply to: Changed from AHCI to RAID, PC doesn't boot.
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Changed from AHCI to RAID, PC doesn't boot.
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Before you make any changes, backup your stuff.

Such a change could corrupt a drive so the first step is to pull the drive and clone it. Now we're safe.

As to the PC BIOS issue, that's a question for the machine's maker or gigabyte. I think this model has a BIOS reset jumper. Try that.

- Collapse -
No reset switch (?)
- Collapse -
It has other names. See picture. Tell me if you see it.

CNET Forums