This is still the same ongoing issue with my hard drive saying the data rate on C is too slow...The Problem: "Data Rate Test: Read: 2545 Kbytes/sec Write: 2372 Kbytes/sec"
"Drive C is not capable of capturing DV data."
I was told to do this:

REGISTRY EDIT TO FORCE DMA FUNCTIONALITY IF TOGGLING DOESN?T CHANGE MODE

Start by making sure the ?Primary Ide Channel/Advanced Settings? tab has ?DMA if available? selected in the ?Transfer Mode? line. This is a very basic registry edit that should fix the issue. The deleted values below will be reset by Windows at the next boot. First, make a backup of the registry. Then click on Start-Run, type ?regedit?, then click on OK. When the Registry Editor loads, go to the following path: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000X

The last four digits will be 0000, 0001, 0002, 0003, and so on.

Click directly on each of the numbered folder/keys, then delete all occurrences of the following values on the right side.:

MasterIdDataChecksum
SlaveIdDataChecksum

Now reboot your system and make sure the DMA Mode has returned to the ?Current Transfer Mode? line on the IDE Channel in ?Device Manager?.




I was directed here:

http://www.intel.com/support/chipsets/sb/CS-009241.htm

I'd start with the Intel