Mac Hardware forum

General discussion

CD/DVD disks suddenly not recognized

Hello, all, I'm back like the proverbial bad penny with a new problem.

I had just backed up my hard disk (on a G4 desktop, Sawtooth model, running OS 10.4.11) to a LaCie drive with Carbon Copy Cloner, which has never been entirely happy doing that. (Long story, maybe not relevant.) Having had several reports of failure to simply do an incremental backup, I decided to try copying the whole of Macintosh HD to the LaCie. Tried that and once again, CCC complained that it couldn't do the job completely and suggested that I click on the box next to the instruction to bypass (ignore?) files on the LaCie that were not on the Mac HD. There still were some errors, but I decided that was good enough. (I had done all the diagnostics for the permissions and disk before starting CCC.)

Then I wanted to burn the contents of either my Macintosh HD or the LaCie (now presumably identical)to a DVD/RW disk. I started by making a new Burn Folder after checking out how to do it in Mac Help, but the DVD/RW disk I put into my external HD didn't show up on the desktop. I tried a CD-R disk. That didn't show up, either, nor did a commercially prepared disk. All this for a drive that I used only a day or two ago with total success.

I switched the Firewire cable to another Firewire outlet on my G4, unplugged the device for a while, put the power cord of the external drive into another outlet, everything I could think of. And I ditched the DVD player preference file. I used Disk Warrior and checked the permissions with Disk Utility. I verified the hard drive with Disk Utility, too, and it passed with flying colors. All to no avail.

Of course, I can't clean the lens, because that requires that the device recognize that it has something inside. I can't use the internal device that came in my Mac for burning disks: It only deals with DVD-ROM, I believe, and I know it can't write CDs?though I can play CDs and DVDs in it.

- Do you think I did something when I was studiously trying to set up a burn folder for the contents of my drive? (I also investigated disk images and such, but I don't think I clicked on anything.)

- Could it be owing to my strange odyssey with Carbon Copy Cloner, which definitely disapproved of some of what was on my hard drive?

- Do you think there is anything I can try to repair this problem? I don't know whether my Mac isn't recognizing the device or the disk, or the device is not recognizing that it has a disk inside. I certainly can hear the thing turn on and hum busily, but it doesn't make that comforting clicking sound that one gets when a drive is preparing to do its thing with a disk.

I considered booting up from my Tiger OS disk (after I had discarded my Finder pref to deal with another problem), but I really don't know what I would want to do with it, nor whether the problem is with my external SuperDrive or with some software. Any ideas, anyone? This was so sudden that it could well be owing to either source. Or to Carbon Copy Cloner (which is unlikely).

Thanks for reading this long saga. I hope to cull your wisdom, but at least, my difficulties may also inform others, should they fall into this same pit.

All the best,


Discussion is locked
You are posting a reply to: CD/DVD disks suddenly not recognized
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: CD/DVD disks suddenly not recognized
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Try this,,

In reply to: CD/DVD disks suddenly not recognized

shut down the G4
Remove all connections from it, including the power supply
Remove the battery
Press the power button on the front
Go get a cup of coffee and a sandwich
Fast forward 20 minutes
Put the battery back in
Press the CUDA button, Once. (Next to the battery holder)
Reconnect the Keyboard & Mouse
Ditto the power cord
Start it up.
Once booted, connect the external LaCie drive to the Firewire port and power it up
Stick a commercial DVD in it.
DId it mount?

I recently lost a LaCie CD burner because the Firewire interface in the external case, failed. CD drive was fine.

Good Luck


Collapse -
Do I hear hoofbeats?

In reply to: Try this,,

Ah, it's the cavalry. Sorry, I wasn't expecting such a prompt answer, and this may take a bit of time. I've found the instructions for removing the battery and the diagram showing where it is (but no picture of the CUDA button, though I'm sure I can find that, too). I just don't know whether I shall be able to do this tonight. Like Robert Frost I have "miles to go before I sleep." Not literally; just a whole lot to do.

I'll be back as soon as I can and shall let you know what happened. Meanwhile, many thanks.


Collapse -
Nothing, nada, niente, niechevo. . . .

In reply to: Do I hear hoofbeats?

In other words, after doing everything you told me to do (having looked at what the Apple Support materials said about where to find the CUDA buttom (that is, there was a diagram) and a few other little things, such as where to touch the computer to dispel static and so on, I plugged in the mouse, keyboard and monitor. At first, the monitor stayed blank, though it was clear that the computer was booting up, but after a very short panic, I unplugged the monitor for a while (I think it was about the same twenty minutes you suggested for resetting the battery) and then replugged it. It came up fine.

But when I plugged in the external CD/DVD device(it's a Sony, I think, the LaCie being an external hard drive), it still would not play anything. It turns on, and something whirs around inside very cheerfully, so it sounds alive, as far as that goes, but communication between the computer and the device clearly is not happening.

Is there some preference file that I can dispose of? Is there any other thing you can suggest? It happened so suddenly, and seemingly because of my little adventure with Carbon Copy Cloner, that I am still hoping that it's not a failed connection at the place where I connect the drive to the computer. I'm going to try removing the cords at both ends overnight and see what happens. My experience with the monitor was very encouraging.

I did run Disk Warrior, by the way, and nothing showed up as a change or need for repairs. I can run Disk Utility, too, but I doubt that it will find anything in the permissions and on the disk, but it's hard to say what will happen. Zap the PRAM? Seems to me I've already done that by taking the battery out and putting it back.

So, in long, that's the next stage in the saga. I'm hoping for a resurrection, somehow, but once I've done what I've laid out here, I shall have reached the end of my thoughts on this subject. If you have anything further in the way of ideas, please send them. Right now, it's late, and I must get some sleep.

Thanks again. I'm sure that whatever happens with the drive, my computer will be the better for having its battery refreshed.


Collapse -
Not the result we were after,

In reply to: Nothing, nada, niente, niechevo. . . .

but, all is not lost.

Do you have any other Firewire device?

If so, does it mount on the desktop? If yes, then the good news is that the Firewire controller is still working and the problem may lay with the interface at the Sony device.

If the other device does not mount, we must suspect the controller. Fortunately these can be replaced with a PCI Firewire card and these are very cheap. Firewire/USB 2.0 combo is a good way to go.


Collapse -
Must go, but

In reply to: Not the result we were after,

yes, I have an external hard drive (the LaCie that was mentioned) with Firewire, and it shows up fine.

Why in the world would the device's interface just fail, when the device wasn't dropped and everything showed up beautifully, just a day or two before? Is there anything else I can do?

Still w

Collapse -
Last gasp

In reply to: Not the result we were after,

Tried unplugging the Sony external CD/DVD player on both ends of the cable, leaving it unplugged for hours, then replugging. No effect. (The device clearly is on, though.) Switched Firewire ports, both on the Mac and the Sony device. Ditto. Tried the device on USB. The disk I was trying to see didn't show up with that, either. Looks like it's not a question of Firewire, that the device (the newest I have) just started malfunctioning after that ill-fated attempt with Carbon Copy Cloner, and then using Disk Utility?though I never even got started with that beyond making a new (empty) Burn folder.

One thing has happened, though: As opposed to earlier attempts, when I could hear the drive running but there was no other sound, I now hear not only the whirring of the drive, but a "chuck, chuck" noise similar to what used to happen when I used to put a disk into the drive, but one that stops immediately after that. I've tried turning the drive off and on several times, and it does sound as though it's trying to do its thing, but I can't get it to go any further than that tantalizing beginning. Of course, it could have no meaning at all, but isn't that strange?

Is there no preference file I could try to eliminate? Is this surely the device's problem, and not some software weirdness? I know I'm clutching at straws; it just seems odd that it would have started so suddenly and that the device sounds so alive, with its whirring, and seems to start the work of digesting the disk's contents, if only for the briefest of moments. Well, maybe I've run the course with this. Maybe I need to get a new device or have this one fixed (if such a thing is possible).

Thanks for the suggestions. If there's anything further I can do, please let me know; if not, thanks and that's it.


Collapse -
Such a way with words,

In reply to: Last gasp

Sorry, there is no preference file that will magically fix this problem and the "Chuck Chuck" sound is only there to lull you into a false sense of security.

I don't recall you mentioning if you had another Firewire or USB device attached to the G4 that was functioning correctly.
My STM is not always that good, you may have mentioned it, but if you do, (I get paid by the comma) is it still functioning?

I had a LaCie that exhibited the same symptoms as yours and the problem turned out to be the interface board in the LaCie case.

Electro/Mechanical devices have a habit of failing suddenly, and without warning. Most inconsiderate and highly inconvenient but it is a trait that is apparently built in to every one of these devices, right down to the lowly light bulb. Notice that they always worked the last time you turned them on!

I don't think that CCC had anything to do with the current problem, I think it's more a case of "it's the Sony's time"


Collapse -

In reply to: Such a way with words,

Yes, I do have another Firewire device (that is the LaCie, an external hard drive/backup device), and it works fine. It occurred to me that I might try the LaCie's cables with the device that isn't working, but I was afraid I'd make a bad situation worse?if the cables even could be switched. I truly doubt it would work. You are undoubtedly right that the explanation is simple but not that *kind* of simple.

The Sony (the bad child here) can use either Firewire or USB, and I tried both kinds of cable, to no avail. I even switched the ends of the cables around, from port to port, unplugged things, all that. No drive or disk showed up. I guess this is the end of the road for that drive.

Well, that all is really too bad?especially, because I bought the thing to burn disks?something that my internal CD/DVD drive couldn't do?and play some kinds of disks that the G4's drive couldn't.(Remember, it's the one I got from OWC that had feet and that I couldn't fit into my computer properly? The one for which I had to get an enclosure after that? A model of Sony that was sent to me in place of another brand that you had recommended? A model that must have been outdated, because no model with that number could be found at Sony's Web site?) And it's the youngest piece of computer equipment I own! Verry annoying!

OK, my modest little rant is over. (I can do a much better one, but I'm too tired.) Now I must consider whether I want to invest in another drive to use with my old baby, the G4, and Tiger. For the immediate present, I'll just do my backing up on the LaCie and pray. And maybe get Super Duper for that?assuming that any recent version of SD works with Tiger and a non-Intel Mac. CCC doesn't seem to like some of my files, even after I've gone through the ministrations of of diagnostic and repair software and found nothing wrong with my files or the hard drive. Lots of people think that SD is better, anyway. Or I'll just keep on slogging through manual backup onto the LaCie drive, forget about burning, and so on, until I move on to a new computer and OS. Too much thinking for my little brain, right now, to decide *anything.*

Disgruntled though I am, I do thank you again for all the trouble you put into this, and for the patient explanations. I always learn a lot, even when the news is not what I want to hear. I trust that you are sleeping the sleep of the just tonight. You've earned it.

Oh, and thanks for the compliment in your message title. Most kind of you to sweeten the bitter pill of my drive's being the mechanical equivalent of brain dead.


Collapse -
La Cie

In reply to: Such a way with words,

mrmacfixit said:

"I had a LaCie that exhibited the same symptoms as yours and the problem turned out to be the interface board in the LaCie case."

I am not happy with LaCie drives. I had two, both only 18 months old, both of which failed within a week of each other a year ago. The fault turned out to be in the internal power supply circuitry (not the external power supply). The data on the drives was still there which I got recovered (at considerable expense). I don't buy LaCie after that.

Collapse -
If you ever suspect the power supply or interface board,

In reply to: La Cie

which actually supplies the power to the drive, remove the drive and pop it into another enclosure.

All data is then recoverable at no expense.


Collapse -
What a shame, Steve

In reply to: If you ever suspect the power supply or interface board,

That's bad luck. My LaCie (external backup) drive is a sturdy little honey.

I hope your problem gets solved soon. Listen to mrmacfixit. He's helped me a lot.


Collapse -
Now it's the printer!

In reply to: Nothing, nada, niente, niechevo. . . .

I said, in the preceding message that the monitor seemed to have given up after I took out and replaced the internal battery (and pressed the CUDA button), but I had revived it by removing the plug for a long while and then replugging it. (It's back to 2008, when also I lost communication between printer and computer after moving my equipment.)

Well, the printer didn't work, either. It uses AsanteTalk to allow it to use Ethernet to connect to the computer. I wrote to Asante and got some instructions, including to delete my printer from the printer list and then add it. Well, although Tiger (10.4.11) has a driver for my HP 4ML, nothing shows up. I can't add it, no way, no how (to quote Tweedledum and Tweedledee, from the Disney Alice in Wonderland). I tried reinstalling the printer software, the version that worked for all this time, but again, nothing showed up in the Print Utility, even after hitting "More printers."

I seem to recall someone suggesting an order of attaching the various parts of the chain, once I get the printer back on the printer list (well,"got," because that was back in '08, and again my printer is lost), but for now, can anyone suggest a way to get my printer back on the list? This is bizarre: I do something that is supposed to make things improve, and mayhem ensues.

The computer (yes, yes, I know) is my G4 desktop (Sawtooth), and the printer is the HP 4ML. (Please don't sneer; it's not becoming to you.) And for all this, I still can't use that pesky CD/DVD burner! I'm resigned to that, but this is just a bit much.

Grump, grump, but thanks, in advance.


Collapse -
System Preferences,

In reply to: Now it's the printer!

and make sure that AppleTalk is turned on in the Network section.

Pressing the CUDA and removing the battery will have put everything back to basic state and that may mean that AppleTalk is turned off.


Collapse -
AppleTalk definitely on.

In reply to: System Preferences,

I checked it long before I asked for help from Asante. It was their idea for me to delete my printer's name, and I'm really sorry I did it, but like some unspeakable people of the past century, "I was just following orders."

This happened once before, in 2008, when all I did was unplug cords to move my equipment to another room. I would have thought that because Tiger supports my printer, there would have been no problem. Last time, I not only had to get the computer to reinstate my printer in the Printer List (not an easy task, and I wish I had taken down the particulars), but attach the cords of each part of the chain in a special order. It's like alchemy. Kind of. It shouldn't be so difficult.

Thanks for the message, though. Always appreciated.


Collapse -
CD/DVD disks suddenly not recognized

In reply to: Try this,,

I have a powerbook G4 - and the external DVD player just would not write.
The failure was intermittent but fairly predictable.
The DVD player worked fine when it was straight out of the box but as soon as I started moving it between devices I had no end of trouble with it.

It's a HP DVD 1040. It's USB but at the time it was the only thing i could grab that claimed to be approximately compatible with a Mac.

I've tried disconnecting things and powering all the devices up in different orders before. Sometimes it writes one disc but won't acknowledge a second. This is the first time I've disconnected the battery pack since owning the machine .... and it works!

But why does the magic only happen when you're drinking coffee?

Thanks for this tip!

Collapse -
It also works with

In reply to: CD/DVD disks suddenly not recognized

Wine, (White or Red), Scotch, Bourbon, Beer, (canned or draught), Vodka, Tequila and Margaritas.

Perhaps the instructions should say, "Insert beverage of your choice"

Glad it worked for you


Popular Forums

Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Best Black Friday Deals

CNET editors are busy culling the list and highlighting what we think are the best deals out there this holiday season.