Question

Can't review security settings

I've been ignoring MS requests to update my security settings but now they say I must. It says "select security settings" but there's no "security settings" button. It looks like this but the big blue button isn't there:

I can't do anything except re-boot, then it comes back.
I guess the problem may be because it needs Admin rights, but it's my own computer and I have no other users so how can I not have Admin rights?

Discussion is locked

Follow
Reply to: Can't review security settings
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't review security settings
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Re: administrator

In Control Panel or in Settings go to users to check if you really have admin rights. It's easy to see.

Since you write you can't do anything except rebooting see if you can do it after booting into Safe Mode. It just might be that it doesn't do this check then.
https://win10tips.net/windows-10-safe-mode/ tells how to boot into safe mode. You might need the recovery drive you made (you made it, didn't you?) or a fresh bootable install disc or stick you have to make with the Windows Media Creation Tool on another PC.

Once you have that bootable disc or stick, you can use it to install the Creators Update and after that Windows won't ask this question again. Two things to do after installing:
1. Carefully check if the privacy settings are as you prefer.
2. Make that recovery drive.

Post was last edited on August 4, 2017 4:29 AM PDT

- Collapse -
Sort of working but problem not solved

Thanks for that.
I tried to restart in safe mode using shift-restart. It restarted but with a blank screen. I forced a reboot and it came up working, without the Microsoft “You must review your security settings” dead-end screen.

I checked if I am an Administrator and I am, so that wasn’t the reason why the “Review your security settings” screen doesn’t show a button to do it.

It’s sort of workable for now. If I let it go to sleep it comes up with the dead-end screen again but I just have to shift-reboot and it’s ok. It takes a while, but it's no use expecting Win10 to be available just when you need it anyway. Shift-reboot does not give me any options such as safe mode, it just works normally.

I then went to my security settings and altered some of them, hoping it would look as though I have “reviewed my security settings” but that didn’t solve the problem.

I don’t know if I want or need “Creators update” but it seems I have no choice. I need to “review my security settings” first and there’s no clue as to how I do that. Manually reviewing the settings in “Updates and Security” is apparently not enough. The button to do it is missing off the message screen so what else can i do?

- Collapse -
what happens if you turn off Fast Boot?

It should do the same thing as your current "fix" since it abandons use of a hibernation file and does a fresh reboot each time.

CNET Forums

Forum Info