Networking & Wireless forum

Question

Can't port forward on EchoLife HG-520c

by mpasd / April 3, 2016 9:22 AM PDT
Starting of with my pc build:
Gigabyte EP43-DS3L
Intel Core 2 Quad Q8200
4gb RAM - DDR2
NVIDIA GeForce 9600 GT

My modem is Huawei EchoLife HG520c (actually i'm not sure what the difference between modem and router is, i think mine is both combined..)
Firmware Release: 3.10.29.0-1.0.7.0
Tried finding an update but the only thing i found gave me:
ERROR: FAIL TO UPDATE DUE TO... The uploaded file was not accepted by the router.
Internet provider is Telekom Serbia: https://www.mts.rs/
Connection type: ADSL

I got 2 tv's connected to my modem as well as my pc of course.. Other than that i use wi-fi for my phone and tablet.


Weird thing is i had ports opened before and it worked. I'm not talking about any specific port for a game and/or software, i can't open any port.

What i tried so far is:
- To open ports by myself, like before
- Then i tried with Simple Port Forwarding
- At first it was a dynamic ip address, changed it to static, still nothing
- Then i found some program that detected 3 routers:
http://i.imgur.com/vPj4zdu.png
But then i checked with Network Utilities and it shows only one:
http://i.imgur.com/8Z3rN7a.png
- Both simple port forwading and network utilities show a fail on every port i try to open:
http://i.imgur.com/kUh53g0.png
http://i.imgur.com/WhB98V4.png
- I have Avast antivirus. Tried disabling it, and i even tried uninstalling it completely, same thing...
- My windows firewall has been disabled before, same with modem firewall...
- This program that is supposed to detect possible firewalls finds nothing:
http://i.imgur.com/q5xe2XK.png
- Restoring modem to factory default settings...

I think that's all so far.
Would really appreciate any feedback. Thanks in advance...
Discussion is locked
You are posting a reply to: Can't port forward on EchoLife HG-520c
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't port forward on EchoLife HG-520c
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Clarification Request
What are we trying to fix?
by R. Proffitt Forum moderator / April 3, 2016 9:50 AM PDT

I read your post twice and can't see why we need port forwarding. Sometimes an app needs broader access but I don't see what is causing the need to port forward so I can't offer alternatives.

As to the firmware update, many of the ISP supplied models are "special." Back to the ISP which supplied it for instructions on how to update.

Tell more.

Collapse -
...
by mpasd / April 3, 2016 9:54 AM PDT

I am trying to open ports primarily for games.

Before i had ports opened for Tunngle, minecraft and counter strike.
What i'm trying to do is open ports so that people could join my lan game in cs 1.6.

That was the main reason behind port forwarding. But at this point, it is just annoying me that i can't do it, when i could do it just a couple of months ago...

Collapse -
My son played those without changes to the router.
by R. Proffitt Forum moderator / April 3, 2016 10:03 AM PDT
In reply to: ...

But if you are hosting a game the incoming requests should fail.

Since you may have to wait for ISP to support this router modem, you may want to go all stock then put the "server" into the DMZ entry on the router. The DMZ and more is on the web about what it does so i don't write much more than that.

Collapse -
...
by mpasd / April 3, 2016 10:18 AM PDT

I tried putting DMZ on , wasn't sure about that ip address, but nothing happened...
I tried opening a random port like 23456, then tunngle one 11155, even tunngle said it wasn't opened and it had a problem...

Lets focus on cs 1.6 then, i have steam version of cs 1.6 and i want people to be able to see and join my lan game, anytime...

Collapse -
There are many articles about using DMZ.
by R. Proffitt Forum moderator / April 3, 2016 11:17 AM PDT
In reply to: ...

There has so far been no way to "put DMZ on." It's an entry on many routers that you put the LAN IP of the machine you are serving up something on.

Then you have the firewall issues in most Windows PCs. Due to everyone asking for more security you find folk writing "it worked before." That is, maybe it did but many antivirus suites update to add more protection as well as Windows.

DMZ has yet to fail for me or folk I know. But your words are a little off. There was never a way to put DMZ on. It's a setting with one entry on hundreds of routers so far.

Collapse -
About dmz
by mpasd / April 3, 2016 11:33 AM PDT

I meant this:
http://prntscr.com/anoxlz

Whatever i put under DMZ Host IP Address , i get nothing different.
And i have read that it is supposed to open every port, and is not recommended to use. So i would like to avoid using it if possible.

Like i said every firewall is disabled, i even tried with no antivirus installed, still the same...

Collapse -
The reason I use it is
by R. Proffitt Forum moderator / April 3, 2016 11:44 AM PDT
In reply to: About dmz

That unless it works on the DMZ then the issue is not port forwarding. Since you can't get it to work with the DMZ then you won't get it to work with port forwarding.

That means you look for the other reasons it fails. Sometimes it's the ISP. Many ISPs block inbound connections "for your protection."

Get DMZ working first.

Your post still reads as if you are new to networking. That's only one thing to put into the DMZ field. You've read enough so in short, the LAN IP of the machine that's serving up the game or such.

Collapse -
...
by mpasd / April 3, 2016 11:53 AM PDT
In reply to: The reason I use it is

I did use my local ip address, this one:
http://prntscr.com/anpadn

I am not sure , but i think i got this problem after my network card fried and i had to buy a new one. Not sure if that can affect anything...

Collapse -
The DMZ would not be the Default Gateway IP.
by R. Proffitt Forum moderator / April 3, 2016 12:11 PM PDT
In reply to: ...

Many LANs on routers use the 192.168.0.x range. So the IP is of the server's IP on the LAN. I can see why it won't work.

If you did this to your port forwards those would fail. too.

Collapse -
...
by mpasd / April 3, 2016 12:13 PM PDT

Okay, now i'm confused...

For opening ports i used my IPv4 Address , not the default gateway...
Was that wrong or?

Collapse -
So far I've yet to use the GW IP.
by R. Proffitt Forum moderator / April 3, 2016 12:28 PM PDT
In reply to: ...

I took it for granted you did this before.

On the router, port forward would be the destination IP which is the server's LAN IP. Same for DMZ.

Again, if you can't get DMZ to work, port forward won't work either.

Correct your mistakes and try again.

Collapse -
DMZ
by mpasd / April 3, 2016 12:31 PM PDT

I have already started googling about why dmz is not working.

Do you have any idea why DMZ won't work for me?

Collapse -
You wrote why above.
by R. Proffitt Forum moderator / April 3, 2016 12:37 PM PDT
In reply to: DMZ

Your screenshot showed the Gateway IP address and if you put that into your DMZ entry, then it should not work.

Same for port forwards.

I've written many times which IP to put in there for both DMZ and later when you get it working and you want to go back to port forwarding.

Collapse -
...
by mpasd / April 3, 2016 12:40 PM PDT
In reply to: You wrote why above.

I am sorry but i am just getting more and more confused by all of this...
I do not know what you mean by destination ip...

Can you just tell me from this screenshot:
http://prntscr.com/anpadn
what to use in the empty field for DMZ?

Or if it's not there , tell me where to find it ...

So far i have tried that default gateway and IPv4 address there...

Collapse -
For me it's the server's IPV4 address
by R. Proffitt Forum moderator / April 3, 2016 1:11 PM PDT
In reply to: ...

I'm a little confused too. Your top post sounded like you port forwarded before. I don't mind folk leaving out details but it sounds as if you are doing something you never did before,

Collapse -
...
by mpasd / April 3, 2016 1:15 PM PDT

You confused me lol...

I had ports opened before, i just filled out a page under BASIC - NAT - Port Forwarding, and everything worked.

It was when i entered Tunngle that i found out that the ports i had opened before and were working, are not working anymore.

Before i got a green light in Network Utilities. Now, no matter what i do i get that ports are not opened.

I tried using IPv4 address in DMZ ip field, but it still showed up as not opened...

Collapse -
Remember
by R. Proffitt Forum moderator / April 4, 2016 7:50 AM PDT
In reply to: ...

You seemed unsure about what address to put into the DMZ entry and did not share your LAN IP which can't be used to attack you.

I think you're stuck with your ISP support here.

Again, you claim you did it before but in this thread you seemed to show you put the gateway IP in and not what we usually use. This makes me doubt you are doing this correctly as you seem unsure of what IP to put into the DMZ or other entries.

Finally we have ISPs that block game servers. You must find out if they block servers.

Collapse -
...
by mpasd / April 4, 2016 8:02 AM PDT
In reply to: Remember

I was only unsure of it because it said "DMZ Host IP Address" , so i didn't know what address to put. That has nothing to do with me port forwarding before. First i went with IPv4 and when i saw it didn't work i tried with everything else i can find.
Before this all i had to do was set a static ip address and type in a port that i want to open. But now i searched 100 forums about this, and haven't found a single thread that resembles my problem and has been solved...

I don't see a reason behind posting my lan address when you say i shouldn't use it for anything...

About my ISP, i have been with them for many years, and not once did i had this problem. So if they weren't blocking anything for 5+ years, why would they start now... And also this is the same modem/router i had before, that had ports opened...

I have found something about setting a static ip address in my WAN settings, do you think that might have something to do with my problem? Because i can't getting it to work, keeps reporting duplicate ip, and i didn't want to search anymore..

Collapse -
This is why you give me the LAN addresses.
by R. Proffitt Forum moderator / April 4, 2016 8:39 AM PDT
In reply to: ...

That way I can write specifically what the IP for the DMZ is.

Since there's no way for me or others to exploit this, your choice to hamper help or not.

Since it's gone this far without resolution and you've elected not to share details, I have to send you back to the ISP.

Mind you that you still need to control your Firewalls in both router and PC. But we never made it off the starting blocks here after this many posts.

All Answers

Collapse -
Answer
a lot of confusion in thread
by James Denison / April 4, 2016 8:26 AM PDT

first,you wanted to upgrade the firmware and was probably and properly told the upgrade you wanted to use was an incorrect one. Forget the upgrade, shouldn't be necessary for game playing.

DMZ = "de-militarized zone" meaning an area that neither side in a war or battle controls. In internet use it means nothing between a computer and the internet, but the internet is passed directly to the IP address of the computer assigned as the DMZ computer facing the internet. If the computer facing the internet directly has no server on it, or software that will interact directly with internet incoming requests, then you still have no information flow between the internet and the computer. Of course you need the router to know where the DMZ is supposed to be used. If you use Dynamic IP address assignment, then that can change and it's dangerous, so any computer assigned as DMZ should also have an internal static IP address on the LAN.

For instance your gateway may be 192.168.1.1 and the computer you want as the DMZ computer is assigned 192.168.1.5, so you need to set that IP address as Static IP to that computer's name and/or MAC.

As for port forwarding, still for gaming is to assign a static ip on your home LAN to the computer used for gaming, and you check the game and what ports it needs to use and make sure all incoming traffic on those ports are forwarded to that computer's IP address.

http://compnetworking.about.com/cs/networksecurity/g/bldef_dmz.htm

https://en.wikipedia.org/wiki/Port_forwarding

http://www.linksys.com/us/support-article?articleNum=136791

http://www.extremetech.com/computing/83298-how-to-configure-your-router-for-gaming

http://www.pcmag.com/article2/0,2817,2399412,00.asp

Collapse -
Answer
Lets start over
by mpasd / April 4, 2016 9:57 AM PDT

I appreciate your efforts and you sticking with me through all this posts.
I would like to clarify something right now.

I am neither new to this , nor am i highly skilled at it. I admit i did not know what ip addresses i could post and what i couldn't, so i decided a safest way to do this is to not post any...

My local ip address and the address i use to access my router options is "192.168.1.1".
From now on if you are still with me , i would like you to post as if i was new to all of this, to avoid any further confusion...

I will read everything James Denison posted and will make a new answer if anything from there helped me.

Again , thanks for sticking with me so far... Also R. Proffitt i am not deliberately trying to not give out some information, i just did not understand what you were trying to say to me.
Please do ask for any further information if needed, and i'm sorry for this confusion.

Collapse -
The only addresses that you should not share are
by R. Proffitt Forum moderator / April 4, 2016 10:40 AM PDT
In reply to: Lets start over

The external IP of your router. That's known by many as your "Internet IP" and maybe by other names.

It's OK to share your LAN addresses since 192.168.n.n is non-routeable and can't be attacked from the web. Same about the DNS, netmask and your gateway IP (which is a LAN IP address.)

Since port forward fails, what I do is test with the DMZ. DMZ must work before I go back to try port forwarding again.

Here's my IPCONFIG /ALL. Can you share what you think you can exploit there?


Windows IP Configuration

Host Name . . . . . . . . . . . . : sli62
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : lan

Wireless LAN adapter Local Area Connection* 12:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
Physical Address. . . . . . . . . : 68-17-29-E0-41-A1
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Bluetooth Network Connection:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Bluetooth Device (Personal Area Network)
Physical Address. . . . . . . . . : 68-17-29-E0-41-A4
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Ethernet adapter Ethernet:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Qualcomm Atheros AR8171/8175 PCI-E Gigabit Ethernet Controller (NDIS 6.30)
Physical Address. . . . . . . . . : 28-D2-44-22-87-79
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes

Wireless LAN adapter Wi-Fi:

Connection-specific DNS Suffix . : lan
Description . . . . . . . . . . . : Intel(R) Centrino(R) Wireless-N 2230
Physical Address. . . . . . . . . : 68-17-29-E0-41-A1
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Link-local IPv6 Address . . . . . : fe80::81f9:ee89:8185:998a%3(Preferred)
IPv4 Address. . . . . . . . . . . : 192.168.0.149(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : Monday, April 4, 2016 7:36:33 AM
Lease Expires . . . . . . . . . . : Monday, April 4, 2016 12:25:00 PM
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DHCPv6 IAID . . . . . . . . . . . : 258479912
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-19-D5-A6-B2-68-17-29-E0-41-A1
DNS Servers . . . . . . . . . . . : 2.4.4.1
8.8.8.8
NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Local Area Connection* 14:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:79fd:2432:813:3f57:ff6a(Preferred)
Link-local IPv6 Address . . . . . : fe80::2432:813:3f57:ff6a%7(Preferred)
Default Gateway . . . . . . . . . : ::
DHCPv6 IAID . . . . . . . . . . . : 167772160
DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-18-D5-A6-B2-68-17-29-E0-41-A1
NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.lan:

Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes

Post was last edited on April 4, 2016 10:41 AM PDT

Collapse -
...
by mpasd / April 4, 2016 11:13 AM PDT

Ok, here is my ipconfig:

http://pastebin.com/ihDn1gNa
I didn't provide my computer name and my ipv4 address because i'm still a little bit skeptical about those. Forums like toms hardware require you to remove those addresses.
So i think they are not needed...

Collapse -
Then I have to defer back to your ISP.
by R. Proffitt Forum moderator / April 4, 2016 11:38 AM PDT
In reply to: ...

In my example
IPv4 Address. . . . . . . . . . . : 192.168.0.149(Preferred)

Can't be attacked and well, must we repeat why?

Anyhow as you won't share, I can't be more specific and back to your ISP to sort it all out.

Collapse -
ipv4
by mpasd / April 4, 2016 11:43 AM PDT

192.168.1.176

There you go , i don't see how this is so valuable though..
Now you have all info...

Collapse -
OK, on the router remove all the port forward rules
by R. Proffitt Forum moderator / April 4, 2016 11:49 AM PDT
In reply to: ipv4

And put 192.168.1.176 into the DMZ.

Some routers need a reboot on such changes. Now your PC should be receiving network requests in the clear UNLESS there is an ISP block or some firewall we have yet to turn off.

I also see Hamachi which is a VPN so you know that for everyday networking and gaming we don't use a VPN as that could block access to other things on our LAN. I've run into printer issues with that. Just so you know.

Finally, you HARD ASSIGNED the client IP. I can't guess why but here I use DHCP and notice the Preferred in my IP? That way I can serve up something and port forward and it works. That is, if this fails I'd go back to DHCP then change the DMZ to match my DHCP'd client IP and retest.

Collapse -
PS. Just in case your network stack is corrupt.
by R. Proffitt Forum moderator / April 4, 2016 11:54 AM PDT

Run

netsh winsock show catalog

And make sure they only have stock entries.

To reset I suggest

netsh winsock reset all

Collapse -
the IPv6 could be decrypted for the IPv4
by James Denison / April 4, 2016 11:45 AM PDT
Collapse -
The LAN addreses of 192.168.n.n
by R. Proffitt Forum moderator / April 4, 2016 11:54 AM PDT

Are used by millions so this is quite doubtful.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!