Question

Can't connect to smarthub with RCN Internet

I recently purchased a samsung 55" 4K tv, model UN55JU6500FXZA. I did have ATT U-Verse and I was able to connect and use the apps just fine. I switched to RCN for faster internet and the smart hub will not work with it. My computer/phone/xbox connects to the internet and works; but not Smarthub. I've tried the Wifi and hard-wired in and neither work. It says it's connected to the internet, but no apps will load. If I switch back to U-Verse wifi, the smarthub works fine again. Neither RCN or Samsung customer service was able to help; any suggestions? Thank you.

Discussion is locked
Follow
Reply to: Can't connect to smarthub with RCN Internet
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't connect to smarthub with RCN Internet
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Clarification Request
Did either ask you to try the other DNS entry?

Try 8.8.8.8 next time.

Samsung usually goes over resets, firmware and the DNS. Be sure the date and time are set in the TV to your local time.

- Collapse -
Answer
Re: Internet.

I'm sorry to hear this! I would try what bob stated above, try changing the DNS to 8.8.8.8 or 4.2.2.1.

If the firmware is completely up to date some questions that may be asked would be how far away is the router from the television? We usually recommend about 15 to 20 feet for a good secure connection.

You can also try changing your prioritization settings in the router and making television top priority.

Regards,
HD Tech

CNET Forums