Windows Legacy OS forum

General discussion

Cant boot into ANYTHING :(

by treminaor / March 1, 2008 11:36 AM PST

Ok, I am pretty computer-savy and I useually know what I am doing and more, but I am stumpted on this one. I am running a Dell XPS 600 Windows XP Media Center system(is this the same as Prefessional, except with more features?) and I have a DELL Operating System DVD (Not a CD-ROM) and I cannot boot into windows. This started when I wanted to boot into Windows Setup to preform a repair install. My computer gave me an error saying that I was missing hal.dll and I could not boot into setup. I went into windows and even though i did indeed have the hal.dll file, I thought maybe it was corrupt. Here's the part where I screwed up. I accidently replaced it with a Windows 2k hal.dll from I have a backup located on the drive, but I can;t get into Windows anymore now, either. It says that crucial system files are missing that are required for boot and that I need to contact my system administrator. So now I cant boot into anything but Recovery Console because I have it in my Bot Cfg. i tried to just format my drive and start from scratch by using "format C: /Q /FS:NTFS" and then I hit "yes" to format, but I does nothing and gives me another "C:WINDOWS>" prompt. I REALLY dont want to talk to some indian guy on DELL support for an hour, so do you uys have any ideas?

Discussion is locked
You are posting a reply to: Cant boot into ANYTHING :(
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Cant boot into ANYTHING :(
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
First, you can't format from within Windows ...
by Edward ODaniel / March 1, 2008 12:29 PM PST

because Windows doesn't allow you to format the system drive.

If you really want a fresh install just place the installation disk in the DVD drive then ensure that the DVD drive is your first boot device and reboot the computer.

When the DVD boots instead of performing the repair you simply choose to install and pay attention to the prompts. There will come a point where you can choose to delete the partition and install fresh - do so.

Collapse -
by treminaor / March 2, 2008 1:46 AM PST

I cant boot the DVD beasue it tells me that hal.dll is missing. I have tried rebuilding my bootcfg but it does not help. I I did not know that I could not format my windows drive from the repair console. What are my options exactly? my goal is really just to get back ito a working Windows environment. I dont really care about the data on my hard drive,, since all of my important things are on my second hard drive. Excuse me for my horrible typing, for I am using a PS3 controller and browser at the moment...

Collapse -
I may not have fully understood your wording ...
by Edward ODaniel / March 2, 2008 3:30 AM PST
In reply to: Crap


So now I cant boot into anything but Recovery Console because I have it in my Bot Cfg. i tried to just format my drive and start from scratch by using "format C: /Q /FS:NTFS" and then I hit "yes" to format, but I does nothing and gives me another "C:WINDOWS>" prompt.

Appeared to indicate that you were booting your installation disk and choosing the Repair option. Your latest response now makes it appear that you have the Recovery Console installed to your hard drive as a boot option. You should be able to reformat from the Recovery Console but I have only done such from the Recovery Console via the installation disk which has a presence only on the CD/DVD and in RAM.

Are you POSITIVE that you have first placed the installation DVD into the drive then rebooted and IMMEDIATELY accessed your CMOS to change the boot order so the DVD drive is the FIRST bootable drive? If not you will keep getting the hal error if there is a problem with the improper hal. Humor me and do this as I have NEVER seen any HAL error initiated while booting from the installation media.

You could also verify the boot order by attempting to boot a Linux Live CD.

Collapse -
by treminaor / March 2, 2008 6:22 AM PST

I am sorry that my post was not very clear. I was frantic at the time. Happy
In my BIOS, the Onboard or usb Cd drive is the first option in my boot order, but i cant choose anything to do with a DVD drive. Would this be why the Windows CD wont boot? When I start my comp with the DVD in the DVD drive, It does not prompt me to press any key to boot from CD. Instead, it adds Windows XP Setup to my MBR. PS: I can boot a Linux Live CD. I also have an XP Professional CD ROM and it gives me the same error, but boots correctly on my other custom desktop.

Collapse -
If all you want to do is erase
by dhrwfan / March 3, 2008 1:06 AM PST
Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?