Question

Can't access volumes on a home shared computer

I enabled everything i knew and i see the two hard drives on a remote computer on my simple home network, with simple file sharing, but i am told i have no permission and can't access them.

There is no password on the remote and it just refused, with a hard sound, it didn't ask for a password

Discussion is locked
Answer
Follow
Reply to: Can't access volumes on a home shared computer
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't access volumes on a home shared computer
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
Windows sharing is deeper than most think.

For example the share to "Everybody" confounds most. "Everybody" is defined as "accounts on this PC." This got worse with the email login on W10. So to get this working you may enable the Guest account (how, what is on google searches.)

And you never dismiss logging onto the remote computer locally with the account you use on your other PC. I find this step to be missing most of the time and folk new to Windows networking ignoring this step.

- Collapse -
I want full control, not Guest

I want full control over the remote Fujitsu, so i guess a Guest account won't do
I don't understand the english, what does it mean "dismiss logging onto the remote computer locally with the account you use on your other PC", do you mean i have to give the user name and pass. of the remote comp?

- Collapse -
I see this is confusing to some.

In Windows networking "Everyone" is everyone with an account on that "server." Since this is not Windows Server things are done differently. The Guest account in Windows networking enables access without the user account on the "server."

It has nothing to do with full control. That's what the ACL (access control list) does.

As to your last question, no. Until you get a grip on how Windows Networking deals with accounts and restrictions you may be lost for a bit. There are many articles on the web but here I keep it short.

Again. New networkers somehow balk at the idea they need to login to the server ON THE SERVER. Not remotely. And using the account they use on the remote client. Even if that means creating an account on the server.

It's a shame that Microsoft ditched the HomeGroup.

- Collapse -
PS. Beyond the Windows networking.

If you enable the firewall on some routers you get this issue as well. When setting up, be sure you know your firewalls. For me I just disable till it works then re-enable and test.

- Collapse -
Guest (Visitor) account i made didn't solve

I followed the instructions and made a guest account with the name Visitor, but still don't have access from clients.
I still don't understand, to balk means to stumble, to have an obstacle, so what do you mean by "networkers somehow balk at the idea they need to login to the server ON THE SERVER. Not remotely. And using the account they use on the remote client. Even if that means creating an account on the server"
From a client trying to log into a server (my Fujitsu) i have to enter the user (or account?) name that i made on the Fujitsu, no?

- Collapse -
Sorry but I did write enable.

"enable the Guest account (how, what is on google searches.)"

As to the user name for the share, we use the username you login on the client.

So now we have two issues.

1. You did not enable the Guest account.
2. My words are not working as to how to be sure you have a good account on the server. So I'll try again. Walk to the server and login using the same name and password you do on the client. If you can't do that, create that account there. Now that you can login with your name and password on the server, then you should be good to go on the client unless there is some firewall or antivirus blocking this.

Remember I write as if this is a normal off the shelf Windows with a local login and no firewall blocking the share.

- Collapse -
Guest account enabled but still...

I looked in Local Policies and the Guest account is enabled. i didn't do it but it's so. still no access

- Collapse -
But there is no Guest account picture in Accounts section

And on typing Guest in the search box it finds almost nothing, in particular no Guest account

- Collapse -
So the firewall is off.

And these are local logins that function on both server and client.

I wonder if there's some antivirus that is on the Server or Client now as some block shares.

- Collapse -
I don't want to sound dismissive

But this area of Windows Networking is not in the help or search. Microsoft has not done a good job here leaving us to google (research) how to enable the Guest account.

But this account is not a normal account. I don't want to duplicate the web but what it does is allow access to shares for those that have no user account.

At the office we don't use this because we want more security but for home networks where the client does not want to deal with accounts this is what we enable.

To make matters worse Microsoft reversed course on HomeGroup and didn't take time to add this information into the Windows Help system.

-> So the usual causes of the share not working continue to be firewalls, antivirus suite blocks, ACL (access control list omissions) and so on. Since this list can get quite long I have to offer what the usual are and hope for more clues when I'm not there to see the machine first hand.

- Collapse -
Share button on Win 10 grayed out

I think the problem is i can't make any volume to be shared on the Win 10 comp, in the file browser, when i select the drive and select properties-->Sharing, i can't use the Share button

- Collapse -
Good find.

See new reply to your top post.

- Collapse -
Here's the Google about the Guest account.
- Collapse -
Answer
windows version on each computer?

Are they both under the Home group? I found it better to not use the Home method and use the other normal networking area to allow easier shares between windows computers, and can also access with my Linux system too.

- Collapse -
The HomeGroup is dead AFAIK.

But good question about the versions.

- Collapse -
Answer
When the Share button is greyed out.

""Sharing Wizard" was disabled in my system, and because of that, the share button was grayed out, probably it's disabled in your system too. Search in youtube for "How to Enable File Sharing in Windows 10", it shows how to do it." - From the web.

Now there is more to sharing than this. For example if someone did make a local login with no password then that won't work either. Microsoft has made a lot of changes in sharing and it does trip up folk that were used to the old no-password required system. Here's a discussion about that and more: https://www.bleepingcomputer.com/forums/t/682724/why-is-file-sharing-so-difficult/

As noted. All the ducks must be in a row. No one I know can spot which of your ducks is out of the row.

Post was last edited on May 9, 2019 8:42 AM PDT

- Collapse -
Server doesn't see clients trough WiFi but does through wire

Now another problem. the server, Win 10, the one i tried to access to, it's the Fujitsu, saw an other, important, computer called Base, that runs Win XP. i did something, i don't remember what, or maybe it happened "by itself", but now i don't see the XP from the Fujitsu when the last is on WiFi, but it does see the XP when Fujitsu is wire connected, ethernet connection.
The troubleshooter on Fujitsu didn't find the reason but said it connects with the name server, i think, but it doesn't find "Base". i see Base on the file explorer but can't access, the same problem i had till now the other way round

- Collapse -
That's a known effect of firewalls in routers.
- Collapse -
I don't think my router has a firewall

The router i got from the ISP is ADB and i don't find any firewall in it
I want to insert a picture's URL, which is on my computer but i don't succeedd

- Collapse -
It doesn't matter where it is.

You as the networker have to find it. The effect is well known but firewalls exist in a few places so you have to find it.

Another variant is called Client Isolation. You can google that one up but the effect is the same. You are very close to getting this working.

- Collapse -
on some routers

it's also called "AP Isolation". Purpose is to allow wifi connections but block them from seeing shares on other computers using the router.

- Collapse -
Thanks.

I deal with some many models that the only time I can't seem to sort it out is when I was in Asia and didn't read the language.

CNET Forums