Windows 7 forum

General discussion

Canoscan Driver

by slewslew / December 29, 2009 10:30 AM PST

I'm trying to use my dear old Canoscan N650U with my new Acer 1410, and I can't get the OS to find the driver that I downloaded from Canon didn't offer one for W7, so I downloaded the driver that's good for Windows 98 thru XP. Will that one not work for me?

Discussion is locked
You are posting a reply to: Canoscan Driver
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Canoscan Driver
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Did you try?
by R. Proffitt Forum moderator / December 29, 2009 10:39 AM PST
In reply to: Canoscan Driver

And try letting windows find one.

Collapse -
Hi, Slewslew: ... Canoscan
by Ol Rod / December 29, 2009 8:47 PM PST
In reply to: Canoscan Driver

I did not research N650U before I post, but I have Canoscan 4200f and I have basically given up on getting it to work with W7. My scanner has a feature to scan film, which I never use, but the feature is there. I read elsewhere that these film scanners interact directly with the OS in such a way that they can't work with Vista or W7. I am keeping an older system with XP that I only boot to scan and also to use an older photo editing program (MSFT. P.I.P.) that won't work with W7.
My Canon printer, iP4200 about the same age, works good with W7.
If you get any solution please post back to help me.

Collapse -
If you have Windows 7
by orlbuckeye / February 14, 2013 8:27 PM PST

Pro or Ultimate it should work in XP mode. I believe XP mode will read USB devices. The problem with devices like this (includes printers) the vendors don't go back and update drivers and concentrate of current and new devices for the current OS. Sometime you can find generic Windows drivers that do work.

Collapse -
Watch those dates? at 3+years ago.
by R. Proffitt Forum moderator / February 15, 2013 6:50 AM PST
In reply to: If you have Windows 7

This old discussion is now closed.

Collapse -
How serious are you?
by R. Proffitt Forum moderator / December 29, 2009 10:34 PM PST
In reply to: Canoscan Driver
Collapse -
by bido170 / December 29, 2009 10:37 PM PST
In reply to: Canoscan Driver

I am having the same problem with my CanoScan D1250U2F E-Mailed Canon and they told me that they will not be supporting older models in Windows7 I tried searching Windows no help. Canons answer was buy a new scanner I like the scanner and it is in perfect condition. I don't think I will be doing busness with Cannon again.


Collapse -
See post 4.
by R. Proffitt Forum moderator / December 29, 2009 11:39 PM PST
In reply to: CanoScan

And given that all the scanner makers eventually drop support are you telling everyone you won't buy a scanner again?

And did you try the software in post 4? The software is free to try.

Collapse -
Vista Driver
by TaraS_WinTeam / December 30, 2009 3:36 AM PST
In reply to: Canoscan Driver

You mentioned you tried the drivers up to XP have you tried a Vista Driver?

Collapse -
Neither Vista nor 7
by slewslew / December 31, 2009 12:03 AM PST
In reply to: Vista Driver

Canon doesn't support either Vista or W7 for the N650U. They do support the D1250U2F for Vista, but not W7.

I'm not inclined to pay $40 for the hamrick-site software when I can get a scanner for under $75.

Collapse -
I am sorry
by TaraS_WinTeam / December 31, 2009 2:31 AM PST
In reply to: Neither Vista nor 7
Collapse -
And that $40. only buys one year
by Ol Rod / December 31, 2009 3:32 AM PST
In reply to: Neither Vista nor 7

Did you notice that? I checked it enough to find my 4200f was listed and came to the same conclusion as you.

Collapse -
One year of updates.
by R. Proffitt Forum moderator / December 31, 2009 3:47 AM PST

There are solutions out there. 40 bucks is still less than most scanners.

Collapse -
going back
by TaraS_WinTeam / December 31, 2009 4:21 AM PST

You mentioned you have kept using XP to run your scanner. Are you using a multiboot or a different computer? Is this no longer an option to run it through XP?


Collapse -
Multi-Boot Same Box, separate HdD
by Ol Rod / December 31, 2009 5:38 AM PST
In reply to: going back

It just takes a moment. I have to shut down, then catch the bios at re-start, and switch HdD. As mentioned above in this thread, I also have a MSFT Picture it Publishing on that XP install, which P.I.P. does not seem to run on W7. And for any security problems I have Browser and email connections blocked in that XP, so I do all online stuff with W7.

Collapse -
Hamrick licence UNLIMITED
by pgph / February 14, 2013 1:53 PM PST

Hamrick's licence is unlimited. Free upgrades are restricted to one year.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?