Peripherals forum

General discussion

Canon PIXMA MP500 - MP Navigator 2.0 won't scan

by Stardustn / October 17, 2006 7:47 AM PDT

Windows XP on a HP pavilion a230n.....
Purchased the Canon PIXMA MP500 and I can't, nor can Canon support help me to figure out the problem.

If I use the Arc Soft Photo Studio or Scansoft Omnipage it will scan just fine, however if i go to the MP Navigator 2.0 it will not scan and a box pops up saying "the scanner driver supported by this software is not installed, install it and then retry"...

I spent over 2 hours on the phone to fix it, it was uninstalled, re-installed, started up with windows only and no other programs, downloaded driver and software from canon website, tried to extract drivers off the CD that came with it.
Does anyone know the problem or any info on how to fix?
Thanks so much

Discussion is locked
You are posting a reply to: Canon PIXMA MP500 - MP Navigator 2.0 won't scan
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Canon PIXMA MP500 - MP Navigator 2.0 won't scan
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Scanner Driver issue
by granterickson / October 20, 2006 7:24 AM PDT

I had the same problem today installing the printer with Vista RC2. Somehow my scanner got hooked up to what looked like a printer driver. It would scan fine with other problems but would not open the MP Navigator.
I actually have an MP830, but it might work for you.
1. Go into device manager and find the scanner
2. Right click and choose update driver.
3. After following the screens to select a driver yourself, from the list choose the driver that doesn't have the word inkjet in it.
My two drivers were something like Canon Inkjot MP830 and Canon MP830. When I selected the second one, it seemed to work.
I hope this helps.

Collapse -
Thank you !!
by Stardustn / October 20, 2006 11:21 AM PDT
In reply to: Scanner Driver issue

Thanks so much, I'm going to go try that now. Have a great weekend!

Collapse -
MP 830 Scanner Problems
by skaz1 / January 6, 2007 3:09 PM PST
In reply to: Thank you !!

I am having the sameproblem with the Canon MP 830 using the MP830 driver. Have you found a solution. Please advise. Thanks. SLK.

Collapse -
Spoke to technical help at Canon and
by Stardustn / January 7, 2007 3:51 AM PST

Spoke to technical help at Canon and spent two and a half hours doing and redoing everything they said but nothing helped. I called back a couple of days ago and went through most of the same thing again. Uninstall, re-install, all of it, parts of it. I was sooooo aggravated!! Bottom line Canon says its a glitch with my PC and the driver of my Canon printer. He clearly stated its my problem and nothing to do with Canon.
I can't find anyone else that can help either. I have tried and tried.
Best of luck to you with your problem!

Collapse -
PM 830 scanner prob.
by scalebldr / February 16, 2007 7:43 AM PST
In reply to: Scanner Driver issue

HI I did what you sugested,reinstalled driver, no good
I am trying to contact MSI the manuf of the motherboard mabe its something else. Any other Ideas.

I was abel to do a preview by going to cont pan, scaner camera dbl click on MP 380 but when I tryed to save the file, it when by by.

You would think Canon would be more helpful, i guess it takes us bitching on fourms to get there attention, or not.

Collapse -
Canon missing driver error
by jdstouf / March 27, 2007 1:23 PM PDT
In reply to: PM 830 scanner prob.

I has same problem with MP800R. On a new system I had installed drivers then MP Navigator. MP Navigator could not find the driver for the scanner. Turned out I needed to install IJ Network Utility (I was using wired network attach to printer. Once that was installed, then MP Navigator worked.

Collapse -
I will try that too
by Stardustn / March 28, 2007 10:14 AM PDT

Thanks I will try the IJ Network Utility and see what happens.

Collapse -
IJ Network Utility
by rob6300 / November 26, 2007 4:34 AM PST

I have looked for the IJ Network Utility and can't find it. I am having the same issue. Where can I find/get it? Thanks!

Collapse -
*** is the IJ Network Tool... ahhhh
by gifters / November 27, 2007 9:39 AM PST
In reply to: IJ Network Utility

Same here, no I've looked high, I've looked low and all I see are blank faces looking at me... does anyone have this file to share?

Collapse -
Scanner Driver Updates
by creeljlg / April 1, 2007 2:05 PM PDT
In reply to: Scanner Driver issue

I used your advise, because I sure do need some right now. I went into my device manager as you instructed, but there was no mention of a scanner driver for me to update nor a printer driver. I have been able to print to my MP830, but when scanning it locks up on the last step. I'm running Vista too. Is there anything else you could suggest?

Collapse -
Canon MP830 won't power up
by disko1 / April 17, 2007 11:28 AM PDT
In reply to: Scanner Driver Updates

For no apparent reason my Canon MP830 simply will not power up. We had some power surges the last few days but I'm hooked up through a pretty heavy duty surge suppressor. To be sure I ran several other devices off of same surge suppressor and they all worked fine. Anyhow, I unplugged the MP830 I felt more than a little stupid since it wouldn't power up but I had to do it. Plugged the power cord to different outlets just to be sure and still no power to machine. So there it is. It's about eight months old and not heavily used as it is my home office machine. I did consider that 1 of the ink tanks may be low but w/o power how can one get to the tanks since they have to position themselves while the machine is powered up? Any thoughts would be greatly appreciated. Thanks.

Collapse -
MP530 won't power up either
by ccaahh / July 12, 2007 1:59 PM PDT

Did you ever figure out the problem. My MP 530 is permanently shut down. Anyone have an idea about this?

Collapse -
If it's doing that without being plugged in to Mac/PC.
by R. Proffitt Forum moderator / July 12, 2007 2:05 PM PDT

Then it's usually a dead printer.


Collapse -
Canon MP530 Won't Power Up
by boater74-22705095918270638691994050960110 / January 1, 2009 5:40 AM PST

I tried the same procedure that was suggested for the MP830....I unplugged it for one hour. When I plugged it back in the machine was able to power up and work properly. Our power went out yesterday and I think there were probably a couple of surges as it came back on. Although I'm glad the printer is now working, I'm a little disappointed it was the only one of my devices that was affacted out of the 20+ pieces of electronic equipment I probably have plugged in. Also, for such an easy fix, it's amazing I could not find reference to this in the Canon Knowledge Base. Overall, I've been very pleased with my MP530.

Collapse -
Canon MP830 won't power up -- What worked for me
by mortonmj / August 14, 2007 12:13 AM PDT

Since I did not see anyone offering the following advice, I thought I would contribute back. I too experienced a dead MP830 and also deduced that this happended after a power surge. No matter how good of a surge protector you have, all electronics can fall victim to disruption. So, I decided to call Canon support and they apparently are aware of this dead MP830 issue and you simply need to keep the unit unplugged for 20+ minutes to allow it to fully discharge. Then mine came back to life with power.


Collapse -
MP830 won't power up after power surge- remedy worked.
by TracyDes / September 3, 2007 10:20 AM PDT

Michael - thanks so much for that simple remedy. I unplugged my all-in-one for about 20 minutes and when I plugged it back in - BINGO - it worked perfectly. I thought I was just out of 280.00 and my favorite printer. This is a good day. Much Much Thanks Tracy

Collapse -
MP830 won't power up after power surge- remedy worked.
by jobobbrown / June 11, 2008 12:08 PM PDT

Worked exactly the same for me. Electricity had gone out for a couple of minutes. I was ready to throw the MP830 in the garage with all of the other 'blown up' electronic devices I have been accumalating over the last 20 years. Thank You So Much.

Collapse -
MP830 won't power up.
by disko1 / September 3, 2007 11:46 AM PDT

I apologize for not posting my solution but I simply forgot. Anyhow, my resolution was in the interior bottom paper feed being open from when I was in there for some reason that escapes me at the moment. Maybe a jam... Yeah, it was relief co-mingled with a certain self loathing. Kidding of course, but my fix was definitely operator error. Thanks to all who posted nonetheless.

Collapse -
MP830: The Resurrection
by markjude06 / December 11, 2007 7:42 AM PST

I was furious when my MP830 crapped out from power a surge, even on an UPS/surge protector. It's a year and a day old, so canon wouldn't do jack for me. I took it to the trash and ordered a new one. After reading this, I brought back in from the garage and it worked again. Looks like my wife is getting Brother 7420 for Christmas. HA!

Collapse -
Thank you!
by EHJ3 / April 21, 2013 3:28 AM PDT

I thought I had a boat anchor, unplugged my MP830 for 20 minutes, plugged it back in...I'm back in business! Happy

Collapse -
How to Fix the scanner driver problem on the Canon Pixma
by mwcarey / June 25, 2007 5:35 AM PDT
In reply to: Scanner Driver Updates

Hi--I was also having trouble with the scanner/MP Navigator. What you have to do is uninstall everything for the Canon MP....then turn off the printer...and UNPLUG the cable that connects the printer to your computer. Now re-install both the software for the MP830 and the drivers (I was using Vista so I had to go to the website to get an updated driver & software Now, once that is completed, turn the machine back on and plug in the cord that connects the printer to your computer (this is when it automatically downloads the driver needed for the software to work- MP navigator- and the scanner) Hope this helps, I FINALLY got mine to work! YEAH!

Collapse -
Canon Pixma MP500 HELP
by aghan1 / June 27, 2007 5:49 AM PDT

I have this printer, however, I cannot find the installation CD that came with it. I want to put it on a new computer, so is there a way to download the installation CD? I have looked online, but can't seem to find what I need. Any ideas?


Collapse -
Straight from are the directions ..
by Stardustn / June 27, 2007 9:52 AM PDT
In reply to: Canon Pixma MP500 HELP

My printer is still under warranty so I called to see for sure if it can be done, she said it could and here is the info she just gave me....
click on consumer...
at the top of page click on download library...
under product menu
#1 - multifunction
#2 - inkjet
#3 - pixma mp500 then click go...
make sure pop up blocker is off then click on Drivers / Software
when the box pops up choose your windows type and then
I agree and download ...
where it says save or run click on save to desktop then close it and then she said to restart your pc and it should be ready!
I went through the steps and it looks fine to me and I specifically asked if i had to have any of my printer info and she said no.
Good luck with it!

Collapse -
MP830 Scanner button problem on XP
by nihatk / August 24, 2008 4:37 AM PDT


I have lost my MP830 scanner CD and downloaded the software from Canon site and reinstalled. But since then the "Scan" button on the printer doesn't seem to work. When I press the "Scan" and select "Save to PC" or similar from the LCD, it used to initiate the scanner software on the PC and start scanning automatically.

Does anybody have the same problem with the software from the Canon site? It seems to me that the software on the Canon site is not complete.

Does anybody here have the full MP830 installation CD?


Collapse -
You are my hero!
by stjerome08 / March 7, 2009 7:52 AM PST

I am vacationing in TN and forgot my printer. I found a guy selling a
MP830 for $80 and I offered $60 and he said yes. He had XP and I have Vista. Needless to say nothing worked.I installed his Cd and also Canon sortware. Everything worked except when I tried to scan to a PDF file. No MP Navigator. Downloaded it and got the "no connect" error. Documentation said Vista could have this propblem! Tried what you said and everything worked! The wife doesn't know the work that goes into solving these problems or the joy in finally getting it done.

Thaanks again,

Jerry K

Collapse -
Scanner Driver Updates
by sisani / July 1, 2009 5:42 PM PDT

Thanks mwcarey for that tip. It worked! Yay!!!

Collapse -
Canon MP830 scanner navigator issue
by tonychristopher / July 7, 2007 11:36 PM PDT
In reply to: Scanner Driver issue

Thank You granterickson,

I stumbled on this site,also had the Canon Mp830 scanner navigator
problem, but no more!!!

Collapse -
thanks granterickson - simple solution that worked!!!!!!
by jhumblej / May 2, 2009 6:27 PM PDT
In reply to: Scanner Driver issue

i have an mp830 and got a new vista pc - printer worked ok but mp navigator couldn't find scanner driver. your solution
saved me lots of time and angst. thanks again

Collapse -
by molly1234554 / February 12, 2011 11:46 PM PST
In reply to: Scanner Driver issue

Where do you download the scanner driver. i have an mp navigator but it says "the scanner driver supported by this software is not installed. Install it and then retry." whene ever i try to open the mp navigator

Collapse -
I use to have this same problem.
by CalifGirl00 / July 5, 2007 3:15 PM PDT

I had the same problem with my PIXMA MP530. The problem was, I had the printer plugged into a USB card I had added to my computer. When I moved the USB cord from this one, to a USB outlet that was orginial to the computer even though it was a slower 1.1 USB it worked. I had to delete the driver and the MP Navigator and do a reinstall, but after that it works great.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions

The Samsung RF23M8090SG

One of the best French door fridges we've tested

A good-looking fridge with useful features like an auto-filling water pitcher and a temperature-adjustable "FlexZone" drawer. It was a near-flawless performer in our cooling tests.