Question

Canon EOS Rebel T5

My Canon EOS Rebel T5 is having an issue. The two part mirror over the shutter sticks open, causing no picture or a half black picture. I have opened the camera to gently coax them together. That usually fixes it, but now it's happening 99% of the time. Any suggestions?

Discussion is locked
Follow
Reply to: Canon EOS Rebel T5
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Canon EOS Rebel T5
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
Answer
The T5 is pretty newish.

I'd check my purchase date and call it in to see where to send it in.

- Collapse -
Answer
Half Black Picture

.
The problem is likely the camera operator.

Put the camera in "Auto" mode and it should work properly.

You likely are taking flash pictures while in a manual mode and have the shutter speed set too fast.

(Set shutter speed to 1/60th of a second if you want to shoot flash in a manual mode.)

A common event for a camera that has a focal plane shutter; which your camera has.

...

- Collapse -
Focal Plane Shutter

CNET Forums