Cameras forum

General discussion

Canon A75 - Camera mode not working

by BoldSamurai / June 21, 2005 9:43 PM PDT

I borrowed a friends Canon A75 to take some pictures but the problem is that it doenst go to the camera mode: It always stays at the preview mode. This happens even when the knob is placed at the 'Camera' mode and not the 'Preview' mode. Any idea why it is such ?
I think the camera is some one year old.

Discussion is locked
You are posting a reply to: Canon A75 - Camera mode not working
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Canon A75 - Camera mode not working
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Slide Switch
by snapshot2 Forum moderator / June 22, 2005 12:39 AM PDT

There is a slide switch on the back of the camera, near the top right corner of the LCD screen.

You apparently have it setting on the icon that looks like a triangle. Slide it up to the icon that looks like a camera.

...
..
.

Collapse -
Slide Switch : Thank you
by BoldSamurai / July 9, 2005 6:00 PM PDT
In reply to: Slide Switch

Thank you for replying but I did mention that the switch itself wasnt working as it should. I did solve the problem though a little risky for some.
I loosened all the screws from the back side and lightly raised the plastic part. I then carefully cleaned the metal contact and the switch spring with a cotton bud using some medical spirit. Put everything back and it has been working all right ever since.
The problem was the contacts had gone a little 'dirty'.
My advise to people having the same problem is to go to the closest Canon repair center and hint them about the problem and the probable solution.

Popular Forums
icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

CNET FORUMS TOP DISCUSSION

Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?