Windows Legacy OS forum

General discussion

Cannot make USB to RS232 Adapter Cable drivers work...!!!

by SanCarlosScott / August 21, 2007 2:44 AM PDT

Very frustrating. I have an old Kenwood shortwave radio that provides computer connectivity via RS232. However, my computer only has USB. Try as I might, I cannot get the USB-Serial adapter cable drivers to install correctly in XP. I have even tried additional drivers for other makes of adapter cable with the same result. There is always an exclamation point next to the USB-to-Serial Bridge and Human Interface Device entries in Device Manager and no new COM port is apparently created/opened. Trying to update or reinstall the drivers from there only gives some useless message akin to "can't find information on hardware" or "can't find software." Until this link is functional, I cannot determine if the RS232 communication from the radio is working. Maybe a separate RS232 card is the answer. I know that compared to other problems in this forum, mine is trivial. But hey, I'm compulsive and would sure like to play with the radio on the computer. Thanks in advance for any help you can offer.

Discussion is locked
You are posting a reply to: Cannot make USB to RS232 Adapter Cable drivers work...!!!
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Cannot make USB to RS232 Adapter Cable drivers work...!!!
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
I own the Belkin, Cable2Go and other...
by R. Proffitt Forum moderator / August 21, 2007 2:54 AM PDT

Makes of this adapter. Microsoft has NEVER supplied the drivers so your method of using the Microsoft device manager should not work.

Try this. Use the drivers from it's maker.

Also, if you had the make and model I might have the link to the driver or if it's that other obscure brand I own I have the driver for that one. -> In closing there is no generic driver.


Collapse -
I have to admit, I cheaped out...
by SanCarlosScott / August 21, 2007 3:48 AM PDT
Collapse -
Try brands I used.
by R. Proffitt Forum moderator / August 21, 2007 4:00 AM PDT

I've used the Belkin, the Cable2Go with great results. The KFI you noted is not a true USB to COM port adapter but a " PDA/Modem " adapter. You can see this unit at

"NOTE: This cable is not recognized as a standard COM port which can be used by a terminal program. It can only be used for a modem or a Human Interface Device (HID)"

Sorry you have the wrong adapter.


Collapse -
Thanks for the info...
by SanCarlosScott / August 21, 2007 4:37 AM PDT
In reply to: Try brands I used.

I'll look into the Belkin and Cable2Go cables. I never quite figured out serial connections when they were all there was, but apparently I should have.

Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?