Attention: The forums will be placed on read only mode this Saturday (Oct. 20, 2018)

During this outage (6:30 AM to 8 PM PDT) the forums will be placed on read only mode. We apologize for this inconvenience. Click here to read details

Windows Legacy OS forum

General discussion

Cannot copy 7GB pst file to 32GB USB Memory stick

by kmaslowski / December 9, 2008 12:10 AM PST

Im simply trying to copy a ~7GB .pst file, albeit rather large, to a empty 32GB usb memory stick (Micro Center Branded) and get an error saying there is not enough room on the memory stick? I tried reformatting the memory stick, same issue. Tried the memory stick on a different laptop, tried copying the same 7GB file, same isue. Tried copying a smaller 3GB pst file and that works! Took back the stick and got a replacement, still same issue. Im out of ideas?? Thanks!

Discussion is locked
You are posting a reply to: Cannot copy 7GB pst file to 32GB USB Memory stick
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Cannot copy 7GB pst file to 32GB USB Memory stick
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Check that file system.
by R. Proffitt Forum moderator / December 9, 2008 12:48 AM PST

It's usually one of two things.

1. The memory stick is formatted in FAT32.
2. You put the file in the top directory and the top directory is full.

Collapse -
re: check that file system
by kmaslowski / December 9, 2008 1:40 AM PST

The memory stick is formatted Fat32 (the only option shown when I format it is WinXP) Not sure exactly what you mean when you say top directory is full? The drive is empty, nothing on it at all. Just for grins, I created a folder and tried to copy the file to the folder instead of the root of the drive, same error. Thanks for your suggestions!

Collapse -
(NT) File Size Limit For Fat32...4 GB...
by Grif Thomas Forum moderator / December 9, 2008 1:46 AM PST
Collapse -
If it's FAT32
by Jimmy Greystone / December 9, 2008 1:48 AM PST

If it's FAT32, then you're limited to file sizes UNDER 4GB. This is a filesystem limitation, and there is no way around it. You'll either have to find a tool that can format the flash drive as NTFS or use a tool like WinZip to create a multi-part archive with at least 2 parts, each under 4GB in size.

Collapse -
re: if it's fat32
by kmaslowski / December 9, 2008 3:15 AM PST
In reply to: If it's FAT32

Thanks guys! Thats it. I did find some info on how to format it NTFS. In case your wondering, under Device Mgr, expand disk drives, select the USB drive, goto properties and Policies and change it to Optimize performance. Then when you format the drive, NTFS is available.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

FALL TV PREMIERES

Your favorite shows are back!

Don’t miss your dramas, sitcoms and reality shows. Find out when and where they’re airing!