Samsung forum

General discussion

Cannot Activate Netflix On New "Smart TV"

by cadmium48 / April 1, 2011 2:08 AM PDT

I just received a 2011 Samsung PN59D8000 TV. It's great other than I cannot get the freaking Netflix App to Activate correctly.

I go through the activation process and on Netflix's end it claims it was successful, but on the TV itself it says "Sorry, this device cannot be activated".

I've talked to Netflix support and they say it's registered fine on their end. I've talked to Samsung support, who have also been less than helpful.

For background, the tv is connected to the internet fine, I've activated pandora and vudu, and can stream video though vudu and youtube apps. I can also use netflix through other devices in my house (tivo, xbox).

Also, due to some manufacturing defects, I went through 2 other "smart tv's" (though the led/lcd un55d8000 series) before this one, which were running the exact same software and both of which activated without a hitch.

So the problem seems to be specific to this app on this tv. And I have no idea why.

I'm very frustrated here, can anyone help?

Discussion is locked
You are posting a reply to: Cannot Activate Netflix On New "Smart TV"
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Cannot Activate Netflix On New "Smart TV"
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Did samsunng offer?
by R. Proffitt Forum moderator / April 1, 2011 2:19 AM PDT

The advice about firewalls and OpenDNS?

Some folk will not try such since "it worked before." I find those folk to be stuck in a can't find support zone.

Collapse -
Cannot Activate Netflix On New "Smart TV"
by Samsung_HD_Tech Samsung staff / April 1, 2011 2:37 AM PDT


I'm sorry to hear that you're having trouble activating Netflix.

If the other Apps are working and Netflix isn't, that usually points to the App itself, but that may not be the case here.

If it worked on the same model, but different TV, then it's most likely an issue with the TV itself. I'd recommend checking your options for an exchange or repair.

If you'd like, with the TV on, press and hold the EXIT button for 15 seconds, and see if you're prompted to RESET. If so, press YES and [Enter], which should put the TV back into out-of-the-box condition, and reload the firmware. Then, try connecting to the network again and try launching Netflix.


Collapse -
It Worked!
by cadmium48 / April 1, 2011 5:53 AM PDT

The resetting of the TV worked!

Thank you so much, I was pulling my hair out trying to figure it out. And as this was my third tv from my seller, I was loath to have to return another one, especially since I am happy with the picture.

But it worked and is activated! Woot.

If you have any way of talking to your tier 1 techs, you should mention the resetting trick as something to try first.

Thanks again!

Collapse -
It Worked!
by Samsung_HD_Tech Samsung staff / April 1, 2011 7:10 AM PDT
In reply to: It Worked!


Great news!

We're in different buildings, but I know a few of the fellas over there. I'll be happy to send it over.


Collapse -
Hi HD_Tech! Help, please!
by SamsugTvUser / December 11, 2011 2:49 AM PST

I got an UN46D8000, it's wonderful for me, but i can't activate my netflix account in it:
It is suppoused that after cliking the Nextflix icon for the first time the tv will ask you if you are a member of netflix (i answered YES). after that the tv will supply you with a code necessary to register the tv in netxflix website. that is my problem, the code is never produce by the tv, actually it get me (after the "yes") to a screen asking me the username and password for netflix. Sad
even if i introduce the requested info the app said it is incorrect.
i have been with samsumg a lot of hours on the phone, chat, and remote assistance (i have almost all the ticket numbers) and they never get the correct answer, we reset the tv, reset the smart hub, everything and nothing!
note: what kind of reset is that? after the reset, my password network is still there and no need to get the new firmware as i had to do when i bought it. is there a for of of reset to REALLY factory defaults?
waiting your answer ,
Please, help!

Collapse -
Some note the app has been updated.
by R. Proffitt Forum moderator / December 11, 2011 3:53 AM PST

Sorry but that's all I know about this.

Collapse -
OPENDNS blocking Netflix on SMARTTV
by Stopped_By_OpenDNS / December 15, 2011 12:15 AM PST

I had a similar issue. What I understand is the new TVs from Samsung do not require a activation code. Once I found that out I starting looking at my routing settings for my home network. I use OPENDNS for web content filtering and found that even though OPENDNS was not blocking Netflix on a WII, Xbox or computer, it was blocking it for the SMART TV. If you are using OPENDNS, you can easily verify if it is blocking your SMARTTV's access to Netflix by turning off OPENDNS in your router and testing Netflix. I have not figured out the OPENDNS filtering changes to make this work, but I know for sure it was not the TV.

I have a UND557000.

Collapse -
by SamsugTvUser / December 15, 2011 4:59 AM PST

thanks lot!
but my DNS's in my router are
Primary DNS Server :<span id="wan_primary_dns_0" class="output">
<label class="duple">Secondary DNS Server :</label><span id="wan_secondary_dns_0" class="output">
<span class="output">i dont think those are OPENDNS, or they do?
<span class="output">thanks!!!

Collapse -
"Technical Trials"?
by R. Proffitt Forum moderator / December 15, 2011 5:08 AM PST
In reply to: DNS
Collapse -
by SamsugTvUser / December 15, 2011 7:45 AM PST
In reply to: "Technical Trials"?

i have overriden the dns given to my by my provider (comcast) with (Google DNS) and nothing happened!
Please, another solution?
thanks a lot!!!!!

Collapse -
Is there any firewall in that router?
by R. Proffitt Forum moderator / December 15, 2011 8:21 AM PST
In reply to: Thanks!

Samsung has not supplied what ports to open so I turn the router firewall off.

Most of what we know is at the next link:;threadListing

And regarding netflix. From memory there are a lot of small hurdles. Such as logging into Samsung's servers before netflix will work. Then you have seen Samsung servers go down which causes no end of troubles.

While I think they are trying, my advice to Samsung is to decouple the apps from the Samsung servers NOW. Get with the program?

Collapse -
OpenDNS blocking Netflix on SmartTV
by Stopped_By_OpenDNS / December 15, 2011 9:41 AM PST
In reply to: Thanks!

I am using OPENDNS to control access to unsafe sites for my child. OpenDNS is a provider of Internet security and DNS services. I therefore cannot substitute Google DNS. Even though I am using OPENDNS, I have the settings such that I can access Netflix via WII, Xbox and computer but not my incredibly "Smart TV". Samsung may be requiring additional authentication through other sites above what WII, XBox and my computer are using. I am trying to find out what OpenDNS settings are required in order to get this Smart TV operational with NetFlix.

Collapse -
Who said the TV must use OpenDNS?
by R. Proffitt Forum moderator / December 15, 2011 9:49 AM PST
Collapse -
by SamsugTvUser / December 15, 2011 10:09 AM PST

i put the tv ip address in the DMZ of my router and nothing yet...
Please any idea?

Collapse -
DMZ will not fix this one.
by R. Proffitt Forum moderator / December 15, 2011 10:44 AM PST
In reply to: DMZ

If I knew the HDTV was wired I would suggest a manual entry of IP address, DNS, NETMASK and then it should be fine.

Collapse -
by SamsugTvUser / December 15, 2011 10:53 PM PST

yes, tv is wired and i did what you said (entering the ip, dns, netmask manually) but nothing happens. please anyone has another idea.
thanks you!!

Collapse -
Time to call it in.
by R. Proffitt Forum moderator / December 15, 2011 11:54 PM PST
In reply to: wired

Remember I can't see what you did and can't test things. This is where a tech visit can help.

Then again, imagine if you put in the OpenDNS DNS address. Your post is missing too many details.

Collapse -
Google DNS on the TV and OPENDNS on the router works
by Stopped_By_OpenDNS / December 15, 2011 10:18 AM PST

Awesome. You are correct that the TV does not have to use OPENDNS. I could not get google DNS to work before when manually overriding the DNS before on the TV. It now works for whatever reason. Could have been some other setting I overlooked. We will mark that one in the user error column. Thanks for your help.

Collapse -
Thanks for the report.
by R. Proffitt Forum moderator / December 15, 2011 10:45 AM PST

I'll add OpenDNS as a known issue in the CNET Networking Forum shortly.

Collapse -
Cannot activate Netflix App on Smart LED TV UN46ES6500
by sandichat / July 6, 2012 6:55 AM PDT

Youtube, Hulu etc. everything works, but the Netflix App does not! I tried to reset the TV by pressing and holding the Exit button - but the reset option did not appear for me. Is there any other way?

I really want to avoid the hassle of returning the TV. Would appreciate any help/tips you can provide!


Collapse -
Just checking.
by R. Proffitt Forum moderator / July 6, 2012 7:02 AM PDT

1. Date and time set.
2. The DNS is not OpenDNS and you tried the Google DNS?
3. Called Netflix support?
4. Called Samsung support?

At this point they should have asked and checked out if the firmware is current.

My bad comment is that toasters should make toast and firmware should be something the consumer should never know about.

Collapse -
by R. Proffitt Forum moderator / July 6, 2012 7:04 AM PDT
In reply to: Just checking.
Collapse -
Unable to get Netflx to work on Samsung UN55ES6150
by B-Thomas / December 24, 2012 1:41 PM PST
In reply to: Just checking.

Unable to get Netflix to work on our new Samsung unes6150. Received message "unable to connect you to Netflix". I have changed DNS settings, made sure the date/time was set. Has any progress been made to resolve these issues?

Collapse -
Yes. But why post in this discussion?
by R. Proffitt Forum moderator / December 25, 2012 2:20 AM PST

It's too unwieldy and hard here. I'm locking this old discussion and hope you can make a new and complete with network details, firmware versions new post.

Collapse -
Samsung Smart TV
by smithfield54 / October 25, 2012 8:26 AM PDT

Hello- it is now 2012 and the Smart TV's still seem to be having this problem. Mine being one of them. I was so excited and the "netflix" app was a big plus point in getting this Samsung TV. I stream netflix through a Wii and the remotes are a pain- I digress- why is this problem still persisiting.

I am in that "Stuck in I can't find support zone". Can someone please help. It is model #UN55ES6150FXZA if this leads back to the Samsung Online Brand Ambassador.

Thank you.

Collapse -
This very old discussion.
by R. Proffitt Forum moderator / October 25, 2012 10:28 AM PDT
In reply to: Samsung Smart TV
Collapse -
Same problem!!
by N3uRo / May 21, 2011 11:26 PM PDT

I have the same problem!! Black screen and it's the only app that does this. Hulu works but Netflix doesn't and I have an account that I want to use in my TV!!

Anyone has a solution? Thanks

Collapse -
Samsung Smart TV connects to Netflix now.....
by mijole1 / February 4, 2012 3:14 AM PST

I was having nearly the same problems connecting to Netflix as everyone on this thread:

-I could connect Smart TV to internet and use other Smart Hub apps but Netflix app said "You are not connected to the internet" when launched.

I don't know what changed or how it connected but here is what i did when it finally worked. It does not make a whole lot of sense but here you go:

- I did not change any settings on my 5 yr old Netgear router; I have at least 7 other devices connected via WIFI to this old router and they all work fine

-I took one tip from this thread and performed a reset by holding down the exit button for 15 seconds and clicking OK to return to factory settings; but this time when i did it; I unplugged the power cord from the TV (when i did this before i did not unplug); then of course I connected the power cord back to the back of the TV.

-Then I ran through all the setup again; it didn't take long and for some reason I did not have to re-enter my Network key or pair the QWERTY remote.

-Then something I did different during the Network authentication was changed my DNS setting from AUTO to Manuel and entered a bogus DNS server IP of;

-Then tried to continued through the network setup process and it gave me an error that it could not connect to network

-I went back to Network settings and change DNS from manual to AUTO and then went to next step; connection to my network was established

-Then the setup came to an auto setup to scan for cable tv channels; I skipped this step earlier because we have a cable box (as most do) but I let it run through the process anyways

-Once the rest of the setup process finished (time zone, daylight savings time, etc..) I lauched Smart HUB and then launched the Netflix app, then I got the 'Are you a current Netflix subscriber screen' , which means Success!

I don't know why this worked but it did and I did not change anything on my router or disable any firewalls. I hope this works for someone else.

Collapse -
You helped me!
by techsavvywife / July 31, 2012 1:02 PM PDT

I tried changing the DNS to manual, and entered the bogus IP, and somehow, darnit, Netflix is working!

Collapse -
You can activate Netflix on tv and blu rays also
by Andy1ram / February 23, 2012 6:08 AM PST

Try setting your clock and your time zone as well. Netflix requires a time zone. Netflix themselves do no realize this.
If you reset your unit to factory settings, the clock also will be reset, so set the clock again!

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


Samsung Galaxy S8's major makeover

This year's flagship phone gets a sexy new design and Bixby, a house-made digital assistant.