Windows Legacy OS forum

General discussion

Cannot acquire IP address - RPC server unavailable

by pkostrze / October 4, 2007 8:44 PM PDT

I use Earthlink DSL under Windows XP SP2.

If I boot to a UBCD and set the network to DHCP I get an IP address and can connect to the internet although ipconfig shows no IP address and network neighborhood shows "acquiring network address".

If I boot to my hard drive I cannot connect to the internet, network says "acquiring net work address", ipconfig is empty and if I try to /renew I get "RPC server is unavailable".

If I plug in the IP address obtained by the UBCD DHCP it forces a reboot and I still cannot connect to the internet - ipconfig still shows empty.

-It's not the modem because it works booting to CD, same with the cables. What would cause this and why would I connect using the boot CD but still get the "acquiring network address" message even though I have an IP already assinged by DHCP? I've searched and have gotten nothing that really matches my situation. Thanks,

Discussion is locked
You are posting a reply to: Cannot acquire IP address - RPC server unavailable
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Cannot acquire IP address - RPC server unavailable
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Can't Acquire Address
by Darton Fury / October 5, 2007 7:21 AM PDT

Make sure the workstation and RPC services are started. Check the installed network protocols. If the DHCP server was changed, "release" and then renew. Might also try downloading/running winsockfix for XP. If pinging the loopback fails, you can reset TCP/IP by entering, netsh int ip reset resetlog.txt in command prompt. Reboot and try again.

Collapse -
Can't Acquire Address
by pkostrze / October 9, 2007 1:51 AM PDT
In reply to: Can't Acquire Address

RPC was running and I could not release and renew. I ran winsockfix for xp a second time and it fixed the problem. I'm not sure why it didn't work the first time I ran it but I'm not going to argue with results. Thanks for the help.

Collapse -
Go to Administrativer Tools and start up "SERVICES"
by OCVATO / October 8, 2007 7:44 AM PDT

start services and enable the rpc server

Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


iPhone 8: Everything we know so far

This is all the iPhone 8 reports and rumors in one place. From a 5.8-inch OLED display, reports of wireless charging and even a 3D scanner for facial recognition, it's all here.