Mac OS forum

General discussion

cancel massive file copy

by brentaye / October 20, 2006 2:08 AM PDT

I need to innterupt or cancel a massive file copy, gone wrong. On an old G4 PowerMac running OS X, I was trying to move about 1600 files by drag and drop. There was a lag that somehow got me to drop on the Desktop rather than the directory I wanted. The Desktop is on a different disc, and so the move became a copy, that has been running for DAYS! I have tried "Esc" and "Cmd"-period- but they don't seem to break the process. It is tying up my mouse/GUI, so I am looking for keyboard solutions. Is MrMacFixit out there?

Discussion is locked
You are posting a reply to: cancel massive file copy
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: cancel massive file copy
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
File Copying
by mrmacfixit Forum moderator / October 20, 2006 4:52 AM PDT

If it is actually copying stuff, which I doubt after that long, I would suggest that you try Force Quitting the Finder.
Apple + Option + Esc. (oh, I just remembered, I got shouted at for telling someone that a while ago!) With any luck you will be able to relaunch the Finder.
Given that you did not win the PowerBall on Wednesday, your luck is not that good. So, if the Finder will not relaunch correctly, hold down the power button on the G4 until it shuts down.

Sit back, wipe your brow, cross your fingers and start it up again. It may take a while. All you original data should still be there as this was only a copy and not a move. You may need to tidy up the desktop of the other drive.

Let us know how you got on


Collapse -
reply to reply to file copying
by brentaye / October 20, 2006 6:33 AM PDT
In reply to: File Copying

Thank You, MrMacFixit, I have tried Force Quit on the Finder, and I have forced powerdown by holding the button 'til it shuts down, and when it starts back up the copy is still in progress. Sometimes it seems to go to sleep and I get a cursor back, but if I click on the Apple or the Edit Tool Menu or try to select the Dock, it wakes up in the copy and I get a spinning rainbow instead of a cursor. A new file gets stacked on top every minute or so, but it seems to stop while sleeping. I can't get to the Process Viewer to kill the process as the GUI seems to be tied up and it's been going for days.

Collapse -
Power Down
by mrmacfixit Forum moderator / October 20, 2006 8:51 AM PDT

I think you just put it to sleep for a while.

Hold the power button down for at least 5 seconds, if not longer, and the machine will shut down.
If that does not work, and there should be no reason why it doesn't, on the front of the G4 there are two small buttons, just below the power button.
The button on the left is slightly raised while the button on the right is indented.
Press the Left hand button ONCE. That was the reset button.

The reason for the spinning rainbow, when you select anything that has to do with the Finder, is that the Finder is stuck in this copying loop.

If all else fails, you know where the power cord is!


Collapse -
PowerDown and Reset
by brentaye / October 23, 2006 1:53 AM PDT
In reply to: Power Down

I hadn't tried the reset button, that was a good idea! I have now tried reset, which did the reset, but the copy job is still running. I forced powerdown, and pulled the power cord just to make sure. When it turns on, the job is still running.
I don't know if this is pertainent, but my clock display only updates between when one copy finishes and the next copy starts. It takes 35-40 seconds to do a copy, and at that rate it should have been done long ago. I have been turning off the monitor, maybe that is letting it sleep? At this point, it has been going for a week. If the target disk is full, the copy should stop itself, not just keep trying...

Collapse -
by mrmacfixit Forum moderator / October 23, 2006 2:53 AM PDT
In reply to: PowerDown and Reset

That hardly seems possible but I'll take your word for it.

Here is the next step.

Shut down the machine
Remove the power cord
Press the On button. (nothing will happen)
Open the side of the machine and remove the battery.
Press the CUDA button, little round button in a small metal square, ONCE.
Leave the whole thing standing for at least 20 Minutes.
Insert the battery
Shut the side door
Insert power cord and fire it up.

Now what???


Collapse -
Robust Operating System
by brentaye / October 25, 2006 2:02 AM PDT
In reply to: Wow!

OK, I powered down for about a day, pulled the powercord, pressed the ON button, pulled the battery, a lithium type, then pressed a button on a small metal square not much bigger than the button that was near the battery and between the battery and the CPU. I think that was the CUDA that you referenced. I wated a skoshi more than 20 min., probably 25, then reinstalled the battery, closed the case, plugged in the cord and powered up. The copy is still going... Is it possible to boot to safe mode and move or rename the file/files being used to recover the job?

Collapse -
by mrmacfixit Forum moderator / October 25, 2006 4:46 AM PDT

If you have done any form of hack to enable "Safe Sleep" on this machine or you are not running some form of Hibernate program, then I think you only have one course of action left.
Boot from the installation DVD/CD. If the copying is still taking place after the machine boots, pack it into a cardboard box and leave it at the end of the driveway. If the copying is not there, do an Archive and Install.
This will place a new copy of the system on the drive and you will boot from this on completion. All you data will be archived and them moved back into the correct folders.

What you are describing is very similar to Hibernate, available in Windows, but it is not found on desktop Macs.


Collapse -
Patience is a virtue
by brentaye / October 27, 2006 6:43 AM PDT
In reply to: Hmm

I don't know of any hack or ''Safe Sleep'' offhand. I've got an OSX Tiger disc, but it is on DVD. I got an external DVD +/- DLRW, but haven't been able to get the installation to run from there, although it sees the device and files. I was thinking I could copy the files to a scratch location on the harddrive and install from there. I have mislaid my original orange box of cds for OSX, so I guess I'll just try to wait it out. It has to run out of files sooner or later, right? Oh, I'll look for the original cds, but I never get lucky...

Collapse -
External Drive
by mrmacfixit Forum moderator / October 27, 2006 6:47 AM PDT
In reply to: Patience is a virtue

IF that drive is a USB one then you should be able to boot from it. I guess you were one of the unlucky ones that did not get a DVD-RAM or DVD-ROM in their G4

Start up the machine and hold down the option key until you see your choices appear. One of them should be the external drive.

You cannot copy the files the HD because you need to boot from another location to perform the install


Collapse -
Boot Choice Option
by brentaye / November 17, 2006 8:00 AM PST
In reply to: External Drive

mrmacfixit, sorry to take so long to get back, I found an upgrade CD and installed 10.1.something on one of my other hard-drives, booted to it and then went to the user/desktop/files and removed all of the files from the bad copy, emptied the trash and rebooted to my original 10.2.8.something and it is running GREAT! Many thanks for your invaluable help and advice.

Collapse -
Way to go!
by mrmacfixit Forum moderator / November 17, 2006 10:20 AM PST
In reply to: Boot Choice Option

It's always nice to have an alternative way to boot the machine as some problems cannot be fixed from the original Boot disk. But you already know that ! Happy

Glad you got back up with your original OS. You might want to consider moving to OS X 10.3.x which was a great improvement over 10.2


Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Help, my PC with Windows 10 won't shut down properly

Since upgrading to Windows 10 my computer won't shut down properly. I use the menu button shutdown and the screen goes blank, but the system does not fully shut down. The only way to get it to shut down is to hold the physical power button down till it shuts down. Any suggestions?