Peripherals forum

General discussion

Can't switch resolution on monitor

by gautrau / September 24, 2007 10:43 AM PDT

I'm having trouble switching resolution on my monitor. Specifically when a game tries to change to resolution I get a black screen with diagnal lines and have to reboot to get the resolution back. Same thing happens if I try this manually. If a game is set to the same resolution as my current settings (1680 X 1050) it works fine. See system and monitor info below. Driver appears up to date, but I don't believe it was updated for Vista.

Any help figuring out how to get games to work would be appreciated.

Monitor - BenQ FP202W 20" LCD
Windows Vista Ultimate
Dual GeForce 7900GT running in SLI mode (256 MB memory each)
ASUS A2N32-SLI Delux motherboard
AMD Athlon 64 X2 4800+


Discussion is locked
You are posting a reply to: Can't switch resolution on monitor
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't switch resolution on monitor
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Try the old trick....
by R. Proffitt Forum moderator / September 25, 2007 12:06 AM PDT

Run DXDIAG. Now click on the right most tab then click on OVERRIDE.

Try the number 60 for now.


Collapse -
No override
by gautrau / September 25, 2007 11:07 AM PDT
In reply to: Try the old trick....

Thanks for the reply. When I run DXDIAG, the right most tab is Input and there is no override to click on (or on any other tab). Am I missing something?


Collapse -
You have to click on the tabs.
by R. Proffitt Forum moderator / September 25, 2007 9:44 PM PDT
In reply to: No override

Sorry I tried to use my memory on this. Run DXDIAG, click on the More Help button and the Override button is on that screen.


Collapse -
by R. Proffitt Forum moderator / September 25, 2007 9:45 PM PDT

You may have to share all the details as asked by the words in red as well as your version of DirectX, DXDIAG and more.


Popular Forums
Computer Newbies 10,686 discussions
Computer Help 54,365 discussions
Laptops 21,181 discussions
Networking & Wireless 16,313 discussions
Phones 17,137 discussions
Security 31,287 discussions
TVs & Home Theaters 22,101 discussions
Windows 7 8,164 discussions
Windows 10 2,657 discussions


Turn up the volume with our Apple Byte sweeps!

Two lucky winners will take home the coveted smart speaker that lets Siri help you around your connected house. This sweepstake ends Feb. 25, 2018.