PC Hardware forum

General discussion

Can't select DMA

While using XP, what could potentially prohibit me from choosing DMA mode for a hard disk drive? When checking the primary and secondary channels, device 0 of both channels shows Ultra DMA Mode 2. However, device 1 of both channels shows DMA Mode if Available, and transfer mode as PIO.

Why can't I change device 1 to DMA Mode? Any ideas on what to look at?

Thanks.

Discussion is locked
You are posting a reply to: Can't select DMA
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't select DMA
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
Re: Can't select DMA

In reply to: Can't select DMA

For starters, you neglected the FORUM TIP which reads:
"Tip: If you are asking for help to troubleshoot a computer-related problem, please be sure to include all the necessary information (ie: operating system, model number, hardware, software, etc) that will help others identify your problem for a speedy resolution."

If you had supplied the make/models of motherboard or machine, I may have just told you to install the motherboard drivers and re-test. You also didn't tell all about the IDE CABLE TYPES, the jumper settings you used. Why the cable types and jumper settings matter is I fixed another one that had the master/slave jumpers on the 80 conductor cable by moving to cable select. This would be incorrect for 40 conductor cables, but right or wrong, cable select cleared it up on the 80 conductor cable.

Wish I could read more about the machine, cables, jumpers and BIOS version.

Bob

Collapse -
Re: Can't select DMA

In reply to: Re: Can't select DMA

Thanks. I know I left a lot of info out, but I just started getting into this problem and I was looking for a few hints of where to look. I won't have the details until I open up the PC.

The PC is a P3 Dell (Dimension 4100) with 2 Maxtor 80GB Ultra ATA/133 and 1 IBM 45G drive. The IBM drive is on it's own PCI external Maxtor disk controller.

I think all drives are set to cable select, per Dell's recommendation.

I'll post more info once I have it. Thanks again.

Collapse -
That's a clue.

In reply to: Re: Can't select DMA

The PCI controllers tend to be problematic and you may run into an unit now and then that will never do DMA at full tilt. The only fix I know is to dump the controller and move back to the onboard controllers.

If the drive is "external" then DMA is a non-starter since the connection may be USB, Firewire, SATA or other. Again, details are far too light to see what we can do.

If you can post gritty details, it can help.

Bob

Collapse -
Re: That's a clue.

In reply to: That's a clue.

The drive that concerns me the most is connected via the onboard controller.

I installed these drive myself several months ago and I'm 99.9% confident that at that time, all drives were set to DMA mode. Since then, I haven't changed the PC's config. I recently started experiencing slow performance with video editing so I checked DMA mode for each drive which led me to posting the question.

Collapse -
Did you?

In reply to: Re: That's a clue.

There's a MICROSOFT'ISM that you have to set it to PIO, OK your way out and then go back in and set it to DMA, then ok your way out. Some will not do this, but continue to stare at the settings. I'm unsure why they do that.

Hope this issue is yours. Easy to fix.

Bob

Collapse -
Re: That's a clue.

In reply to: Re: That's a clue.

I seem to recall a piece of triva I read about if windows (xp I think) encountered too many errors on the IDE ports it started stepping back the speed.

It did not apply to me so I said ya that's nice and moved on.

If I had an IDE device that was set to DMA and then later showed as PIO I might be wondering if windows was trying to tell me something.

Collapse -
Re: That's a clue.

In reply to: Re: That's a clue.

I have usually seen the problem you mention happen when the second drive was not set to Auto in the BIOS when it was added to the Dell. If you do this the system can't properly recognize it and sees it only as a PIO drive, if you go into the BIOS and set it to auto for the drive then it will use DMA.

Popular Forums

icon
Computer Newbies 10,686 discussions
icon
Computer Help 54,365 discussions
icon
Laptops 21,181 discussions
icon
Networking & Wireless 16,313 discussions
icon
Phones 17,137 discussions
icon
Security 31,287 discussions
icon
TVs & Home Theaters 22,101 discussions
icon
Windows 7 8,164 discussions
icon
Windows 10 2,657 discussions

GRAMMYS 2019

Here's Everything to Know About the 2019 Grammys

Find out how to watch the Grammy Awards if you don't have cable and more.