Windows Legacy OS forum

General discussion

Can't save notepad text to desktop

by Artie62 / September 15, 2008 4:46 AM PDT

I am no longer able to save notepad text documents to the desktop. They just disappear. When I try to resave them there I am told they already exist on the desktop, but I cannot acess them and they do not appear in the desktop contents list in My Computer. The desktop is not overcrowded - there is space for new icons.

Thank you for any suggestions.

Discussion is locked
You are posting a reply to: Can't save notepad text to desktop
The posting of advertisements, profanity, or personal attacks is prohibited. Please refer to our CNET Forums policies for details. All submitted content is subject to our Terms of Use.
Track this discussion and email me when there are updates

If you're asking for technical help, please be sure to include all your system info, including operating system, model number, and any other specifics related to the problem. Also please exercise your best judgment when posting in the forums--revealing personal information such as your e-mail address, telephone number, and address is not recommended.

You are reporting the following post: Can't save notepad text to desktop
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Collapse -
by R. Proffitt Forum moderator / September 15, 2008 4:48 AM PDT

"they do not appear in the desktop contents list in My Computer."

Try clicking Start, Run and DESKTOP. Press enter and see if they are there.

Collapse -
Desktop text files
by Artie62 / September 15, 2008 5:14 AM PDT
In reply to: try

Thanks - I did as you suggested, but the list of desktop contents was the same as I saw through My Computer - without the lost notepad files I saved there.

Collapse -
So the lesson is?
by R. Proffitt Forum moderator / September 15, 2008 6:18 AM PDT
In reply to: Desktop text files

Save somewhere else? Remember that XP has that desktop cleanup feature so why chance it?

Collapse -
Lets see if they are hdden.
by MarkFlax Forum moderator / September 15, 2008 6:21 AM PDT
In reply to: Desktop text files

Although I can't see how they should be...

Do the same as before, Start > Run > Desktop, and when the explorer window displays, goto Tools > Folder options, then the View tab. Make sure the "Show hidden files and folders" is selected, and the "Hide extensions for known file types" is not selected. If it is, change it to the one below, "Show hidden files and folders".

Also, for this exercise only, remove the selection for "Hide protected operating system files, (Recommended)". Accept the warning note, then click Apply then OK.

Do these files appear now?

If so, one of those "hide" settings is hiding them. You should re-select the "Hide protected operating system files" again after the test.

Just to confirm, when you save a txt file, you do give it a file name, and the .txt file extension?


Collapse -
Hidden desktop files
by Artie62 / September 15, 2008 6:45 AM PDT

Thank you!
I did as advised. One previously unseen file saved to the desktop WAS there, but I had already successfully saved it there - after saving it to My Documents, it was then also savable to the desktop.

I give the text file a name prior to saving, but allow the extention to be added automatically.

Collapse -
If Notepad says it already exists ...
by Kees Bakker / September 15, 2008 6:51 AM PDT
In reply to: Hidden desktop files

the most likely interpretation is that it does. Somewhere.

So use Windows Explorer or My Computer or the command prompt (dir \myfile.txt /s /h - substitute the correct filename) to find it.

Doing this a few minutes after midnight or first thing in the morning, you can search for files created "today" also. That might even be easier. Be sure to include hidden files.


Collapse -
Just a thought.
by MarkFlax Forum moderator / September 15, 2008 7:01 AM PDT
In reply to: Hidden desktop files

Do you have two monitors? If so, are they both switched on?

It's just an off chance, but I have a two monitor setup where my Desktop extends across to the 2nd monitor. If I turn that monitor off, (physically), the display on the primary monitor looks standard, but the icons I display on the 2nd monitor are still there. I just can't see them.


Collapse -
Two monitors
by Artie62 / September 15, 2008 7:09 AM PDT
In reply to: Just a thought.

No, I don't have two monitors - I never heard of two being used at once with the same computer.

Collapse -
OK, but just double check,
by MarkFlax Forum moderator / September 15, 2008 7:27 AM PDT
In reply to: Two monitors

No, I'm not doubting your eyesight, Happy

Before I got my own 2nd monitor, and before I knew much at all about computers, someone played a trick on me once.

Unknown to me he opened Display Properties on my computer, (Control Panel > Display, or right click any empty part of the Desktop, select Properties), then the Settings tab, highlighted the 2nd monitor icon and selected the "Extend my Windows desktop onto this monitor". He then somehow pushed a couple of files across to the right and they disappeared off the Primary. It took me ages to work it out.

I'm not saying that this has been done to you, but as we are clutching at straws here, it maybe worth a try.

Another thing you can try is this. Try and save another Notepad file to your desktop. Give it a full name, like testfile.txt, then in the Save as type; box, use the pull down arrow to select "All files". This should display all the files listed on your Desktop. Do those missing files appear there?


Collapse -
Saving Notepad files to desktop
by Artie62 / September 16, 2008 3:44 AM PDT

Thanks for the suggestions. After making some recommended changes in my settings, I'm now able to save files successfully.

Collapse -
That's great.
by MarkFlax Forum moderator / September 16, 2008 5:39 AM PDT

Well done Artie62.

It would be good if you could say what you did to resolve the issue. This is not something we come across often, and knowing a possible solution for future members may be helpful.

Anyway, congratulations.


Collapse -
Saving text files to desktop
by Artie62 / September 16, 2008 6:04 AM PDT
In reply to: That's great.

I believe what did it was Start > Run > Desktop; then Tools > folder options > View; and checking "show hidden files and folders."

Collapse -
(NT) OK, thanks for that.
by MarkFlax Forum moderator / September 16, 2008 7:01 AM PDT
Popular Forums
Computer Help 51,912 discussions
Computer Newbies 10,498 discussions
Laptops 20,411 discussions
Security 30,882 discussions
TVs & Home Theaters 21,253 discussions
Windows 10 1,672 discussions
Phones 16,494 discussions
Windows 7 7,855 discussions
Networking & Wireless 15,504 discussions


iPhone 8: Everything we know so far

This is all the iPhone 8 reports and rumors in one place. From a 5.8-inch OLED display, reports of wireless charging and even a 3D scanner for facial recognition, it's all here.