General discussion

Can't ping 1 computer on network, all access in Network Neig

Okay gurus, I NEED HELP!

I have a network consisting of 3 computers, all linked through a Linksys router. One computer uses Windows Media Center, the other two use Windows XP. All computers run with ZoneAlarm.

My main computer cannot be pinged, yet can ping the other computers fine. The other 2 computers can ping each other without a problem.

All computers can access each other through Network Neighborhood.

I'm trying to use a program between my main computer and another computer and it isn't working. When I tried pinging my main computer, "request timed out"

I turned ZoneAlarm off and disabled it, rebooted, and still no ping capability.

Windows Firewall is turned off all machines.

Does ANYONE have any ideas here? I'm am truly at my wit's end!

Discussion is locked

Follow
Reply to: Can't ping 1 computer on network, all access in Network Neig
PLEASE NOTE: Do not post advertisements, offensive materials, profanity, or personal attacks. Please remember to be considerate of other members. If you are new to the CNET Forums, please read our CNET Forums FAQ. All submitted content is subject to our Terms of Use.
Reporting: Can't ping 1 computer on network, all access in Network Neig
This post has been flagged and will be reviewed by our staff. Thank you for helping us maintain CNET's great community.
Sorry, there was a problem flagging this post. Please try again now or at a later time.
If you believe this post is offensive or violates the CNET Forums' Usage policies, you can report it below (this will not automatically remove the post). Once reported, our moderators will be notified and the post will be reviewed.
Comments
- Collapse -
No details = stumped.

For instance what IP address and netmask for the 2 machines that can't ping? 192.x.x.x and 255.255.255.0 is not revealing anything dangerous but you can help others see the issue.

You do know that Zonealarm can remain active even if disabled?

Bob

- Collapse -
Information...

Pingable PC #1:
IP: 192.168.1.104
Subnet: 255.255.255.0
Default Gateway: 192.168.1.1

Pingable PC #2:
IP: 192.168.1.95
Subnet: 255.255.255.0
Default Gateway: 192.168.1.1

Unpingable PC:
IP: 192.168.1.110
Subnet: 255.255.255.0
Default Gateway: 192.168.1.1

No, I did not know ZoneAlarm would remain running when you turned off the option to run at startup, then rebooted. Hmmm

- Collapse -
Since you are behind a router...

One could uninstall ZA on the unpingable PC, run WINSOCKXPFIX and try again. Also, since you have a router, there can be a firewall there, but no detail means I can't check that.

Bob

- Collapse -
Question

There is a firewall on the router. But I don't understand this. If there is a firewall on the router, and it is turned on, why aren't all of the computers equally affected.

Likewise for ZoneAlarm. All are running with ZoneAlarm.

Just curious is all...

- Collapse -
Because the router can have rules.

To block some machines and not others. I am not privy to details that matter and you do have zone alarm.

I'm calling this as normal operation given the details so far.

Bob

- Collapse -
Alrighty then

So, here's what I've done:

I turned off the router firewall.

I uninstalled ZoneAlarm.

I rebooted.

I ran WinSockXPFix.

Tried to ping (after checking IPConfig).

Request timed out.

- Collapse -
Ping by name? IP.

Sorry, the gritty details. Break it down. Does each machine ping 192.168.1.1 ?

The one that can't needs attention to wiring, drivers or "other."

Bob

- Collapse -
Gritty details are what I'm looking for!

Not a problem, cuz if I knew what you know, I'd have been troubleshooting this thing properly long ago! Now I have to ask the expert (Bob) - and thank you for your time and experience, by the way.

All computers can ping 192.168.1.1

What next? Happy

- Collapse -
In my router I have a nifty feature. I can ...

Ping from the router to the machines. I missed what router you have but that's my next step.

Also I might boot up my Linux on CD to see if there's a soft or hard issue with that machine.

Bob

- Collapse -
Router ping

Router cannot ping troublesome computer. Router pings other 2 computers fine.

I don't understand what you mean about a Linux computer from CD. I don't have a Linux computer.

- Collapse -
Ok, we have it cut down to that machine and just the link to

And from that PC to the router. The issue is clearly not the other PCs.

As to Linux, I use this to sort out if there is some hardware issue (found a similar issue with home made cables) or software. I boot up my KNOPPIX CD and repeat the ping tests.

There are smaller version such as DAMN SMALL LINUX you can get that are smaller and easy to use for the test.

bob

- Collapse -
Losing me...

I hate to show my lack of expertise, but you are losing me.

I've checked out the DAMN SMALL LINUX website, but I can't for the life of me figure out what to even download! Their FAQ says download the DSL-X.X.X.ISO, but I see quite a few of those and all sorts of different folders that mean absolutely nothing to me.

At the risk of losing your assistance, I have to ask for more specific help here!

- Collapse -
just curious...

have you tried to ping your localhost? because it might be your tcp stack that is not working thats why all your doin is not working..

- Collapse -
That's ping 127.0.0.1 but I skipped it because...

ping 192.0.1.1 worked from the failed machine to the router.

The ping from the router to the machine failed. Which puts the suspect on the machine (cables changed... not homemade.)

I do have a sneaking suspicion about the OS install but I boot my linux cd and perform that test to rule out the hardware possibility.

There is an even more remote possibility of a failed port on the router. But that's way down the possibility list. Easy to dismiss.

Bob

- Collapse -
DSL is an OS on a CD.

I hope you researched what an ISO file is, but if you didn't here's a link about it.

http://en.wikipedia.org/wiki/ISO_image

I can use CDBURNERXP to write the .ISO proper to a CDR. NO! You don't write file to the CDR, you wirte the image to the CDR. It's a very small difference.

Boot the CD and then retry the ping. If that fails, it means the IP changed or you have a hard failure. The command for linux to find our IP is...

ifconfig -a

I supply this so you can shortcut to the answer. Not as an offer to teach command line skills.

Bob

- Collapse -
Oops. Addendum. WINSOCKXPFIX?

On the failed machine I take it you uninstalled ZA and ran the winsock repair tool. I'm proceeding as if this was accomplished.

I also dropped a hint about home made cables which drew no response so I take it the cable was not home mode and has been changed out.

Bob

- Collapse -
Correct

You are correct in your assumption. I did uninstall ZoneAlarm, disabled the router firewall, then ran the WinSockXPFix tool. My IP address did change after the WinSockXPFix was run, which was noted when I did an IPConfig. When I pinged the new IP address, still request timed out.

Cables are not homemade, but have been changed out and still ping gets a request timed out on the same computer.

I have a few hours of work to push through, then will eagerly work on the Linux suggestion.

Again, thank you for your continued assistance! It is greatly appreciated!

- Collapse -
More info

Okay Bob - here's what I've now come up with.

I got DAMN SMALL LINUX, burned a bootable CD, booted from that CD, then tried to ping that computer. Request timed out.

I then did IFCONFIG -A and here's what it says:

Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packetsShocked errorsShocked droppedShocked overrunsShocked frameShocked
TX packetsShocked errorsShocked droppedShocked overrunsShocked carrierShocked
collisoinsShocked txqueuelenShocked
RX bytesShocked (0.0 B) TX bytesShocked (0.0B)

What does all that mean?

- Collapse -
Sadly it didn't put an IP on the NIC.

I was afraid of that. This is usually caused by someone turning off DHCP in the router or odd hardware or dead hardware.

We are either turning on DHCP for the test or a full disclosure of the failing machine is needed. I've skipped writing about the usual nutty motehrboard drivers and Windows OS installs but now it's coming down to that.

Maybe I missed it, but is DHCP disabled on the router?

From a linux command window (try if you can) does ping 192.168.1.1 work?

Bob

- Collapse -
Wow

This is crazy, and I don't understand a word of what you're saying anymore, but I'm still following you, believe it or not. (And that sentence makes absolutely no sense whatsoever) The fact I could even boot with that disk is a miracle in and of itself. Chuckle.

DHCP Server is enabled in my Linksys router. Max users - 5=.

I'll have to check out the ping after I get back from taking the young'uns to the dentist.

- Collapse -
Which makes me think of this quote.

Any sufficiently advanced magic is indistinguishable from technology.

Or was that vice versa.

Bob

- Collapse -
Double check my ifconfig command.
- Collapse -
I'm baaaaaaaack

When trying to ping from Linux,

Ping: Permission denied (are you root?)

ifconfig all by itself gave same as ifconfig -a

ifconfig * and ifconfig eth0 gave the following:

Events: error fetching interface info: Device not found

- Collapse -
Ok we need to be "root" Here's how on DSL.

"Also, the default user doesn't have the permission to use ping, so you have to become root by typing "sudo su -" just to make sure you can ping google.com (you can also use sudo of course). It's only a detail but I found that annoying."
http://www.linuxforums.org/reviews/damn_small_linux_3.0_review.html

Retry ifconfig and ping...

But if eth0 isn't showing up then tell me about this machine, what is it?

Bob

- Collapse -
You'll laugh at this one...

So I got a bit of work done this morning, then tried tackling the sudo su bit...

Trying to boot with Linux CD, and now for the life of me, I can't get the keyboard to work.

In answer to your earlier question, I have a Dell XPS DXPO51 with a Pentium processor. Not sure if that's all the info you were looking for in regard to that...

This baby only has USB ports for the keyboard that I can see. I've tried switching ports and still nothing. The keyboard does work regularly when I don't boot in Linux.

Any suggestions there? Aside from drinking heavily, that is...

- Collapse -
Actually attempting 2 different approaches here.

1. The linux test tells me if we have a hardware or software issue. The keyboard issue may be a BIOS setting, but it's the one that has no specific name except KEYBOARD USB LEGACY SUPPORT or similar. Same for mouse.

2. I can't find your Dell's chipset. I have a suspicion that if we were to install the motherboard chipset driver and then retest and if fail then the network card driver we would strike off another common issue. But I can't point to that since I couldn't determine what a DXPO51 is made of. It wasn't on the Dell site and the XPS has many different models with varying Intel Chipsets.

Bob

- Collapse -
Success with the keyboard

Dunno how, but now the keyboard works after a million reboots. Here's what I've come up with:

ping 192.168.1.1 comes up with:
PING 192.168.1.1 (192.168.1.1): 56 data bytes
ping: sendto: Network is unreachable

ifconfig and ifconfig -a give the same results as previous with no IP address listing.

ifconfig * and ifconfig eth0 come up with the same results as yesterday: error fetching interface information: device not found

- Collapse -
DSL didn't find the network card. So that path is ...

Dead for us. Too bad since the forces us to dive into Windows and hope a driver update will help. I need the Intel Chipset and maybe a link on Dell's website about your machine to offer which driver I would install.

As to DSL, since it didn't go, I would try PCLinuxOS next. While I prefer the Big Daddy CD, it's a big download. It may find your network card when DSL didn't.

Bob

- Collapse -
:)

Man, I wish I knew what the heck you were talking about...

Off to do some more investigating.

I will give this whole experience something though. I'm learning lotsa stuff I didn't know a couple of days ago!

- Collapse -
First one was semi-easy

Detected chipset: Intel(R) 945 Express Chipset family
Memory Controller: 82945P/PL
I/O Controller: Intel(R) 82801GH I/O controller hub (ICH7DH) SATA Controller found in AHCI mode

CNET Forums

Forum Info